WordPress.org

Ready to get started?Download WordPress

Forums

Gravatar appearing whenever I try to share on Facebook or Digg (15 posts)

  1. jschmuck2
    Member
    Posted 4 years ago #

    Kind of at a loss of what to do and this is the weirdest damn thing.

    Everytime I use one of the dynamic share buttons (or even the static ones) to try and share an article from my site, I get my Gravatar icon as the thumbnail.

    I've tried disabling any trace of Gravatars through my admin panel, making sure I'm logged out of WP.com and Gravatar, cleared my browser cache, tried different browsers and even a different computer but no matter what I do, the Gravatar still keeps appearing as a thumbnail.

    Ahhh!

    http://www.youvediedofdysentery.com

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

  3. jschmuck2
    Member
    Posted 4 years ago #

    Yessir/m'am - still no dice.

    Driving me bonkers!

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    What about resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  5. jschmuck2
    Member
    Posted 4 years ago #

    Yes, I'm afraid. If anyone visiting this thread wants to give it a show, just see what image pops up when you try to share a post on FB. That would be super.

  6. jschmuck2
    Member
    Posted 4 years ago #

    There's like, nothing even remotely gravatar associate with my site anymore....ahhhh! It's like they're chasing me.

  7. rossagrant
    Member
    Posted 4 years ago #

    Have you tried setting the head meta data for your site? This is what FB looks at when choosing a thumbnail.

    http://wiki.developers.facebook.com/index.php/Facebook_Share/Specifying_Meta_Tags

  8. dolemite
    Member
    Posted 3 years ago #

    I started having this problem as of late and It's VERY annoying.

    You know this problem with Facebook not recognizing images would be solved very quickly if this was integrated into the Custom Fields section of posts.

    This is very annoying and just adds unnecessary administrative overhead to publishing since we can't define this before publishing articles.

  9. DanMichel
    Member
    Posted 3 years ago #

    anybody figure this out?

  10. rw1
    Member
    Posted 3 years ago #

    i'd like to know also, page source shows:

    <link rel="image_src" href="http://www.gravatar.com/avatar/******default=&size=110.jpg" />

    but can't figure out where in the template it would be.

  11. rw1
    Member
    Posted 3 years ago #

    this had to do with a specific setting (Show Share Images) in the Share and Follow Plugin which could easily be unchecked:

    here is a great way to dynamically get the thumbnail versions of the featured image of your posts.

    <?php if (in_category('4') ) { the_post(); rewind_posts();
    echo '<meta property="og:title" content="' . get_the_title(get_the_ID()) . '">';
    echo '<meta property="og:image" content="' . wp_get_attachment_thumb_url( get_post_thumbnail_id( $post->ID ) ) . '" />';
    } ?>

    these meta properties are some of the properties that fb looks for when sharing.

  12. AVGoncalves
    Member
    Posted 3 years ago #

    I'm having the same problem, did you solved your problem? i'm getting crazy with this...

    rw1 where to put that code lines?

    I tried to deactivate shrare and follow but that wasn't the problem..

    thank you

  13. rw1
    Member
    Posted 3 years ago #

    Yes, im camping right now so cant go into too much detail, but put the above code in your head area of your header.php, then go to http://developers.facebook.com/tools/lint/ to refresh the version of the image Facebook has in ther cache, hope that works for ya! Post back if not!

  14. Fred Hystere
    Member
    Posted 3 years ago #

    Hey RW1, I know you're busy..but when you get a minute..I copied that code and put it in my header.php without a prob..went to that FB link you gave and typed in the address of my site http://www.fredhystere.com/. Now do I just wait 24 hrs for FB to get their act together? This whole issue has been so weird. I had zero problem with this plugin initially then all of a sudden it went haywire and on most of my posts, the G gravatar logo is all that shows on FB. So annoying. Thanks for your help.

  15. derekbeck
    Member
    Posted 3 years ago #

    I'm so happy to have found this thread! The gravatar was appearing for me too, due to the stupid share and follow setting.

    Find the "Setup share image" box, and under "Show Share Images" select "No".

    Then go to http://developers.facebook.com/tools/lint and enter in the link for each and every page on your blog that has a share button. This is the only way to force facebook to re-acquire your images for your page. Absurd, I know, but that's facebook.

    Derek
    http://www.1775thebook.com

Topic Closed

This topic has been closed to new replies.

About this Topic