WordPress.org

Ready to get started?Download WordPress

Forums

got to step 2 of installation then 2 warnings and fatal error! (3 posts)

  1. gerryf
    Member
    Posted 4 years ago #

    I got the welcome screen and after filling in the details I get to step two where it goes awol...the url refers to install.php? (with the question mark) and gives me the following message .............

    "Warning: Unknown: failed to open stream: No such file or directory in Unknown on line 0

    Warning: Unknown: failed to open stream: No such file or directory in Unknown on line 0

    Fatal error: Unknown: Failed opening required '.footer.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in Unknown on line 0 "

    what the hell does this all mean? I am a newbie of course.

  2. MichaelH
    Member
    Posted 4 years ago #

    Assuming your hosting meets the requirements for WordPress then it could mean you didn't get a complete and intact set of WordPress files uploaded to your host. I'd consider downloading a fresh copy of WordPress from the Download tab at the top of this page, then use something like 7-Zip to extract the files. Then reupload the files to your host. Review Uploading WordPress to a remote host and make sure you are using ASCII transfer mode in your FTP client.

    If you have an .htaccess file, that too could be causing the problem--rename that if necessary.

  3. gerryf
    Member
    Posted 4 years ago #

    dear Michael

    thanks so much for your swift response. I am going bonkers here.
    I re-downloaded version 2.9.1, unzipped with winrar, replaced the wp-config-sample file with the wp-config I had previously edited (the one which got me to the welcome screen the first time), renamed .htaccess file on the host to .nothtaccess and then uploaded everything with Filezilla (transfer mode ASCII) all to your instructions but, to my acute disappointment, exactly the same error happens!

    This has been a tale of woe from the beginning. My first assault on the citadel of the magical 5 minute installation hit a "Parse error" (syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in wp-config.php on line 46) which I eventually got over by ditching the authentication passwords provided by the online generator and substituting them with my own. Soemwhere around this time I also got hit with a virus threat that actually popped up when accessing wordpress own forums - called 'Exploit script injection 370'... this had to be dealt with with by downloading back all the wordpress files that were on my site in order to scan them plus change the site password before uploading them again. Until getting your advice I have been ftp'ing files entirely via windows explorer which is just not up to the task and has meant most of the time copying files manually one by one. (So Filezilla is a phenomenal improvement there at least)

    Anyway, I just needed to get all that off my chest, the 5 minute installation has taken three days so far and Im still not there!

    If you have read this far thanks, and any further advice you can give will be gratefully received

    desperate wordpresser

Topic Closed

This topic has been closed to new replies.

About this Topic