WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Googlebot triggers 404 on MySite.com/?product_variation=1234 (7 posts)

  1. apcgallery
    Member
    Posted 1 year ago #

    WordPress ver 3.5.2
    WooCommerce ver 2.0.12
    SEO Ultimate ver 7.6.1
    Google XML Sitemaps ver 3.2.9

    In the 404 monitor of SEO Ultimate, I have ~100 errors logged from Googlebot attempting to access ?product_variation=XXXX. I'm also getting errors on ?orderby=popularity (rating too), because the data currently doesn't exits.

    I would like to stop these errors from happening.

    In XML Sitemaps, the only items I have selected are pages, categories, archives, and products. No variations, no coupons.

    How should I go about this?

    I've queried for solutions involving "woocommerce" and "sitemaps"/"robots", and could hardly find anything relating to suggested exclusions or disallows. So... I'm a little lost.

    Please help! Thank you :]

    http://wordpress.org/plugins/woocommerce/

  2. apcgallery
    Member
    Posted 1 year ago #

    Could it have to do with robots.txt?
    Or perhaps something I overlooked with sitemaps?

    Surely I can't be the only person with this problem...

  3. apcgallery
    Member
    Posted 1 year ago #

    71 new errors after the weekend.

    Almost all of them are variations and orderby=popularity

    How can I block googlebot from accessing these nonexistent pages?

  4. rufiooO
    Member
    Posted 11 months ago #

    Hi apcgallery!

    Did you solve that problem?

    Same problem here. But only with "?orderby=popularity".
    600+ 404 errors in Google Webmaster Tools ...

    Please help! Thanks!

    WordPress 3.5.2
    Woocommerce Version 2.0.12
    Wordpress SEO (Yoast) Version 1.4.15
    WooCommerce Deutsch (de_DE) Version 3.0.12

  5. apcgallery
    Member
    Posted 11 months ago #

    Well, It's been a little while. I tried many things- I don't remember what worked- I don't even remember what all I tried- but I don't get those 404's anymore. If I left anything out, I'll add them on later. See if any of these work for you.

    1. Try removing popularity and rating from the dropdown all-together.
    -If you 404 on popularity, you probably will on rating too. Put this in your custom CSS. I'm not positive it keeps robots away but it keeps real visitors from 404'ing on them.

    /* Woocommerce Remove Order by Popularity and Rating */
    .orderby option[value="popularity"] {display: none;}
    .orderby option[value="rating"] {display: none;}

    2. Here are my robots.txt disallows. Again, I don't know if it helped with the 404's, but it's a pretty solid list.

    Disallow: /wp-*
    Disallow: /*.js$
    Disallow: /*.inc$
    Disallow: /*.css$
    Disallow: /*.cgi$
    Disallow: /*.wmv$
    Disallow: /*.opml$
    Disallow: /*.shtml$
    Disallow: /*.xhtml$
    Disallow: /wp-admin
    Disallow: /wp-includes
    Disallow: /wp-content/plugins
    Disallow: /wp-content/cache
    Disallow: /wp-content/themes
    Disallow: /wp-content/managewp
    Disallow: /wp-content/upgrade
    Disallow: /wp-content/w3tc-config
    Disallow: /etc
    Disallow: /include
    Disallow: /cgi-bin/
    Disallow: /trackback/
    Disallow: /templates
    Disallow: /xmlrpc.php
    Disallow: /comment-page-
    Disallow: /?product_variation=
    Disallow: /product-tag

    3. Another way to cut down on 404's (if you haven't already done so) is by adding a blacklist to your .htaccess file. This is more for security, but it cuts down on 404's by keeping hackerbots and spammerbots away.
    -The one from hackrepair.com is very good: http://pastebin.com/5Hw9KZnW

    That's all I got for now, let me know if it works out.

  6. rufiooO
    Member
    Posted 10 months ago #

    Hi apcgallery!

    Thanks for your answer and your solutions. I found another way to solve the problem.

    I realised that somehow not all products in the popularity order were shown. I found out that the popularity order is based on the "total_sales" query in woocommerce. My shop is only a catalogue - there is no possibility to buy any products. This could have been the problem.
    In \wp-content\plugins\woocommerce\classes you can find the "class-wc-query.php" here I changed

    case 'popularity' :
    $args['meta_key'] = 'total_sales';

    into:

    case 'popularity' :
    $args['meta_key'] = '';

    This is the // default - menu_order now.

    This solved my problem.

    Cheers,
    Malte

  7. apcgallery
    Member
    Posted 10 months ago #

    "Rufio! Rufio! RU! FI! OHHHHHH!"

    I couldn't resist.

    Great going. So your fix changes the popularity ordering to the default ordering?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic