WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Google Webmaster tools error: URLs not followed: Redirect error (5 posts)

  1. krimsly
    Member
    Posted 5 years ago #

    Greetings all.

    Google Analytics is reporting that URLs are not followed for my blog articles in my WordPress site URLs, and that the reason is Redirect Error. I'm not sure what would be causing these errors. I've been using the same robots.txt for months without a problem. I recently reconstructed my sitemap using gsitecrawler, and I eliminated any duplicate URLs. I'm not using the WordPress Sitemap Generator plug-in.

    Can anyone point me to what I should look at to resolve this?

    Thanks.

  2. dvlchd3
    Member
    Posted 5 years ago #

    I have this same problem with one of my sites.

    What google says:

    URLs not followed
    1 – 2 of 2
    URL: http://www.sbf-pc.com/blog
    Detail: Redirect error
    Problem Detected On: Feb 15, 2009

    URL: http://www.sbf-pc.com/disclaimer
    Detail: Redirect error
    Problem Detected On: Feb 15, 2009

    More Information:
    Redirect error

    Google was unable to completely follow the redirects from this page. Our guidelines suggest that you make every page on your site reachable from at least one static text link, so that we can access these pages easily. Below are some suggestions about using redirects:

    * Minimize the number of redirects needed to follow a link from one page to another.
    * Make sure your redirect timer is set for a relatively short period of time.
    * Avoid using meta refreshes in the <head> statement of your pages.

    Robots.txt:
    User-agent: *
    Disallow:

    This seems odd to me. Why doesn't WP not block anything from crawlers??

  3. Henry_Wink
    Member
    Posted 5 years ago #

    Try adding a trailing slash to your URLs.

    For example, in my sitemap, my URLs are like this

    http://www.onlyespadrilles.co.uk/blog/

    Note the very last "/"

  4. krimsly
    Member
    Posted 4 years ago #

    Thanks Henry, I'll try that.

  5. TheVirtualPreacher
    Member
    Posted 4 years ago #

    Did you insert the meta tag generated by Google Web Master tools in to your WordPress blog template, for site verification purposes?

    remove that meta tag and everything should come back to normal (It takes some time however. In my case this error disappeared from Google Web Master Tools, after a one week)

    If removing the meta tag from your WP template gives you a verification error, simply use the upload an HTML file option... Let me know if this worked for you...

Topic Closed

This topic has been closed to new replies.

About this Topic