WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Google Webmaster Tools can't see XML Sitemap! (10 posts)

  1. MikepFive
    Member
    Posted 1 year ago #

    WordPress version: 3.5.1
    WordPress SEO version: 1.3.4.4

    I did this: Installed WordPress SEO at http://www.cambridgemedicalenglish.co.uk and checked 'XML sitemap' button supplied by the plugin

    I expected the plugin to do this: show me XML sitemap for -http://www.cambridgemedicalenglish.co.uk/sitemap_index.xml

    And it did - Hooray!!

    I expected Webmaster Tools to find the sitemap_index.xml file there too

    But it didn't - WTF!!

    Checked my Browser again:
    http://www.cambridgemedicalenglish.co.uk/sitemap_index.xml

    Yep - looks fine

    Checked the site home (/public_html) directory using Filezilla:

    NO file called 'sitemap_index.xml' in the /public_html directory !!!

    Checked out the Forums. Found lots of information about cache/rewrite and stuff I didn't understand and stuff about 404 errors (that don't seem relevant 'cos I don't see any error messages) and so I thought I'd post this here......

    Anyone any idea what might be going wrong here ??

    Mike

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. process
    Member
    Posted 1 year ago #

    Yeah, I'd like to know a little more on this as well. I was having a few WMT issues earlier today but they seemed to clear up after adjusting my robot.txt file.

    Like you, I wasn't getting the 404's I just couldn't find WHERE the sitemap was located in my files.

    It seems like it's hosted by an independent server. Then again I've only been working with this stuff for a little more than a year so I'm not sure about that one. To me, it seems like my sitemap is on my server since the sitemap starts with my domain name.

    Where could this sitemap be?

  3. MikepFive
    Member
    Posted 1 year ago #

    stranger still, after leaving things be for more than 12hrs - now WMT can sitemap_index.xml and says indexing is 'pending'

    Why couldn't it find it last night - i've changed nothing in the meantime ??

    and even more strange, I still can't see sitemap_index.xml in the root wordpress directory using my FTP client!!

    If anyone understands this, I'd appreciate the explanation. I'm sure its at the (err) 'root' of much of the Sitemap problems in this forum

    Mike

  4. mailworm
    Member
    Posted 1 year ago #

    This happend to me when I additionally checked the boxes to ping Yahoo! & Ask.com.

    I unchecked them boxes, saved settings & my sitemap was back.

  5. nbruley
    Member
    Posted 1 year ago #

    I have a similar issue. My sitemap is visible from
    http://www.gospelriver.com/tech/sitemap_index.xml
    but not from
    http://gospelriver.com/tech/sitemap_index.xml
    (without the www)
    (This is really a subdomain mapped to a subdirectory)
    When I try to access the sitemap from the subdomain, I get an internal server error.
    But I just realized that I can submit the domain
    http://www.gospelriver.com/tech, with www, as a website for Google Webmaster Tools so I'm good to go now I guess.

  6. mailworm
    Member
    Posted 1 year ago #

    @nbruley:

    You should add the following to Your .htaccess in the next line to "Rewrite Base /" to avoid Google to index duplicate content (once via gospelriver.com and once via http://www.gospelriver.com):

    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^www\.
    RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

  7. abouttheinn
    Member
    Posted 1 year ago #

    Similar problem here - just converted a site from Drupal to WP 3.5.1 and WP SEO 1.3.4.4.

    When I submit the link for the xml sitemap to Google Webmaster Tools it tells me the link is for an html page and will not accept it unless it is reformatted in an accepted format. Sitemap looks just like the others in this thread - can be seen at http://www.historicfreeportbedandbreakfasts.com/sitemap_index.xml

    I've tried it with and without the notify Yahoo and Ask boxes ticked. No difference.

  8. nbruley
    Member
    Posted 1 year ago #

    @mailworm
    Thank you for the suggestion. When I go to http://www.gospelriver.com it looks like my browser redirects to http://gospelriver.com without www, and when I do a google search for site:www.gospelriver.com I only get the gospelriver.com/tech entries. I don't see a redirect to without the www but it must be redirecting somehow right?

    By the way, I tried to create a redirect to www for the /tech site so the sitemap would show up, but that didn't do anything, as follows:
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^gospelriver\.com/tech/$ [NC]
    RewriteRule ^(.*)$ http://www.gospelriver.com/tech/$1 [R=301,L]
    It already was set up to go to www apparently also.

    I also tried this:
    redirect 301 /tech/sitemap_index.xml "http://www.gospelriver.com/tech/sitemap_index.xml"
    but that created a redirect loop.

  9. mailworm
    Member
    Posted 1 year ago #

    @nbruley:

    OK so at this time do NOT insert the a.m. code into Your .htaccess!!! It will result in a Serer 500 error (endless redirect www>none-www>www)!

    Check WP preferences tab, first menu item there. Check whats noticed in site-url and wordpress-url.

  10. Basiq22
    Member
    Posted 1 year ago #

    Hello guys,
    i'm still very green in matters of wp and any cms or so and i don't know if this helps at all.

    I don't have file sitemap_index.xml on my ftp server but when i got to Google webmaster tools and in test/add site map i just typed sitemap_index.xml after my site name and it worked without any problems.

    I got Yahoo and Ask pings checked on.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic