WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Google Structured Data Missing Required Field Authorship Thumbnails Gone (39 posts)

  1. FidoSysop
    Member
    Posted 7 months ago #

    Greetings Everyone, I searched for this on the net and here and didnt come up with anything, so here goes.

    Apparantly within the past week or so Google has made changes to it's webmaster tools under > search appearance > structured data, I'm getting a slew of errors, actually all pages are showing this: Missing: entry-title Missing: updated. There is this verbiage on the page: This property is missing in the html markup or was not properly highlighted in the structured data markup helper. This may prevent the rich snippet from appearing. And in all six of my WordPress sites with authorship all the thumbnails are gone from Google results.

    Google release this just a few days ago: http://googlewebmastercentral.blogspot.com/2013/12/structured-data-dashboard-new-markup_12.html

    So I'm not sure if this is a WordPress or JetPack problem, or if Google mucked something up on their end. Any suggestions would be appreciated. :)

  2. FidoSysop
    Member
    Posted 7 months ago #

    Here is a screen shot of the error I'm getting.

    http://www.doc2014.com/hentry-errors.jpg

  3. FidoSysop
    Member
    Posted 7 months ago #

    Getting this on Google's Structured Data Testing tool.

    Extracted structured data
    hatom-feed
    hatom-entry:
    Error: At least one field must be set for HatomEntry.
    Error: Missing required field "entry-title".
    Error: Missing required field "updated".
    Error: Missing required hCard "author".

    Since i am running AIO Seo Pack Pro on some sites and Yoast WordPress SEO on others, and getting the same error in webmaster tools, it seems this problem came up after upgrading to WordPress 3.8.

  4. ppiekarski
    Member
    Posted 7 months ago #

    I've been running into a similar issue. However, the only errors I'm getting are:

    Error: Missing required field "updated".
    Error: Missing required hCard "author".

    I'm also using Yoast WordPress SEO. Funny thing is, this issue started on December 6, 2013, much like it did for you.

    It's all very random. I've been searching for a solution for over a week now, but nothing seems to work. I would love to know how to fix this. We're running a completely custom template.

    If I find anything, I'll be sure to come back and share it.

  5. FidoSysop
    Member
    Posted 7 months ago #

    Ppiekarski, thanks for your post. I am using Artisteer to generate my WordPress templates. Contacted Artisteer support and they sound like they didn't know what Google webmaster tools and the structured data testing tool was.

    I found that two of my sites have different front page settings and might be where the problem lies. The one that uses the default blog style home page passes the structured data testing tool test. The one that uses a static page does not.

    I should note that both of these two sites, like yours, both the
    Error: Missing required field "updated".
    Error: Missing required hCard "author".
    are still present. But thumbnails are showing in search results.

    Apparently the fields below are critical and will stop authorship thumbnail from appearing on search results.
    Error: At least one field must be set for HatomEntry.
    Error: Missing required field "entry-title".

    I'm now thinking it's a bug in WP 3.8 when using a static front page.

    Hopefully one of the WordPress staff will look into this and post their findings.

  6. ppiekarski
    Member
    Posted 7 months ago #

    That'd be great if the fix was as simple as a WP update. I'm certainly hoping. Thanks for your post. While I have nothing new to report, I'm hoping to find out more before the end of the week.

  7. FidoSysop
    Member
    Posted 7 months ago #

    Google has recently cracked down on Authorship structured data requirements.

    I'm finding that my posts that previously were displaying an authorship thumbnail in search results are no longer. The author name is showing, but not the thumbnail.

    Google is saying that missing fields will now prevent an authorship thumbnail from showing. So the data for these fields must be generated by WordPress. "Error: Missing required field "updated" and hCard "author".

    With Google being more picky about who's site they give a good rank to, this potentially could cost a lot of us our hard earned rankings.

    Anyone that's browsing this thread is welcome to run their site through this tool and see what results you get: http://www.google.com/webmasters/tools/richsnippets

    It would also be appreciated if someone from WordPress would weigh in about this problem.

  8. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Have you tested with any other themes?

    There is no WordPress staff, BTW.

  9. FidoSysop
    Member
    Posted 7 months ago #

    Even with the default WordPress theme these two errors are present: "Error: Missing required field "updated" and hCard "author".
    While before they didn't prevent authorship thumbnail from showing, they now do. So it's important to get this fixed in the next WordPress update.

  10. FidoSysop
    Member
    Posted 7 months ago #

    I should add that these were Warnings until a recent Google algorithm update. But now are showing as Errors.

  11. Aaron Courtney
    Member
    Posted 7 months ago #

    Same problem here:

    Missing: author
    Missing: entry-title
    Missing: updated

    This is clearly a WP engine problem and the development team is on the hook to fix it expeditiously I might add...

  12. FidoSysop
    Member
    Posted 7 months ago #

    I opened up a ticket with WordPress Trac and they are looking into it.

    Might want to look at the Facebook comments on this blog post.

  13. Aaron Courtney
    Member
    Posted 7 months ago #

    Thanks, that was exactly what i did as well to fix this problem. So I was totally wrong in my first post - this is a theme problem (and the class definitions of the theme), not a core WP problem.

  14. FidoSysop
    Member
    Posted 7 months ago #

    I just set this site up to test the testing tool.. http://www.fidosysop.com

    Anyway it's a bone stock WordPress 3.8 i downloaded and set up. It's failing the below home page test:

    Error: Missing required field "updated".

    And both these on it's default page.

    Error: Missing required field "updated".
    Error: Missing required hCard "author".

    Now i don't know if it's the 2014 Theme, or a Core problem. But the fact remains it's there on a default stock WordPress install.

  15. Whims
    Member
    Posted 7 months ago #

    The issue's not specific to 3.8

    I checked a couple of sites today, one is still using 3.7.1 and starting Dec 6, Google Webmaster Tools is displaying the following errors -

    Error: Missing required field "updated".
    Error: Missing required hCard "author"

    For me the blog posts are fine, however I'm getting this error for all static site pages.

    Thing is though, for something like a corporate website, static pages shouldn't have an author (as such), they are pages published by the corporate entity, not an individual author.

  16. ppiekarski
    Member
    Posted 7 months ago #

    Thing is though, for something like a corporate website, static pages shouldn't have an author (as such), they are pages published by the corporate entity, not an individual author.

    That's our problem. The site I've found this problem on is on a company website. All the individual pages don't have an author (well, they do, but we don't list it).

    I've still been unable to find a solution for this problem. Hopefully one comes up soon.

  17. FidoSysop
    Member
    Posted 7 months ago #

    I got my Atristeer theme static home page problem fixed with a single line code swap in wrappers.php, AND toggling show title on page. But all blog posts still show Error: Missing required field "updated". and also this same error comes up with a stock wp install. So I'm thinking it's a WordPress core fault of some kind.

    These were Warnings until just recently when Google cracked down on the requirements. Has anyone noticed less authorship thumbnails in searches lately? I know all of mine are gone. Still shows the author name though.

    WordPress please fix this ~ We need to start the new yesr out with a clean slate. :)

  18. ppiekarski
    Member
    Posted 6 months ago #

    The site I'm having the problem with is a business site, so not all pages need to show who the author is. I keep checking forums to find a fix, but nothing really seems to work. It seems a lot of people are running into this issue.

  19. EnderWiggin
    Member
    Posted 6 months ago #

    I just noticed that I am having the same issue, in my case missing author, entry-title and updated, so I started wondering if this is related to my blocking access to /author/ as well as other locations (/feed, /trackback) in the robots.txt file.

  20. esmi
    Forum Moderator
    Posted 6 months ago #

    @EnderWiggin: If you require assistance then, as per the Forum Welcome, please post your own topic and stop posting on existing topics. Your posts in two other, completely unrelated, theme topics have been deleted.

  21. FidoSysop
    Member
    Posted 6 months ago #

    [Comments moderated] I started this thread and are still having problems with "WordPress" and structured data. Updated is omitted by WordPress on posts, pages, categories, and tags. It would be helpful if someone would fix it!

    As i said above, this problem whacks your thumbnails from Google Authorship search entries.

    Best Wishes, Doc.

  22. omlivin
    Member
    Posted 6 months ago #

    I am sad/glad to hear I am not the only one having difficulties with this! @FidoSysop have you been able to figure out a solution? I am sorry to be adding to this forum with no new updates, but I would like to be notified if there is a solution.

    In the meantime I am still looking & will comment if I find anything!

  23. FidoSysop
    Member
    Posted 6 months ago #

    No solution that i am aware of. Guess if you want to get the benefits of Authorship don't use WordPress!

    [Comments moderated]

  24. Satyapriya
    Member
    Posted 5 months ago #

    I am having the exact same problem... What do I do?? Fido, I'm counting on you to figure this out! :D

    If I figure it out I will post the solution here.

    Good luck!

  25. Satyapriya
    Member
    Posted 5 months ago #

    I think I found the solution:

    http://fivera.net/hatom-feed-hatom-entry-error-wordpress-solution/?fb_comment_id=fbc_156814557860557_321044_185506044991408#fa20a4d27c2662

    I will test it out now and let you guys know later on if it worked for me.

  26. Satyapriya
    Member
    Posted 5 months ago #

  27. FidoSysop
    Member
    Posted 5 months ago #

    Satyapriya, yes that's the ticket for common themes with the elements that is described. I'm using Artisteer as my theme generator and it has different elements. But thanks for that update!

  28. omlivin
    Member
    Posted 5 months ago #

    Ok guys... here is an article I came across...let me know if this works for you guys!
    good luck!!

    http://websitetrafficincreaserguy.com/google-authorship-compliance-wordpress/

  29. Whims
    Member
    Posted 5 months ago #

    That is fine and removes the authorship issue for pages that do not require it, however it doesnt fix the following errors in Google Webmaster Tools for static site pages

    Error: Missing required field "updated".
    Error: Missing required hCard "author"

  30. omlivin
    Member
    Posted 5 months ago #

    I think I accidentally pasted the wrong link!
    http://fivera.net/hatom-feed-hatom-entry-error-wordpress-solution/

    this unfortunately did not work for me, however in the comments people were saying that it worked for them.

Topic Closed

This topic has been closed to new replies.

About this Topic