WordPress.org

Ready to get started?Download WordPress

Forums

Google Sitemaps and WordPress 2.3 (Please help testing) (87 posts)

  1. Arnee
    Member
    Posted 6 years ago #

    Hi,

    if you're already using WordPress 2.3, the Google Sitemaps Plugin < Version 3.0b9 will NOT work for you since it tries to access database tables which don't exist anymore. Please help me getting the new version in a stable state prior the WP 2.3 release.

    The current test release is 3.0b11. It works with WordPress 3 and uses MUCH less memory than the older versions. Please test it and report any problems so I can fix them until WP 2.3 comes out.

    Here is the download URL to the always most current version:
    http://downloads.wordpress.org/plugin/google-sitemap-generator.zip

    Thank you very much for your help! :)

  2. Geezerjim
    Member
    Posted 6 years ago #

    Arnee, just to clarify, I assume you are referring to WordPress 2.3, correct?

  3. Arnee
    Member
    Posted 6 years ago #

    Thanks, corrected ;)

  4. Bull3t
    Member
    Posted 6 years ago #

    Okay, to clarify for myself, hehe. The latest version of this plugin does work with WordPress 2.3, but still needs to be tested?

    Not really much to test though I suppose, just check whether it updates correctly and that's all we really need. If it does work then I will have to congratulate you, Arnee! Thanks for the already amazingly useful plugin.

  5. alyas2022
    Member
    Posted 6 years ago #

    I'm using the beta version of the plugin, but in each post I steel have the message: '

    WordPress database error: [Table 'name of my table.wp_post2cat' doesn't exist]
    SELECT t1.ID, t1.post_title, t1.post_date, t1.post_content, t3.display_name FROM wp_posts t1, wp_post2cat t2, wp_users t3 WHERE t1.ID=t2.post_id AND t1.post_status = 'publish' AND t1.ID != 69 AND t2.category_id IN (7) AND t2.category_id NOT IN (-9999) AND t1.post_author = t3.ID ORDER BY rand() LIMIT 5'

    Im not sur if this is due to "Google XML sitemap" but I had this message with the version 2, and when I updated to version 3, the site works fine ! but I had the error message in each post !

  6. ArneBrachhold
    Member
    Posted 6 years ago #

    @Bull3t: Well it should work. I've tested it on my and several other blogs but there are so many different configurations out there that I can't guarantee that it's working everywhere. That's why I'm asking you to check if the new version is working on your system before I declare it as "stable" :)

    @alyas2022: This error is probably not related to the Sitemaps plugin since it is not active on the front end. There is also no such database query in it so you could try to disabled all your plugins one by one to see which of them causes the error.

  7. war59312
    Member
    Posted 6 years ago #

    Hi,

    Running WordPress Version 2.2.1 and Google XML Sitemaps 3.0b11.

    When I try to view the site map:

    http://www.war59312.com/sitemap.xml

    I get:

    Error loading stylesheet: A network error occured loading an XSLT stylesheet:http://www.war59312.com/wp-content/plugins/sitemap.xsl

    I have the plug-in installed at /public_html/wp-content/plugins/google-sitemap-generator just like it is suppose to be. So the xml file is expecting the sitemap.xsl file not to be within the folder but just in the plugins directory. So moving it there and it works fine.

    Just thought I'd point that out...

    Thanks,

    Will

  8. rob1n
    Member
    Posted 6 years ago #


  9. Bull3t
    Member
    Posted 6 years ago #

    @war59312: Your sitemap looks fine to me.

    @arnee: Ah, okay, I will begin testing as soon as possible! Thanks.

  10. seanh
    Member
    Posted 6 years ago #

    Hi folks. I'm an engineer on the Google Webmaster Tools team. I noticed that the Google Sitemaps Plugin was mentioned as having problems with WordPress 2.3 on the WordPress Blog. It looks like you have things under control, but I thought I'd check in to see if there's anything we can do to help make sure this is working before 2.3 is officially released. Please let me know if we can be of assistance.

    Thanks for creating this plugin to help people benefit from Sitemaps, Arne!

    Sean

  11. Sazuka
    Member
    Posted 6 years ago #

    about the sitemap .xml , do i have to link from my blog to the .xml file so searchengines can see it? or its no need to link to it?

  12. Arnee
    Member
    Posted 6 years ago #

    @war59312 Maybe you had the plugin installed in the wp-content/plugins folder before (without an own subdirectory)? Does it work if you move the sitemap.xsl back to the sitemap plugin directory and click on "Use default" next to "Include a XSLT stylesheet"?

    @seanh: Thanks for your help! At the moment it looks very promising. If I don't receive any error reports until this evening I will set the current beta version as the new stable download.

    @Sazuka: No you don't have to link to it. Just use the integrated feature to "ping" Google if your sitemap has changed or add it at the Google Webmaster Tools.

    Thank you all for testing!

    Best regards,

    Arne

  13. Bull3t
    Member
    Posted 6 years ago #

    Wow! Nice work, Arne! You even have the support of the Google Webmaster Tools team. I have tested this version of Google Sitemaps on WordPress version 2.3 myself and have not found any errors. Thanks again.

  14. bigbluelin
    Member
    Posted 6 years ago #

    when i active it,wordpress said that:
    Plugin could not be activated because it triggered a fatal error.

    i use the version 2.3 of wordpress.

  15. I have also upgraded this plugin and WP 2.3 seems to be working just fine for me.

  16. Arnee
    Member
    Posted 6 years ago #

    @bigbluelin: What version of PHP are you using?

    @jeffr0: Great, thanks for your feedback :)

  17. Erwin
    Member
    Posted 6 years ago #

    No troubles at all here:

    http://strikdiploma.nl/sitemap.xml
    http://strikdiploma.nl/info.php

    WP 2.3, XML Sitemap Generator for WordPress 3.0.

  18. Keilya
    Member
    Posted 6 years ago #

    I'm running on 2.3 as well but whenever I upload sitemap.php to the plugins directory, the Plugins page refuses to load (so I can't even activate it). Deleting sitemap.php brings the page back. I would really like to get this plugin running since it's been a really long time when it stopped working for me.

    I've tried this only with one other plugin on my server - Akismet and the same thing happens. I think we can pretty much rule out interference from other plugins? =/

    Any ideas would be great!

  19. Arnee
    Member
    Posted 6 years ago #

    @fantasycrusader: I wrote you an email :)

  20. DonPietro
    Member
    Posted 6 years ago #

    I just upgraded to 2.3.

    When I try to activate this Sitemap plug-in, the Plug-in page goes blank and doesn't show up again until I rename or delete the Sitemap folder. It does activate however and I can view the Sitemap Options in the menu.

    When I try to activate it in combination with the Google Analyticator plugin, it will trigger a fatal error.

    Any ideas?

  21. Arnee
    Member
    Posted 6 years ago #

    Thanks to bigbluelin letting me test what went wrong :)

    The problem in this case was the memory usage of WordPress.

    Even with the Sitemaps plugin completely deleted from the system and no other active plugins, WordPress used 7.5MB of memory. Most PHP configurations allow only 8MB to be allocated, so using any other larger plugin will break the blog.

    I don't know if the memory usage of 2.3 is significantly higher than of the older releases, but I will test it out.

    Possible solution:

    Open your wp-config.php file and add:

    @ini_set("memory_limit","16M");

    That will raise the maximum amount of allowed memory, but may not work on all blogs.

  22. Arnee
    Member
    Posted 6 years ago #

    @DonPietro: is your PHP installation running as CGI? (phpinfo() output -> "Server API") and could you try to raise the memory limit with @ini_set("memory_limit","16M");

  23. DonPietro
    Member
    Posted 6 years ago #

    Not sure about the runnung as CGI thing, but I added the memory_limit like you suggested and it seems to work now.

    It did give a blank page again, but after refreshing the plug-in page still works now.

    Though, I think after I uploaded the new config.php file the UTF-8 code messed up a little.

    This is my blog btw: http://www.elperiodico.nl

    No sure why this happened since the config file is the exact same as before. Even after restoring the original one without the memory limit it's still off.

    It might not even be a conflict with Sitemaps.

    Also, when I save new option settings in the options menu, I get redirected to /wp-admin/options.php resulting in a blank page with only the 2.3 footer info.

    Again, this probably isn't a Sitemaps problem, but I just noticed it right now.

  24. DonPietro
    Member
    Posted 6 years ago #

    Every plug-in I (de)activate will result in a blank page. As in, it doesn´t return to the plugin page.

    Obviously some bigger problem is going here.

    EDIT: I restored the very original config.php from my WP version before I upgraded. The problems described above are now resolved.

    Not sure how to include the memory limit now since it messes other things up when I replace config.php.

  25. Keilya
    Member
    Posted 6 years ago #

    Hi DonPietro. The 'symtoms' you've described sounds very much like what I've had. Basically Arnee told me that WordPress was using more memory that what it was allowed, thus the page simply stops loading.

    If you would like to give this a try in wp-config.php, insert this:

    //Allow more memory.
    @ini_set("memory_limit","16M");

    Above this line:
    /* That's all, stop editing! Happy blogging. */

    Upload it and see if it makes a difference. (:

  26. DonPietro
    Member
    Posted 6 years ago #

    Fantasy,

    It does activate. But I will again get the other symptoms I described earlier (blank plug-in screen etc.) when I edit the original wp-config.php and upload it.

  27. dcaddick
    Member
    Posted 6 years ago #

    Hi,

    I have recently installed WP 2.3, along with XML Sitemap Generator for WordPress 3.0 at http://www.techagility.info and I keep getting an error:

    There was a problem writing your sitemap file. Make sure the file exists and is writable.

    I have made sure that I have the Gzip module loaded, I've installed empty files in the root - could someone please let me know how I can fix this?

    Thanks,
    DaveC

  28. Arnee
    Member
    Posted 6 years ago #

    Did you make these two files writable, via CHMOD 777 for example?

  29. DonPietro
    Member
    Posted 6 years ago #

    I got it to work right now. Even the blank page problem is gone now after I click on activate.

    I copied the original wp-config.php and added the memory limit. (@ini_set("memory_limit","16M");) After that I uploaded it and everything seems to work.

    I must have had a bad copy of wp-config or something when I added the line before.

    Anyway, thanks for the support.

  30. TabrezIqbal
    Member
    Posted 6 years ago #

    Just reporting that the latest version of Google Sitemaps plugin is installed and is working well on my upgraded worpdress 2.3 blog. No database errors were spitout by the plugin in the dashboard and Google Webmaster page reports that it successfully downloaded the sitemap file(reported [roughly] correct no of urls).

    I did not go through the sitemap.xml file in detail but on a rough glance it appeared okay to me. Great work, arnee! Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic