WordPress.org

Ready to get started?Download WordPress

Forums

Google Sitemap - Where Am I Going Wrong? (6 posts)

  1. ilovemynanny
    Member
    Posted 7 years ago #

    I have been working on this for 6 hours. Here is the message I get when I try rebuild the Google sitemap
    with Sitemap Generator current and beta versions

    "Could not write into /sitemap.xml: fopen(/sitemap.xml) [function.fopen]: failed to open stream: Operation not permitted
    Could not write into /sitemap.xml.gz: fopen(/sitemap.xml.gz) [function.fopen]: failed to open stream: Operation not permitted"

    Can you tell me what I am doing wrong?

    Thank you!

  2. jentanne
    Member
    Posted 7 years ago #

    I can tell you what needs to be done, but I don't know how to do it. You need to allow the plug in write access. That is what it says in the installtion section of the plug in download. However, I didn't need to do that, so I can't tell you how. But that must be your problem.

  3. whooami
    Member
    Posted 7 years ago #

    its trying to open and write to OR create a file and cant. Check the permissions on whatever directory it (the script) needs access to.

  4. chinado
    Member
    Posted 7 years ago #

    when i use google sitemap i can't del my post
    and i can't see any sitemap file create in my web site directory

    howsoever when i do this , i just see a blank page

    how a bother thing
    anyone can help me?

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    You have to set the permissions for whatever directory it's trying to write the sitemap into such that it can actually write the sitemap there. Without access to your account, I can't tell you how exactly you have to do that. Ask your webhost. They'll understand better.

  6. sveisko
    Member
    Posted 7 years ago #

    I have the same problem, getting the same error message. I use this plugin on some on my other blogs, and on those it works fine, but on this particular one - not.
    In the "help file", it says I could upload 2 sitemaps files, and set the permission to "writeable" (777), which I have, but still no luck.
    I have also set my .htaccess to this
    "# BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress"

    Can anyone tell me which file or directory needs to be changed to "writable"?
    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic