WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Google Sitemap Prefix Problems (3 posts)

  1. pirog
    Member
    Posted 6 years ago #

    I am having trouble getting my wordpress blog properly configured so that it will get picked up by the search engines. (The site was doing well before I updated wordpress and changed the theme.)

    In particular, I am wanting the site to have the www prefix but when I run the google sitemap plugin 2.7.1, the map it generates reads http://mysite.com instead of http://www.mysite.com.

    Here's the error message from google:

    "Paths don't match
    We've detected that you submitted your Sitemap using a URL path that includes the www prefix (for instance, http://www.example.com/sitemap.xml). However, the URLs listed inside your Sitemap don't use the www prefix (for instance, http://example.com/myfile.htm)."

    The wordpress address URL is set to http://www.mysite.com and the blog address also (under Options). Is there a default setting somewhere else that I need to change? Or something else I can do?

    Thanks in advance for your help!

    Lori

  2. pirog
    Member
    Posted 6 years ago #

    Hello again,

    I have been searching for hours for an answer to the problem with the site prefix.

    I have now set the preferred domain name prefix to the http://www.mysite.com with the Google webmaster tools.

    I have also attempted to delete the sitemap and then rebuild without any luck.

    It seems that the .htaccess file may need to be changed. I have been reading what is posted on this site about file permissions. Evidently, the .htaccess needs to be set with permissions such that WordPress can automatically generate rewrite rules.

    I am having trouble finding this file in my control panel. I see that it is there when I ftp something to my directory. But when I go into the directory files otherwise I can't find this file in the root directory where it seems to be (when I ftp).

    Does anyone know if I need to change the permissions to solve my problems? And if so how do I find the file?

    As you can see I am quite confused at this point.

    Thanks in advance for anyone who can help!

    Lori

  3. pirog
    Member
    Posted 6 years ago #

    I seem to have solved the problem.

    Here's what helped:

    1. Made sure I had the URL set to http://www.mysite.com for Options in WordPress

    2. Set the Google Webmaster Tools to the preferred domain name of http://www.mysite.com and not http://mysite.com

    3. Reset the permissions for the sitemap.xml on my server to be 666 (only the sitemap nothing else)

    4. Did not do anything with the .htaccess file at this time (That would have been my next step.) I was also considering updating the Google-sitemap-generator 2.7.1 to the new version 3.0 as another possibility.

    Hope this helps with anyone else who has a similar problem!

    Lori

Topic Closed

This topic has been closed to new replies.

About this Topic