WordPress.org

Ready to get started?Download WordPress

Forums

Google Sitemap Generator 3.0b1 - Can't generate sitemap and blank page . . . (5 posts)

  1. richeicher
    Member
    Posted 7 years ago #

    I installed the Google Sitemap Generator for WordPress 3.0b1 by Arne Brachhold. First I installed version 2.71, then the newer version 3.0b1 and I have similar issues with both.

    When I go into the options and try to manually generate the sitemap all I get is a blank screen afterwards. No sitemap is generated and I have the refresh to even see the JD-WP component again.

    I am running this on SME server 7.0 with the latest version of Joomla and the latest JD-WP component.

    Also, when I deactivate the component, then remove it (even if I reboot the server) then re-install the few settings I did manage to tweak stay changed and the sites I added are still there too.
    So it's storing that info somewhere.

    Any suggestions?
    I don't see any useful info in the logs anywhere.

    Is there another sitemap gnerator that works?
    Or a way to get this one working with my set up?

    TIA.

  2. Chris_K
    Member
    Posted 7 years ago #

    Is that the one that reminds you to disable gzip compression? If so, did you? (Options -> Reading, bottom checkbox)

  3. richeicher
    Member
    Posted 7 years ago #

    Yes, I have tried it with and without the gzip compression on and get the same results.

  4. richeicher
    Member
    Posted 7 years ago #

    New/More info.

    I have since done more reading and noticed a more current version of the beta.
    I installed 3.0b3

    I do now see an error in /var/log/messages when I try to build a sitemap.

    Oct 23 14:24:33 catpower httpd: PHP Fatal error: Call to undefined function: sefreltoabs() in /home/e-smith/files/ibays/Primary/html/components/com_jd-wp/wp-includes/template-functions-links.php on line 191

    I am starting to look at the file.
    Any suggestions?
    I really need to get this going.

  5. richeicher
    Member
    Posted 7 years ago #

    Okay, I have a working version.
    I commented out line 191 and it's working.

Topic Closed

This topic has been closed to new replies.

About this Topic