WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] google says my 404 page gives 200 (7 posts)

  1. arindra
    Member
    Posted 7 years ago #

    Hi, this is what i have in my 404.php ( using the Blix theme)
    =====================================================
    <?php get_header(); ?>

    <!-- content ................................. -->
    <div id="content">

    <h2>Error 404 – File not Found</h2>

    Sorry, but the page you were looking for could not be found.

    </div> <!-- /content -->
    <!-- SiteSearch Google -->
    <form method="get" action="http://www.google.com/custom" target="_top">
    <table border="0" bgcolor="#ffffff">
    <tr><td nowrap="nowrap" valign="top" align="left" height="32">

    <img src="http://www.google.com/logos/Logo_25wht.gif" border="0" alt="Google" align="middle"></img>

    <br/>
    <input type="hidden" name="domains" value="weblog.featuredhost.com"></input>
    <input type="text" name="q" size="20" maxlength="255" value=""></input>
    </td></tr>
    <tr>
    <td nowrap="nowrap">
    <table>
    <tr>
    <td>
    <input type="radio" name="sitesearch" value="" checked="checked"></input>
    <font size="-1" color="#000000">Web</font>
    </td>
    <td>
    <input type="radio" name="sitesearch" value="weblog.featuredhost.com"></input>
    <font size="-1" color="#000000">weblog.featuredhost.com</font>
    </td>
    </tr>
    </table>
    <input type="submit" name="sa" value="Search"></input>
    <input type="hidden" name="client" value="pub-xxxxxxxxxxxxxxxx"></input>
    <input type="hidden" name="forid" value="1"></input>
    <input type="hidden" name="channel" value="xxxxxx"></input>
    <input type="hidden" name="ie" value="ISO-8859-1"></input>
    <input type="hidden" name="oe" value="ISO-8859-1"></input>
    <input type="hidden" name="cof" value="GALT:#008000;GL:1;DIV:#336699;VLC:663399;AH:center;BGC:FFFFFF;LBGC:336699;ALC:0000FF;LC:0000FF;T:000000;GFNT:0000FF;GIMP:0000FF;FORID:1;"></input>
    <input type="hidden" name="hl" value="en"></input>
    </td></tr></table>
    </form>
    <!-- SiteSearch Google -->

    <?php get_sidebar(); ?>

    <?php get_footer(); ?>
    =======================================

    Early everything was fine , but now ... google gives " Verification Error " in its Webmaster Tools > Sitemaps options .
    Additionally it gives this message :

    We've detected that your 404 (file not found) error page returns a status of 200 in the header.

    I have checked by typing something like http://weblog.featuredhost.com/abcd which is not a real page and checked from other services that page doesnt generate a 200 header but a 404 only.
    Can anyone else shed some light on this problem ?

  2. arindra
    Member
    Posted 7 years ago #

    anyone can help ?

  3. Marcomail
    Member
    Posted 7 years ago #

    i've the same problem and i think a lot of person have this problem...you can verify the site after you have rename/delete the htaccess, but when google retrieve the verification file you have the same problem

  4. koeln
    Member
    Posted 7 years ago #

    You have to send a header before sending text.

    header ('HTTP/1.1 404 Not Found');

    You can verify your header on this page:

    http://www.rexswain.com/httpview.html

  5. Marcomail
    Member
    Posted 7 years ago #

    My header return 404 for non existent pages and 200 for the existent pages....i already check this.
    The problem is another, and i don't know how can solve it.

    GOOGLE INDEX NON-EXISTENT PAGES AND HERE NONE HAVE FIND A SOLUTION

  6. Marcomail
    Member
    Posted 7 years ago #

    up

  7. arindra
    Member
    Posted 7 years ago #

    yipppeee , this is now RESOLVED ..... the answer was in Disabling the WP Ratings plugin ... which was mentioned inanother smmilar topic , mentioned by some member Ottooo and followup by macromail :D
    thanks you 2

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags