WordPress.org

Ready to get started?Download WordPress

Forums

The Google+ plugin
Google + plugin ruins DW Minion, with FF (23 posts)

  1. hujuice
    Member
    Posted 9 months ago #

    I'm enjoying the popular theme DW Minion: http://wordpress.org/themes/dw-minion
    But if I activate the Google + Plugin a transparent layer covers all my pages. The website appears almost normal (exept for a strange horizontal border rule), but everything is inactive, because some wrong z-index.

    I have this problem with FF 24. Chrome works fine.

    I sent a corresponding message to the theme support page.

    Regards,
    HUjuice

    http://wordpress.org/plugins/google/

  2. Mike
    WPMU DEV Support Staff
    Posted 9 months ago #

    Could you send us a link to your website so we can have a look?

  3. hujuice
    Member
    Posted 9 months ago #

    I can leave the problem there for hours, not more: http://sergiovaccaro.it/
    The problem is with Firefox 24 and is produced by the <iframe name="oauth2relay1383139679" id="oauth2relay1383139679" src="https://accounts.google.com/o/oauth2/postmessageRelay?parent=http%3A%2F%2Fsergiovaccaro.it#rpctoken=635312166&forcesecure=1" style="width: 1350px; height: 1350px; position: absolute; top: -100px;"></iframe>, from the plugin.

    Changing the theme the problem goes away.
    HUjuice

  4. hujuice
    Member
    Posted 9 months ago #

    I can easily temporarily avoid the problem with FireBug.
    If I change the iframe style by adding "z-index: -100; border: 0" the problem disappear (there is also a visible border).

    I stop myself because I don't know where that iframe comes from.

    HUjuice

  5. Mike
    WPMU DEV Support Staff
    Posted 9 months ago #

    Hi again, I've just had a look and can't see a problem, have you fixed this or removed something?

    If you are still having this issue please send a screenshot highlighting it so I can have a look at your website and find it.

  6. hujuice
    Member
    Posted 9 months ago #

    I removed the plugin.

    Can you give me a time frame to re-activate it?

    If you cannot establish it, I should produce a copy of the website. Ouch, do you want so?

    HUjuice

  7. Mike
    WPMU DEV Support Staff
    Posted 9 months ago #

    I'm working for the next few hours, so if you can activate it now I'll have a look as soon as I can :-)

  8. hujuice
    Member
    Posted 9 months ago #

    The plugin is now active: http://sergiovaccaro.it/accessi-a-www-istat-it-secondo-google-analytics/
    Everything looks fine, but links and clicks are disabled because the google oauth iframe.

    Here it is the beginning of the night (10.22 pm). I will leave it there until the morning.

    Thanks,
    HUjuice

  9. Mike
    WPMU DEV Support Staff
    Posted 9 months ago #

    I'm not sure this iframe is to do with our google plugin because I can't replicate this on my site, however a conflict might be causing a problem.

    Can you try this:
    Settings > Google+ > Add scripts to my footer - Yes

    This will load our plugins scripts in the footer and might stop problems from occurring.

    What other plugins do you have that use Google in some way?

  10. hujuice
    Member
    Posted 9 months ago #

    Moving the script to the footer didn't resolv.
    I disabled any other Google related plugins (sitemap and analytics), without success.

    The iframe appears if I activate the plugin and disappear if I disable it.

    The problem is with FF only and with that theme only.

    HUjuice

  11. Mike
    WPMU DEV Support Staff
    Posted 9 months ago #

    Give me a minute, I'm going to download that theme and try it myself because I can't replicate on my test instal.

  12. Mike
    WPMU DEV Support Staff
    Posted 9 months ago #

    Ok I've installed that theme on a test site and have only our Google plugin installed and it seems to be working fine for me.

    If you disable all other plugins that you have install so you just have our Google+ plugin installed and the DW Minion theme does it still have this problem?

  13. hujuice
    Member
    Posted 9 months ago #

    You are right.
    The preblem is due also to the activation of "NextGEN Gallery by Photocrati", even if the plugin is not in use in the page. (With that theme and with FF 24).

    I think that it is a company developed plugin (not a one man exercise).
    So they could be interested to investigate.

    At this moment, your plugin is active and the NextGEN is not.
    The iframe is still there, but without sie effects.

    HUjuice

  14. Mike
    WPMU DEV Support Staff
    Posted 9 months ago #

    Is there an alternative to NextGEN that you could use?

  15. hujuice
    Member
    Posted 9 months ago #

    It is not a big problem for me.
    NextGEN has a good vitality, this is their quality.
    But there are many ways.
    HUjuice

  16. Mike
    WPMU DEV Support Staff
    Posted 9 months ago #

    Ok fair enough.

    If you are happy that our plugin isn't at fault and we've resolved this situation I'd appreciate it if you could mark this as resolved now :-)

  17. hujuice
    Member
    Posted 9 months ago #

    I cannot mark as resolved the issue.
    My wanted combination (Google+, DW-Minion and NextGEN) does not work.

    I wrote to the NextGEN authors, too.
    And I hope to have time to build a test installation for all.

    Regards,
    HUjuice

  18. hujuice
    Member
    Posted 9 months ago #

    What I did, for the moment, has been to add this custom style
    iframe[name^="oauth2relay"] {
    z-index: -100;
    border: 0
    }

    It works for me, but it is unmaintainable.
    I hope that a similar solution could be taken in the plugin structure.

    HUjuice

  19. Hi there @hujuice,

    I hope you are well today, sorry about the delay here.

    Thanks for notifying us of your temporary fix, have you heard back from the NextGen Gallery developers?

    Thank you!

    Kind Regards
    Jack.

  20. hujuice
    Member
    Posted 8 months ago #

    Hi Jack,
    no news from NextGen (http://wordpress.org/support/topic/bugged-combination-with-google-plugin-and-dw-minion-theme?replies=1).

    Anyway, since the issue is about an iframe coming from your plugin (not directly, I understood so) I think that a solution could be tested and taken inside the Google+ plugin. How NextGen or DW-minion could manage something not from them?

    Actually the involved iframe has an empty body (header only), so it hasn't any visible content, so a lower z-index should be painless for the user.
    I understand also that your plugin, as plugin, doesn't provide any style, so a similar solution could be hateful for you.

    But, what else?

    Regards,
    HUjuice

  21. J2Media
    Member
    Posted 8 months ago #

    This has been a problem for me as well. I started using the custom style provided by hujuice to "quick fix" my sites.

    But as he said, it's not a real solution to the problem.

    Please keep us posted if and WHEN a better solution is available! :)

  22. Hi guys,

    Sorry about the extreme delay here, I've pinged the lead developer and he should be checking shortly.

    I appreciate your patience here.

    Thanks!

    Kind Regards
    Jack.

  23. Hi All,

    Sorry about the delay on this post, this has been discussed with the lead developer of Google+ plugin. Though a solution can't be put within the plugin, as it will effect the frame on other themes.

    The solution needed to fix this would actually break the iframe on other themes.

    Thanks.

    Kind Regards
    Jack.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.