WordPress.org

Ready to get started?Download WordPress

Forums

Google Page Speed Defer parsing of JavaScript (10 posts)

  1. magonzalez987
    Member
    Posted 2 years ago #

    hello i was testing my site on google page speed

    and the recomendation it gives me was

    Defer parsing of JavaScript

    http://code.google.com/speed/page-speed/docs/mobile.html#DeferParsingJS

    then i keep reading and clicked on async here

    http://code.google.com/speed/page-speed/docs/rtt.html#PreferAsyncResources

    but that example code, i dont know how to implement on my site

    please help

    i want to defer this one on the list:

    http://connect.facebook.net/en_US/all.js

    http://domain.com/wp-includes/js/jquery/jquery.js?ver=1.4.4

    any help putting that code on the example, and where do i put the code?
    or is there a plugin that does that?

  2. shaileshtr
    Member
    Posted 2 years ago #

    I too have the same problem. When I test Google page speed for my webpage http://shareitto.com result shows like this :
    1.Defer parsing of JavaScript.
    2.Leverage browser caching.
    3.Use efficient css selectors.
    Can somebody reply me on how to implement these above options for my website.

  3. rickyprice
    Member
    Posted 2 years ago #

    I also have the same problem on http://adoneirhoy.com

    Not good on programming any plugin recommendation?

  4. dreamgrowers
    Member
    Posted 2 years ago #

    We also have this issue on our Infant Potty Training Site using Elimination Communication at http://ecsimplified.com. The speed test give us the yellow triangle for Defer parsing of JavaScript. Suggestions on how to handle in WordPress?

  5. weightlossninja
    Member
    Posted 2 years ago #

    Anyone figure this out yet?
    We have the same problem at http://weightlossninja.org
    1. Enable compression
    2. Leverage browser caching
    3. Enable Keep-Alive
    4. Defer parsing of JavaScript
    5. Minify JavaScript

    #1. I was told is server side, on bluehost c-panel, go to optimize website, enable compression
    #2 & 3. I was told to go here:
    http://www.askapache.com/htaccess/speed-up-sites-with-htaccess-caching.html#Apache_htaccess_caching_code
    #4. I was told
    <script src="script.js" type="text/javascript" defer="defer"></script>
    but I was hoping for some better "how to instructions"

    Kelly

  6. margje
    Member
    Posted 2 years ago #

    @dreamgrowers @weightlossninja,

    The Defer parsing of JavaScript problem at both your sites are solved. Can you please tell me (and the rest) how you did it?

    Thanks!

  7. mhamidch
    Member
    Posted 1 year ago #

    I have the same problem at a website which I manage which is http://www.idesisms.com Can anyone suggest how to fix it. @dreamgrowers @weidhtlossninja if you can reply How did you solve it , will be great

  8. weightlossninja
    Member
    Posted 1 year ago #

    I can't really remember if I did solve it or not.

    What I think I did was buy a CDN (maxCDN) (insert affiliate link here)
    :)

    once you have a CDN, like 40 bucks a year, your speed goes thru the roof
    integrate it with W3total cache and your set, my website is 95/100 speed

    eventually i'll get back to tweeking the speed more but the CDN was the shortcut I choose, hope this helps.

    ok thats my one good deed for the year :)

  9. gocreations
    Member
    Posted 1 year ago #

    cloudflare.com looks that giving a good solution in CDN....I will try that in my site.... http://gocreations.gr....i will keep you update for results...

  10. gocreations
    Member
    Posted 1 year ago #

    the 50% of my cdn is fixed....

Topic Closed

This topic has been closed to new replies.

About this Topic