WordPress.org

Ready to get started?Download WordPress

Forums

Google not indexing my blog (7 posts)

  1. Anonymous
    Unregistered
    Posted 5 years ago #

    Hi!

    I write the blog http://comunidadgeek.wordpress.com, but now I have hosted my own domain http://www.comunidadgeek.com. I exported all the contents from my first blog and imported them in my new blog. I created my sitemap and my robots.txt. Googlebot has indexed my new site, but just the new posts.
    My questions are:
    How can I make googlebot index the older posts?
    Is this because googlebot thinks the content is duplicated?
    How can I solve this?

    Thanks.

    Comunidad Geek.

  2. iridiax
    Member
    Posted 5 years ago #

    It's normal for Google not to index every page of a site, especially for new, low or no PageRank sites. Time and more incoming links should increase your number of indexed pages.

  3. iridiax
    Member
    Posted 5 years ago #

    One other thing, do you still have the same content on the old URL? If so, remove this duplicate content.

  4. Anonymous
    Unregistered
    Posted 5 years ago #

    Hi!

    Thanks for the answer. I still have the same content in the old URL, I am going to delete some posts. But now I have a bigger problem, Google had already indexed some posts, like 2 or 3, but today I checked and they are gone. (I am talking about the new URL).
    Do you know what can I do?

    Thanks.

  5. Anonymous
    Unregistered
    Posted 5 years ago #

    Hi!

    Thanks for the answer. I still have the same content in the old URL, I am going to delete some posts. But now I have a bigger problem, Google had already indexed some posts, like 2 or 3, but today I checked and they are gone. (I am talking about the new URL).
    Do you know what can I do?

    Thanks.

  6. Mr. Grim Reaper
    Member
    Posted 5 years ago #

    Well, your PageRank is based heavily on how many pages link to it, and their PageRank. Also, your old blog was probably older and got a benefit from that (unless it was only by a month or two) and you should delete your old blog, as duplicate content is a no-no.

  7. OZtwo
    Member
    Posted 5 years ago #

    I was having the same problem with Google not Indexing my site, then found the answer to have Google index my site in seconds after the fix. I wrote up something on the issue:

Topic Closed

This topic has been closed to new replies.

About this Topic