WordPress.org

Ready to get started?Download WordPress

Forums

Google Language Translator
[resolved] Google Language bar appears but disappears (17 posts)

  1. miguelgino
    Member
    Posted 10 months ago #

    Hey Author,

    I am using your plugin and added the php code in the header of my current theme it shows but disappears abruptly.

    here is the code:

    <!DOCTYPE html>
    <html <?php language_attributes(); ?>>
    <head>
    	<meta charset="<?php bloginfo('charset'); ?>">
    	<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no">
    	<title><?php wp_title('-', 1, 'right'); ?> <?php bloginfo('name'); ?></title>
    
    	<?php if(opt('favicon') != ""){ ?>
    	<link rel="shortcut icon" href="<?php eopt('favicon'); ?>"  />
    	<?php } else { ?>
    	<link rel="shortcut icon" href="<?php echo THEME_IMAGES_URI ?>/favicon.png" />
    	<?php } ?>
    	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="<?php bloginfo('rss2_url'); ?>" />
    	<link rel="alternate" type="text/xml" title="RSS .92" href="<?php bloginfo('rss_url'); ?>" />
    	<link rel="alternate" type="application/atom+xml" title="Atom 1.0" href="<?php bloginfo('atom_url'); ?>" />
    	<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    	<!--[if lt IE 9]><script src="<?php echo THEME_JS_URI ?>/html5shiv.js"></script><![endif]-->
    	<!--[if IE 8]><link rel="stylesheet" type="text/css" href="<?php echo THEME_CSS_URI ?>/ie8.css" /><![endif]-->
    
    	<!-- Theme Hook -->
    	<?php wp_head(); ?>
    </head>
    <?php echo do_shortcode('[google-translator]'); ?>
    <body>
    <?php body_class(); ?>
    </body>
    
    	<?php theme_before_header(); ?>
    
    	<?php if( opt('loader_display') == 1 ) { ?>
    		<!-- loader -->
    		<div class="wrap start_loader"></div>
    	<?php } ?>
    
    	<div id="top"></div>

    I am using the redsky theme but i am still doing it locally can you shed some light on my issue? Thanks!

    theme

    http://wordpress.org/plugins/google-language-translator/

  2. Rob Myrick
    Member
    Plugin Author

    Posted 10 months ago #

    Hi miguelgino, would you be able to provide a link to your site? I will try and help. If you don't want to post that here, just contact me here:
    http://www.studio88design.com/get-in-touch/

    Thanks!

  3. miguelgino
    Member
    Posted 10 months ago #

    Hi Rob,

    I am still running it locally..

    Thanks

  4. Rob Myrick
    Member
    Plugin Author

    Posted 10 months ago #

    Hmmm....not much I can do unless it's online. Would you be able to install on a test domain? We can tryout the plugin there in a live environment. Then I can see it, and also it might work anyway since it's in a live setting. Not sure.

    Let me know how you would like to move forward.

    Thanks, Rob

  5. miguelgino
    Member
    Posted 10 months ago #

    alright i'm gonna upload it on a test domain so you can check it out.

  6. miguelgino
    Member
    Posted 10 months ago #

    Hey Rob,

    Here it is

    testdomain/

    <!DOCTYPE html>
    <html <?php language_attributes(); ?>>
    <head>
    	<meta charset="<?php bloginfo('charset'); ?>">
    	<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no">
    	<title><?php wp_title('-', 1, 'right'); ?> <?php bloginfo('name'); ?></title>
    
    	<?php if(opt('favicon') != ""){ ?>
    	<link rel="shortcut icon" href="<?php eopt('favicon'); ?>"  />
    	<?php } else { ?>
    	<link rel="shortcut icon" href="<?php echo THEME_IMAGES_URI ?>/favicon.png" />
    	<?php } ?>
    	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="<?php bloginfo('rss2_url'); ?>" />
    	<link rel="alternate" type="text/xml" title="RSS .92" href="<?php bloginfo('rss_url'); ?>" />
    	<link rel="alternate" type="application/atom+xml" title="Atom 1.0" href="<?php bloginfo('atom_url'); ?>" />
    	<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    	<!--[if lt IE 9]><script src="<?php echo THEME_JS_URI ?>/html5shiv.js"></script><![endif]-->
    	<!--[if IE 8]><link rel="stylesheet" type="text/css" href="<?php echo THEME_CSS_URI ?>/ie8.css" /><![endif]-->
    
    	<!-- Theme Hook -->
    	<?php wp_head(); ?>
    </head>
    <body <?php body_class(); ?>>
    
    	<?php echo do_shortcode('[google-translator]'); ?>
    
    	<?php theme_before_header(); ?>
    
    	<?php if( opt('loader_display') == 1 ) { ?>
    		<!-- loader -->
    		<div class="wrap start_loader"></div>
    	<?php } ?>
    
    	<div id="top"></div>
  7. bardin
    Member
    Posted 10 months ago #

    Hi,

    I am having the same problem. Just doesn't want to show in the template.

    This might have happened after upgrading to WP3.6.1

    Here is the link: http://seoninja.co.za/dev/thebackpack/

    It's also embedded using a shortcode (php) in the template file.

  8. Rob Myrick
    Member
    Plugin Author

    Posted 10 months ago #

    Hi miguelgino, I'm viewing the source of your page by right-clicking on the black header area at top. When I do that, I notice that on line 299 there is an ending </body> tag showing up AT TOP OF THE PAGE, and then the web page continues until the end with another set of <body> tags as I would expect. I'm not sure what is going on here.

    I also see there is some text showing in this area in your header, which is unusual. Would you mind providing me a login for this test domain? I will be able to fix for you quickly at that point.

    Please contact me here: http://www.studio88design.com/get-in-touch/

    Thanks, Rob

  9. Rob Myrick
    Member
    Plugin Author

    Posted 10 months ago #

    Hi bardin, thanks for your post. As a start, please go to Settings > Google Language Translator, and toggle all of the options there (there will be some hidden options that appear when you toggle them). Then make sure you have a value set for each option, whether you use it or not.

    After that, save your settings and see if the translator appears.

    If it works, then you should be good!

    I've found that there seems to be an issue with default options being set, although the plugin seems to work after this happens. I haven't found the source of the problem yet.

    Also, if you need help, contact me on the page in the previous response, and then provide a login. I will go and take a look and fix it for you.

    Thanks, Rob

  10. Rob Myrick
    Member
    Plugin Author

    Posted 10 months ago #

    Hi bardin, I just noticed that the #google_language_translator <div> is set to display:none when viewing your page source, which means that one of the settings could be set to hide the language box.

    Please find the setting, "Show translate box?", and make sure the you have it set to "yes".

    Then let me know the status at that point.

    Thanks, Rob

  11. Rob Myrick
    Member
    Plugin Author

    Posted 10 months ago #

    Actually, I see now that you probably meant to hide the translator box, and the flags are still not showing. Sorry, my mistake.

  12. miguelgino
    Member
    Posted 10 months ago #

    Hey @Rob

    Sent you the Login details on your email,

    Thanks!

  13. bardin
    Member
    Posted 10 months ago #

    Thanks Rob.

    I managed to "fix" it my side. All I did was align the translator bar to the right (in the plugin options), then saved the settings.

    Did the trick! Appreciate your quick response and help with this.

    Thanks!!

  14. Rob Myrick
    Member
    Plugin Author

    Posted 10 months ago #

    Thanks, bardin, for the update. I'm not sure what was happening here, but I did have a small period time where the plugin was available without default options being set in the plugin, due to error on my side. Then I simply uploaded the correct file to the server without upgrading the version.

    Either way, I'm hoping that in the future, your new file properly sets all options, in all cases.

    Your posting this was helpful, as I have no real evidence of what the problem has been.

    Thanks!

  15. Rob Myrick
    Member
    Plugin Author

    Posted 10 months ago #

    Hi miguelgino, your website has a header area with position:fixed assigned to it, which means that it will sit on top of everything else and stay "fixed" there. It is currently covering the translator, so I'm going to move it to a more appropriate area for you.

    Looks like we found a solution!

    Thanks!

  16. miguelgino
    Member
    Posted 10 months ago #

    GREAT JOB! Keep it up Rob!

  17. Rob Myrick
    Member
    Plugin Author

    Posted 10 months ago #

    No problems my friend.....that's what I do man!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.