WordPress.org

Ready to get started?Download WordPress

Forums

Google is not indexing my site (5 posts)

  1. hxavio
    Member
    Posted 1 year ago #

    Hi all!

    I have a problem with my WP installation, google is not indexing correctly my blog. When I search on google my domain in the description appaers a problem with robot.txt.

    I think the problem is in the privacy settings I can save the option of indexing my site I mark the option but don't save If I click on save changes.

    Anyone has the same problem? Thanks

  2. tomontoast
    Member
    Posted 1 year ago #

    Post a link to your site and we can try to help.

  3. Your site may be too "young" as well. Sometimes Google needs a bit of time to index sites properly.

    As well as providing a link to your site as @tomontoast suggested,

    You might want to install the WordPress SEO plugin which will allow you to submit a sitemap and will tell you if there are any Google indexing issues.

  4. elkirkmo
    Member
    Posted 1 year ago #

    You might also have a conflict with your robots.txt file, which could be why your changes never get saved. Open your robots.txt file and inspect it yourself. Make sure you're not disallowing your wordpress directory.

  5. hxavio
    Member
    Posted 1 year ago #

    Thanks I have solved the problem. There was a problem with robots.txt with a plugin who has disabled the / directory.

    Thanks for your answers!

Topic Closed

This topic has been closed to new replies.

About this Topic