WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Google+ Gravatar in Comments from Jetpack (2 posts)

  1. sorensenss
    Member
    Posted 9 months ago #

    I'm using Jetpack comments and am allowing people to post from Facebook, Twitter, Google+, etc - when a user posts using Twitter or Facebook, it seems to grab their correct profile image just fine.

    When someone posts from Google+ though, I'm just getting the default avatar image next to their comments despite it showing up next to the user's name when they 'log in' to post a comment.

    Gravatar's are being output using get_avatar($comment, '68');

    http://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 8 months ago #

    I don't seem to be able to reproduce the problem on my site. Could you try to switch to one of the default themes for a few minutes, and let me know if it helps?

    Gravatar's are being output using get_avatar($comment, '68');

    That's indeed the right way to inserts Gravatars in your comments. Jetpack hooks into this filter when you comment via your Google+ account.

    You might also want to comment using a different Google+ account. While I'm not completely familiar with Google+'s privacy options, iI believe it's possible to make your profile picture private, and thus impossible to access via external services. It could be what's happening with your own Google+ account.

    Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic