WordPress.org

Ready to get started?Download WordPress

Forums

Google Forms
Google Forms v0.64 beta (10 posts)

  1. Mike Walsh
    Member
    Plugin Author

    Posted 7 months ago #

    I have been chasing an issue where checkbox support doesn't work properly and found that in some cases, where the cURL transport isn't available, checkboxes will not work with version of WordPress after 3.6.1.

    This has been a hard problem to nail down which is why there hasn't been much progress lately.

    I have a new beta release available which will warn the user when the cURL transport isn't available. At this point I do not have a solution which will work reliably when cURL isn't available.

    http://wordpress.org/plugins/wpgform/

  2. marc.lejolivet
    Member
    Posted 7 months ago #

    Hi Mike,

    I just downloaded the beta update 0.64-beta-5. Allow me to inform you that I still have two problems:

    . Checkboxes (except display the error, which doesn't appear for me, have you found a solution?)
    . WP SEO Yoast compatibility, the following error appears :

    Fatal error: Call to undefined function get_sample_permalink() in […]/plugins/wordpress-seo/admin/class-metabox.php

    I used the 3.8.1. version of WordPress.
    Thanks for your help.

    Marc
    (sorry for my english).

  3. Mike Walsh
    Member
    Plugin Author

    Posted 7 months ago #

    I need some additional information to help you out:

    1. What is the exact problem are you having with checkboxes? No response gets logged? Only last checked value gets recorded? Please elaborate.
    2. What version of PHP are you running with WoredPress 3.8.1?
    3. Do you have a message on your Google Forms settings page about the cURL transport not being available?

    If you look at the error message you posted, it is coming from the WordPress SEO plugin, not from Google Forms.

  4. marc.lejolivet
    Member
    Posted 7 months ago #

    Thank you for your quick response.

    1. For me, only last checked value gets recorded.
    2. PHP/5.2.17, I upgraded following the occurrence of the error, I was in version 3.6.
    3. No message.

    On WordPress SEO, this error has occured after 0.64beta upgrade. If I disable your plugin there are no errors.

  5. Mike Walsh
    Member
    Plugin Author

    Posted 7 months ago #

    I just installed WordPress SEO on my development site and do not experience the error you are reporting. The other thing which doesn't make sense is get_sample_permalink(), the function it is complaining about, is a built-in WordPress function.

    There has to be an error somewhere else that is manifesting itself as an error at that point.

  6. Mike Walsh
    Member
    Plugin Author

    Posted 6 months ago #

    Google Forms v0.64 has been released.

  7. jkruzonair
    Member
    Posted 6 months ago #

    My website went error 504 via cloudflare. My host told me it was the newly updated wpgform plugin that caused my site to output the error. When I deleted the plugin all of my blog post content was wiped clean with the code [wpgform id= xxxxx] in all my blog posts that I didn't even use a google form for. Please help. This is urgent and I'm kinda freaking out.

  8. Mike Walsh
    Member
    Plugin Author

    Posted 6 months ago #

    I sent an email based on the comment you left on my site, but just in case someone else runs into this, I need some more detail. I have also rolled back the stable build to 0.63 as a precaution.

    Due to a conflict with the very popular WordPress SEO plugin, I had to change how the short code was processed. Previously the plugin would try and detect on the fly when the post type was a form and would insert the appropriate short code on the fly which the short code processor would then process. In some cases, this ended up happening multiple times which was obviously a problem.

    This update to the plugin stores the shortcode for the form as the post content when the form is defined (the post editor field isn't visible when defining a form because it isn't used) upon the publish action. The plugin will also update any forms with their shortcodes as sort of a "house keeping" step. However, in both cases, the post is checked to ensure it is a Google Form post and not a regular post or page before updating the content.

    I've had quite a few people test this version without reporting anything like you've reported but just to be safe, I have rolled back the stable tag to the previous version.

    What else can you tell me about your site? What other plugins and/or themes are active?

  9. Mike Walsh
    Member
    Plugin Author

    Posted 6 months ago #

    I have released v0.65-beta-1 and also written some background detail about the reported corruption. Find both in this post on my web site.

  10. Mike Walsh
    Member
    Plugin Author

    Posted 6 months ago #

    I've spent a fair amount of time looking at and thinking about this problem since it was reported. The only conclusion I can come to is another plugin has implemented a "save_post" hook which doesn't do the necessary checking before modifying post content.

Reply

You must log in to post.

About this Plugin

About this Topic