WordPress.org

Ready to get started?Download WordPress

Forums

Gwebpro Store Locator
[resolved] Google Directions for non latin text? (8 posts)

  1. Stevie D
    Member
    Posted 9 months ago #

    Hi first off amazing plugin thanks for making it!

    Just one thing i have found my stores are located in Japan, i can add the location no problem but the link to check directions seems not to reconcile the location / Japanese text.. see what i mean here http://tinyurl.com/l3u49ej

    any ideas how to fix would be great thanks

    http://wordpress.org/plugins/gwebpro-store-locator/

  2. Jas Saran
    Member
    Plugin Author

    Posted 9 months ago #

    Hello,

    We have checked the URL. Currently the map is in English language, So when you have typed the Japanese character into the search box you will not find any result. You have to use Japanese map for the search of Japanese text.

    Yes you can change the map language easily by placing a code.
    First open gwebpro-store-locator.php.

    Now search for -
    http://maps.googleapis.com/maps/api/js?libraries=places&sensor=false

    Replace with -
    http://maps.googleapis.com/maps/api/js?libraries=places&language=ja&sensor=false

    After changing the code your map will appear in Japanese Language. Also the Japanese characters should support.

    Thank you,
    Gwebpro Team.

  3. Stevie D
    Member
    Posted 8 months ago #

    thanks but i'm not sure you quite get me..

    i'm talking about the directions button this is a link it generates

    https://maps.google.ca/maps?saddr=Shinjuku%2C+Tokyo%2C+Japan&daddr=%u6771%u4EAC%u90FD%u65B0%u5BBF%u533A%u897F%u65B0%u5BBF1-5-1%u30001%u968E%u3000%u30CF%u30EB%u30AF%u30B9%u30DD%u30FC%u30C4%2COdakyu+Halc

    I'm not sure how to fix but looking at
    onclick="direction(\'<?php echo $address1?>,<?php echo $city?>\'

    i'm guessing its losing its character encoding?..

  4. mrnielsen
    Member
    Posted 8 months ago #

    I think I have pretty much the same problem. When I enter a german city with an "umlaut" like "N├╝rnberg" for example, your plugins encodes it to "N%FCrnberg"

    Changing the parameter you mentioned in the post above, doesn't resolve the problem (i changed it to de of course :).

    http://i39.tinypic.com/zj6s5e.jpg

    I would really apreciate it, if u could point me (us) into the right direction on how to fix that problem.

    Kind regards
    mrnielsen

  5. Jas Saran
    Member
    Plugin Author

    Posted 8 months ago #

    Hello,

    We have understand both of your problem.

    The main problem is here character encoding. Fist add meta tag for encoding type in the header. To show your characters properly. I think UTF 8 will support both of your site.

    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <META HTTP-EQUIV="Content-Language" CONTENT="JA"> //for Japanese

    <META HTTP-EQUIV="Content-Language" CONTENT="DE"> //for German

    For more referance for meta tag you can see http://www.webmasterworld.com/forum32/845.htm

    if the problem still not fixed mail in our support with your website url.

    Thank you,
    Gwebpro Team.

  6. mrnielsen
    Member
    Posted 8 months ago #

    Hello,
    the problem couldn't be fixed with your suggestion. On 11-13-2013 I mailed to the support but never got an answer. Maybe you can check what happenend?!

    Best regards
    mrnielsen

  7. abaptista
    Member
    Posted 8 months ago #

    Hi there,

    Just change GWEBPRO-STORE-LOCATOR-FRONTEND.PHP at the line:

    document.location=formatUrl('dest='+encode(address)+'&lat='+lat+'&long='+lng);

    with:

    document.location=formatUrl('dest='+address+'&lat='+lat+'&long='+lng);

    The problem is that while passing the URL the special characters get encoded.

    Hope this works for you guys.

    Best Regards.

  8. mrnielsen
    Member
    Posted 8 months ago #

    Works like a charm! Thx a lot for this!!! *hugs*

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.