WordPress.org

Ready to get started?Download WordPress

Forums

Social Count Plus
[resolved] Google+ Counter Stays at Zero (16 posts)

  1. DeanSaliba
    Member
    Posted 3 months ago #

    Hi,

    All the other counters show correctly apart from the Google+ one, it says 0.

    http://www.build-your-blog.com

    Can you give me some advice why this one isn't showing?

    I inserted my Google+ ID correctly - 109864860632728491904

    https://wordpress.org/plugins/social-count-plus/

  2. Claudio Sanches
    Member
    Plugin Author

    Posted 3 months ago #

    Must be a page/community and not a profile.

  3. DeanSaliba
    Member
    Posted 3 months ago #

    Hmmmmm the link is https://plus.google.com/109864860632728491904/ - that is a profile, isn't it?

  4. hypnoscribe
    Member
    Posted 3 months ago #

    I have the exact same problem...

  5. Claudio Sanches
    Member
    Plugin Author

    Posted 3 months ago #

    Page: https://plus.google.com/+WpodIn/posts
    Page ID: 100619169826819238731

    Don't works with profiles!

  6. hypnoscribe
    Member
    Posted 3 months ago #

    Oh! Ok, thanks for the fast response. to bad, wich it would.. Is there something else i could use?

  7. Claudio Sanches
    Member
    Plugin Author

    Posted 3 months ago #

    Now in version 1.9.0 profiles works too.

  8. Mustafa
    Member
    Posted 3 months ago #

    Hi Claudio,

    I installed version 2.9.0 today, but the Google+ count remains 0 for our page https://plus.google.com/+sendikaorg

  9. Claudio Sanches
    Member
    Plugin Author

    Posted 3 months ago #

    @Mustafa what are your profile/page ID and Google API key?

  10. Mustafa
    Member
    Posted 3 months ago #

    it does never enter the following if check in includes/class-counter.php

    // Google Plus.
    if (
    isset( $settings['googleplus_active'] )
    && isset( $settings['googleplus_id'] )
    && ! empty( $settings['googleplus_id'] )
    && isset( $settings['googleplus_api_key'] )
    && ! empty( $settings['googleplus_api_key'] )
    ) {

  11. Mustafa
    Member
    Posted 3 months ago #

    I found the bug!

    there is no settings item $settings['googleplus_active'].

    It worked after deleting it from the line 148 from includes/class-counter.php.

    Sure, you need to fix it in another way :)

  12. Claudio Sanches
    Member
    Plugin Author

    Posted 3 months ago #

    This is not a bug and is working correct.
    Displays the icon for Google+?
    Why test it before displaying it https://github.com/claudiosmweb/social-count-plus/blob/master/social-count-plus.php#L1013-L1014
    You did not find bug and not fix anything...

  13. Mustafa
    Member
    Posted 3 months ago #

    @Claudio, you don't need to be so arrogant. you are very aggressive against all support requests. every software can have bugs, just relax buddy :)

    I printed $settings variable in the function update_transients(), and $settings['googleplus_active'] did not exist there. I also checked my options table for the option with name socialcountplus_settings, it did not exist there too.

    Then, I removed the plugin and installed it again. Now, it's working. It may be a problem about installation process, a conflict with another plugin, or even a bug in WordPress itself!

    Just, don't be so closed to comments of people. If you hear the same problem from more than one person, you should probably search for a common cause of the problem.

    Anyway, thanks for the plugin.

  14. Claudio Sanches
    Member
    Plugin Author

    Posted 3 months ago #

    You got me wrong, I was not arrogant.
    It will not appear if Google+ is disabled!
    When deactivates it is deleted from the database, but when activated is added back and why I do the test with isset(), the test you thought it was a bug.
    And as I said, will not also show in the widget too.

    This issue has been resolved, the problem was with profile, but now works perfectly profile too.
    So what you're telling me is not the same problem (http://codex.wordpress.org/Forum_Welcome#Where_To_Post) ;)

    But I hope that now you understand how the checkbox works for saving and what I wanted to talk about in my last comment.

    Anyway, sorry, but my native language is not English and had no intention of being arrogant.

  15. BestWPDesigner
    Member
    Posted 3 months ago #

    I am having the same issue. My counter stays at 0. You can see the counter in the upper right hand corner of my site:
    http://www.mikejohnsondesign.com

  16. Claudio Sanches
    Member
    Plugin Author

    Posted 3 months ago #

    I added a FAQ session on teaching how to configure the Google API to work with the plugin:
    http://wordpress.org/plugins/social-count-plus/faq/

    :)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.