WordPress.org

Ready to get started?Download WordPress

Forums

Google bot crawl 404 errors (5 posts)

  1. Phil
    Member
    Posted 2 years ago #

    hi all

    i get lots of 404 errors in google webmaster tools.

    the following "tag" is giving 404 error:
    http://www.tandooricookingexpert.com/tag/meal/

    if you add "blog" as follows it works:
    http://www.tandooricookingexpert.com/blog/tag/meal/

    same with "category", this gives 404 error:
    http://www.tandooricookingexpert.com/category/shop-and-save/

    if you add "blog" as follows it works:
    http://www.tandooricookingexpert.com/blog/category/shop-and-save/

    can i use a redirect to add "blog"? if so how would i do it?

    thanks in advance

  2. webjunk
    Member
    Posted 2 years ago #

    Kinda looks like you have WP installed in /blog and are doing some sort of rewrite already.

  3. Phil
    Member
    Posted 2 years ago #

    thanks for the reply webjunk.

    my files are in public_html. there is no blog folder only:
    - cgi-bin
    - wp-admin
    - wp-content
    - wp-includes

    the .htaccess file is:

    RewriteEngine On
    RewriteBase /
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    the functions.php file is:

    <?php
    if ( function_exists('register_sidebar') )
        register_sidebar(array(
            'before_widget' => '<li class="widget">',
            'after_widget' => '</li>',
            'before_title' => '<h2>',
            'after_title' => '</h2>',
        ));
    remove_action('wp_head', 'wp_generator');// MY ADDED CODE
    ?>

    any ideas please?

  4. webjunk
    Member
    Posted 2 years ago #

    First try resetting Permalinks (or just swtich off) and see what happens.
    What do you have set for URL's in General Settings?

  5. Phil
    Member
    Posted 2 years ago #

    thank you webjunk

    changing permalinks to default has solved problem. all 404 errors in google webmaster reach a page.

    MEGA KARMA TO YOU

Topic Closed

This topic has been closed to new replies.

About this Topic