WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
Google authorship markup not working (6 posts)

2 stars
  1. Kalyan Brata Das
    Member
    Posted 1 year ago #

    Hi plugin author,

    I have installed this plugin that looks good. However, the Google authorship markup is not working even though I have added a valid G+ profile, got it verified and yet the source of the page does not show this nor does Google rich snippet view can detect it. Any thought about this.

  2. Michael Torbert
    WordPress Virtuoso
    Plugin Author

    Posted 1 year ago #

    Hi Kalyanbratadas,

    What is your website URL?

  3. Kalyan Brata Das
    Member
    Posted 1 year ago #

    Hello Michael,

    Here is the URL http://kalyanbratadas.info/blog/ I can see my https://plus.google.com/111739842711825506306/posts in the page source now but Google rich snippet is yet to verify this. Below is the link to that snippet test

    http://www.google.com/webmasters/tools/richsnippets?url=http%3A%2F%2Fkalyanbratadas.info%2Fblog&html=

    PS: I will be happy to share my site's admin details with you if needed.

    Thanks
    Kalyan

  4. wpsmort
    Member
    Posted 1 year ago #

    Hi Kalyanbratadas,

    If you look at line 29 of your source code you will see that you have NOINDEX enabled -

    meta name='robots' content='noindex,nofollow'

    This is possibly because you have Privacy enabled in WordPress under Settings, Reading. Google will return errors about Authorship if you have NOINDEX set on the page.

    Also, you do need to go to your Google+ profile and add your blog as a Public Contributor link as stated in the Rich Snippets tool (See Option 2 here - http://support.google.com/webmasters/bin/answer.py?hl=en&answer=1408986).

    To do this go to http://plus.google.com/me/about/edit and click the last but one icon (Links) then add a link to your blog under Contributor To.

  5. Kalyan Brata Das
    Member
    Posted 1 year ago #

    @wpsmort

    Thanks for your support. Actually this is my test site and hence, I have enabled NOINDEXing of this. Anyway I will lift it temporarily and check it again. Also, I will add the site to my G+ profile. Thanks

  6. robertboblalas
    Member
    Posted 10 months ago #

    Thank you very much for author ship is also my problem. Im going to try it if will not then i post back.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.