WordPress.org

Ready to get started?Download WordPress

Forums

Easy WP SMTP
[resolved] Google Apps SMTP Problems? (4 posts)

  1. ylluminate
    Member
    Posted 1 year ago #

    Having some problems here with v.1.0.2 wherein it will not send messages through Google Apps Gmail SMTP server. I have the settings as they seemingly should be, but yet I get the dreaded "Email could no be sent" error.

    This error is unfortunately very vague and I am hopeful that we might be able to turn on more logging so as to see what the actual error is?

    Additionally, can you give us a sample screenshot of a Google Apps SMTP configuration as well so as to act as a sanity check that we're not misconfiguring something?

    http://wordpress.org/extend/plugins/easy-wp-smtp/

  2. wpecommerce
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, I haven't tested it with Google Apps SMTP. But it works with Gmail SMTP.

  3. Ovidiu
    Member
    Posted 1 year ago #

    I got it working with Google Apps, see screen shot for how to do this: http://screencast.com/t/mozeoXeSkwC2

  4. Robert
    Member
    Posted 11 months ago #

    I too had a problem with Google Apps Gmail and "Email could not be sent".

    My website is hosted on it's own domain and Google Apps MX records are configured in DNS. Google Apps Toolbox Check MX reports everything is fine: https://toolbox.googleapps.com/apps/checkmx/

    My hosting provider (WPEngine.com) does not offer e-mail services, which if it did can cause other well documented problems because mail will be sent to the hosting provider's local mail servers instead of gmail for the domain. See the Google Apps Forums for more info.

    Two-Step Verification is enabled via the Gmail Security settings (Gmail Account -> Security -> 2-step verification).

    Configured Easy WP SMTP as so:
    From Email Address: wordpress@mydomain.com <-- alias setup in Gmail
    From Name: WordPress
    SMTP Host: smtp.gmail.com
    Type of Encryption: SSL
    SMTP Port: 465
    SMTP Authentication: Yes
    Username: admin@mydomain.com <-- real user in Gmail
    Password: < password used for https://mail.google.com >
    Enable SMTP Debug: Checked

    Sending test e-mails via the "Test & Debug Settings" section of the plugin failed.

    I found the problem in the "SMTP Debug:" output panel. The Google Mail server said "Application specific password required" or something very similar.

    Woo Hoo!

    I logged into the Gmail admin@mydomain account via my web browser, navigated back to the Gmail Account -> Security -> 2-step verification and created a new application password for "WordPress". Pasted the application specific password into the plugin:
    Username: admin@mydomain.com <-- real user in Gmail
    Password: <application specific password for WordPress>

    and e-mail works fine! Sent various test e-mails to Google Apps mail, regular gmail and external domain accounts. No problems!

    I now receive WordPress comment notifications!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.