WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7 Analytics by Found
[resolved] Google Analytics data *sometimes* blank (4 posts)

  1. BuzzHamzaDotCom
    Member
    Posted 1 year ago #

    Hi,

    First of all, thanks for making a great plugin - it's one of my favourites.

    I installed it on a client's site recently and all is fine, but some emails (perhaps 1 in 10) are coming through with blank data (and 1970 dates).

    Any idea what might be causing this?

    Thanks

    http://wordpress.org/extend/plugins/contact-form-7-analytics-by-found/

  2. Found
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Thank you for your kind words and we're happy to see you are using our plugin.

    Regarding the blank data - the plugin reads the google analytics cookies in order to provide the information. So when blank data is coming through, it has to be because either - google analytics is not installed on the site (or not properly installed) - which is not your case as it does work most of the times, or the users have blocked cookies via browser settings.
    It is not something we can interfere with or force people to use cookies, we can just provide an insight when the data is there.
    I hope this is useful to you, any other questions, please let us know and we will be happy to help.

    Thanks,
    Dora

  3. orlys
    Member
    Posted 1 year ago #

    Hi,

    Same thing is happing in my site..

    Sometimes I receive all the details correctly full but sometimes I receive the analytics section blank with strange dates: these dates are always the same when the parameters appear to be blank. While when I receive the analytics parameters correctly with all details, the dates are also correct.

    Google Analytics information:
    ——————————————–
    Campaign Source:
    Campaign Name:
    Campaign Medium:
    Campaign Term:
    Campaign Content:
    First visit: 01/01/1970 12:00:00 AM
    Previous visit: 01/01/1970 12:00:00 AM
    Current visit: 01/01/1970 12:00:00 AM
    Times visited:
    I have tried almost everything, including placing the analytics code in the footer section..
    So if I understand correctly you are saying that the cause of this is that the users are blocking cookies in their browser, right?

    Thank you in advance,
    Orly

  4. Found
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Orly,

    That is right, the absence of analytics data is due to missing google analytics cookies and that is most likely happening because users have chosen to block cookies.
    The funny date you are seeing there is the unix epoch - the date time starts being measured in unix. As the time we expect to collect from the cookie is null, the dates default to the "beginning of time" as it is defined by unix.

    More info here: http://www.linuxnix.com/2011/06/linux-time-jan-01-1970.html

    Thanks,
    Dora

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.