WordPress.org

Ready to get started?Download WordPress

Forums

Coming Soon Page & Maintenance Mode by SeedProd
[resolved] Google Analytics code inserter not working? (13 posts)

  1. mugwumpman
    Member
    Posted 4 months ago #

    I copied the below code into the 'Analytics Code' box in the Coming Soon settings for http://hollowgatefarm.co.uk, and yet my Google Analytics account insists that 'Tracking not Installed'. Viewing the source code of the generated page I can see it is appearing just before the modernizr code & </head>, but Google can't seem to find it. How come?

    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    
      ga('create', 'UA-XXXXXXX-X', 'hollowgatefarm.co.uk');
      ga('send', 'pageview');
    
    </script>

    https://wordpress.org/plugins/coming-soon/

  2. SeedProd
    Member
    Plugin Author

    Posted 4 months ago #

    Sorry just now seeing this, what's your url?

  3. Nedu
    Member
    Posted 3 months ago #

    hi im having a similar problem and my tracking code is visible on my page. I have tried to flush cache and it is still visible.

  4. John Turner
    Member
    Plugin Contributor

    Posted 3 months ago #

    Url please :)

  5. Nedu
    Member
    Posted 3 months ago #

  6. Nedu
    Member
    Posted 3 months ago #

    sorry i shouldnt have done that could you delete it ?:

  7. John Turner
    Member
    Plugin Contributor

    Posted 3 months ago #

    Insert all the code google provides not use the account code. Include the script tags. That should work.

  8. John Turner
    Member
    Plugin Contributor

    Posted 3 months ago #

    I can't delete it but you should be able to edit it. and delete

  9. Nedu
    Member
    Posted 3 months ago #

    I did copy the code including the script tag from google analytics and posted as instructed…is there something more i should do as its still not working?

  10. John Turner
    Member
    Plugin Contributor

    Posted 3 months ago #

    hum, I only see the ua code still. Did you save your changes?

    Are you running caching plugin? or is your host?

    I just tested and it work for me locally.

  11. Nedu
    Member
    Posted 3 months ago #

    well i decided to remove the ga code completely and its still visible at this end. I am not sure why and its not the sort of information I want to share. Can you please delete my url on the forum please until this problem gets resolved.

  12. John Turner
    Member
    Plugin Contributor

    Posted 3 months ago #

    That mean it's cached either on your host or by some other plugin you are using.

    Also only you can edit your post. I can't delete it.

  13. John Turner
    Member
    Plugin Contributor

    Posted 3 months ago #

    I don't have the ability to delete, you might contact the forum moderators. You should the ability to edit your own post and delete it yourself.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.