WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Google Ads Not Appearing in Posts (20 posts)

  1. guided
    Member
    Posted 8 years ago #

    I'm trying to introduce google adsense, using the Adsense-Deluxe plugin. The php code added to my sidebar works. But the ads don't show within posts.

    The code appears in the page source, but not on the compiled page. I've got a messy navbar at the top of the page, hacked in using dreamweaver. Ugly, but the best I could do with limited knowledge. It uses java. I'm also running the livecalendar java plugin, but I've tried disabling it to no avail.

    I've also tried to create a dummy page outside the blog and have ads delivered to that. It worked.

    The site is http://www.oldworldwandering.com.

    Please help! I've run out of ideas.

  2. guided
    Member
    Posted 8 years ago #

    Sorry, most stupidly forgot to mention that the adsense code is only in one post, on Oxford: http://www.oldworldwandering.com/2006/02/25/oxford-2/

  3. charle97
    Member
    Posted 8 years ago #

    you're missing a greater than sign in the second script tag.

  4. guided
    Member
    Posted 8 years ago #

    Could you point to where exactly? Appreciate this. Really banging my head.

  5. charle97
    Member
    Posted 8 years ago #

    the greater than sign is there now, but i still don't see the ad.

    are you posting the adsense code in the post itself? it looks like the post filters are line breaking the ad code.

  6. guided
    Member
    Posted 8 years ago #

    I've now taken all the linebreaks out, posting the code directly (myself). Still no joy... The plugin was also producing linebreaks.

  7. madaise
    Member
    Posted 8 years ago #

    I've had this problem before. I ended up having to put a paragraph tag around the google ad script and give it a style code <p style="text-align:left;width:243;">google ad script I added the whole thing to the google ad deluxe area where it says to insert the code.

  8. guided
    Member
    Posted 8 years ago #

    Still stuck! I've tried to add the formatting and still had no luck. It's there now, on the post mentioned above.

    How did you arrive at a width of 243? It's unlike the size of any adsense block I've seen. I tried it with the block size I'm using and that also didn't work.

    If think it must have something to do with the formatting. I'm using 2.0. But not the visual rich editor. Are the
    tags causing the problem?

    Google themselves have been extremely unhelpful and I'm tearing my hair out.

  9. Samuel B
    moderator
    Posted 8 years ago #

    Calm down - take it easy. :>)
    Fisrt, disable your wysiwyg editor (Admin -> Users -> scroll to bottom left) as it messes up code.
    Next, go to write a post and put this:
    <div>
    your adsense code exactly as it is generated
    </div>

    Then publish. Works for me on every blog I've installed it.

  10. guided
    Member
    Posted 8 years ago #

    Thanks. Trying to remain calm, I'm just finding this a trifle frustrating. Did it, didn't work. I'll leave it up for the next little while if you'd like to take a look.

  11. guided
    Member
    Posted 8 years ago #

    Ooops! Double posted that.

  12. Samuel B
    moderator
    Posted 8 years ago #

    Where exactly in the post are you trying to place it? Do you get any parse errors or other? Or does it just not show up at all?

  13. guided
    Member
    Posted 8 years ago #

    No parse errors. It just doesn't show up at all. I'm placing it right after the <!--more--> tag.

  14. Samuel B
    moderator
    Posted 8 years ago #

    OK, that's very strange - it's showing up when you view the source:
    <p><!-- Begin Google Adsense code --></p>

    <p style="text-align:left;width:243;">
    <script type="text/javascript"><!--<br />
    google_ad_client = “pub-2364857001480697″;<br />
    google_ad_width = 234;<br />
    google_ad_height = 60;<br />
    google_ad_format = “234×60_as”;<br />
    google_ad_type = “text”;<br />
    google_ad_channel =”4263882800″;<br />
    google_page_url = document.location;<br />
    google_color_border = “336699″;<br />
    google_color_bg = “FFFFFF”;<br />
    google_color_link = “0000FF”;<br />
    google_color_url = “008000″;<br />
    google_color_text = “000000″;<br />
    //–></script><br />
    <script type="text/javascript"<br />
    src=”http://pagead2.googlesyndication.com/pagead/show_ads.js”><br />
    </script>

  15. guided
    Member
    Posted 8 years ago #

    Other ads are working (one in the sidebar and one above the comments).

    It seems that WordPress is replacing my apostrophes (") with the html ASCII code.

    I tried to show the code here but it just gets converted into the correct symbol. So I can't. If you have any idea of how to help you'll have to go to the site.

    It's actually breaking the page in IE.

  16. charle97
    Member
    Posted 8 years ago #

    do you want to show adsense ads every time you use "more"?

  17. guided
    Member
    Posted 8 years ago #

    Yes.

  18. charle97
    Member
    Posted 8 years ago #

    i've installed adsense deluxe and tested it on a post that i use a more tag. the ad showed up fine. did you copy the adsense code into adsense deluxe directly from google adsense or from some other source?

  19. guided
    Member
    Posted 8 years ago #

    Got it! Thinking about the characters being changed into ASCII numbers I thought about my plugins. I'm running text control by Jeff Minard. Disabled that and the ads within posts worked.

    So text control interferes with adsense. Ha! At last. Might have been obvious to some but took me ages to twig. Thanks to everybody for helping. Kept me encouraged even if you didn't directly resolve the problem.

  20. ublogusserv4latinos
    Member
    Posted 7 years ago #

    I'm new with WordPress. Love their general user friendly format. Lots of user support. One problem, I just pasted in a Google AdSense code two days ago and it still doesn't show up on my blog. What to do?

Topic Closed

This topic has been closed to new replies.

About this Topic