WordPress.org

Ready to get started?Download WordPress

Forums

Comprehensive Google Map Plugin
Good plugin but has some issues. (6 posts)

2 stars
  1. michaelkruger
    Member
    Posted 1 year ago #

    Positives:
    This is a decent plugin with many features and a very handy shortcode generator.

    Negatives:
    There seems to be problems when using markers or KML, which is that several options/variables do not work, such as maptype, scalecontrol, zoomcontrol. I've seen several posts requesting help and I have also posted some, but there seems to be no response or support for this.

  2. Jenson Poobah
    Member
    Posted 1 year ago #

    I can't get it to work. It installed fine. First problem was I couldn't figure out how to limit the "options" section to just one single page. That was not a real problem, but it seemed odd that it's default would be to install Google Map functionality to every page and post on the entire site, with no intuitive way to limit that availability to just one, or a select few pages/posts.

    Who wants a fully-functional google map on every single page on their site? A: No one, so why does it default to this?

    But the real problem is that I can't seem to get the map to load. I've created a new blank page to experiment with, have the whole range of the plugin's options available, have inputed the physical location in every way I can think of, the short code gets generated, and everything looks good, but when I go to "view" the page, the cursor just spins indefinitely and the map never loads. However, the boundries of the map's area are defined exactly as they are configured in the short code, so SOMETHING is working. I've changed the boundries several times, and each time the box represented on the web page changes correctly.

    But the map itself never loads.

    I suspect it's a problem with the address, but I copy and paste that address direct from the Google Maps listing, so I'm giving Google the exact same text as it's giving me. And I've entered the Google Maps URL also, and that doesn't work either.

    So, any help? Thanks in advance.

  3. Jenson Poobah
    Member
    Posted 1 year ago #

    I've narrowed-down my problem by installing the same plugin on another site that was installed just yesterday and has a minimum of other plugins installed. The "Comprehensive" plugin worked just fine on that site.

    One difference between the two is that on the non-working site, when you click the "Add" button to enter the address (or lat-long information), nothing happens, but on the site that works, you get a response, with a red box underneath that contains the address you just entered.

    You don't get that on the site that doesn't work, so I assume the problem is that the address never gets entered. In both cases, both addresses were exactly the same. Further, when I paste the short code of the working site into the page of the non-working site, that site still does not work. But that might be normal, I can't say.

    Finally, I uninstalled and then reinstalled the "Comprehensive" plugin, and it still does not work, so I do not believe it was a failed installation. Other posts I have read indicate that there are other, similar (but not exactly the same) problems with this "add" button. One fix was to uninstall the official Facebook plugin. The site I have (that does not work) has numerous plugins installed and I might deactivate them all to see what happens. Not sure if I want to do that or find another plugin. This one looks really nice on the site that works, so I'd like to have it working on both sites. Any help would be appreciated.

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    Jenson Poobah, you're posting in the wrong place.
    This is the forum where you review themes and plugins.

    If you require support for a plugin, use the Plugins and Hacks forum.

  5. Jenson Poobah
    Member
    Posted 1 year ago #

    thanks, I figured out it was a problem with the theme (Karma ver. 1.2). You can delete all this stuff.

  6. alexanderzagniotov
    Member
    Plugin Author

    Posted 8 months ago #

    Hi, the plugin is now compatible with WP 3.6+ and jQuery 1.9+.

    Apologies, but real life kept me busy. If you still have any issues, please feel free to post in on the support forum

    Thank you

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.