WordPress.org

Ready to get started?Download WordPress

Forums

Good old visual/text editor adding tags issue (2 posts)

  1. icakeov
    Member
    Posted 6 months ago #

    Hi I've been battling this one for quite some time, reading all the forum posts and implementing things but it's still not helping.

    When I switch between visual and text editor, <p> tags are added. I know one would say "stop switching" but I need to be able to be able to switch between them, especially since I'm not the only one using it and if anyone ever switches accidentally, it will mess up the code.

    I have added this into functions.php:
    remove_filter( 'the_content', 'wpautop' );
    remove_filter( 'the_excerpt', 'wpautop' );

    I have Ultimate Tinymce plugin and I checked "Disable wpautop" and "Remove p and br quicktags". I have tried installing and using Tinymce Advanced as well and doing the same thing.

    I have even installed the "Toggle wpautop" plugin and that didn't help.

    The <p> tags are still being added during the switch.
    I might have tried some other tricks, can't remember now.

    Anyone has any suggestions to what else I could do?
    Thanks!

  2. dimitris33
    Member
    Posted 6 months ago #

    i agree that this can be annoying, i would love to know a workaround myself.

Reply

You must log in to post.

About this Topic

Tags

No tags yet.