WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] Gold Cart activated, but not operating (15 posts)

  1. Steve Wheeler
    Member
    Posted 3 months ago #

    We've been using Gold Cart, but it's apparently stopped operating. We've been using Authorize.net, but it doesn't show up anymore, and we're not sure when it went away (we get few orders via the web). As far as configuration is concerned, we only have the default payment gateways.

    How do I get the extra payment gateways to show up again?

    https://wordpress.org/plugins/wp-e-commerce/

  2. whitelamp
    Member
    Posted 3 months ago #

    Have you tried reinstalling the gold cart plugin? Maybe start by de-activating and re-activating, and if no joy, go for a full re-install.

  3. Steve Wheeler
    Member
    Posted 3 months ago #

    I had already tried deactivating and reactivating, and it didn't make any difference.

    I can't reinstall, because the site was put together for us by a contractor (bad experience, so we won't get him involved to fix this), and I can delete the files, but apparently can't get a new copy of Gold Cart without purchasing it again. If that's what we have to do, I suspect the boss will have me looking for a different plugin.

  4. Mihai
    Member
    Plugin Author

    Posted 3 months ago #

    Have you entered the API key info in the Dashboard -> Store Upgrades page ?
    Regards
    Mihai

  5. Steve Wheeler
    Member
    Posted 3 months ago #

    Yes, it's been there since before I took over maintaining the site.

    This was a working installation, and we were using Authorize.net without trouble. Something happened - we don't know what, and we're not sure exactly when - and all we have available now are the default payment gateways that come with the basic wp-ecommerce plugin. The extra gateways with Gold Cart are no longer to be seen.

  6. Mihai
    Member
    Plugin Author

    Posted 3 months ago #

    That usually means Gold Cart is not registered using the API key on the store upgrades page under Dashboard.
    If it says active reset it and enter the api key again.
    Would help if you post WPEC and GOld Cart versions.

  7. Nonfascist
    Member
    Posted 3 months ago #

    WordPress version: 3.8.1
    Gold Cart version: 2.9.7.7
    WP E-commerce version: 3.8.13.4
    Ocean Mist Theme

    My problems: The functions of Gold Cart are not appearing on my WordPress blog after purchasing and installing the plugin.

    Also, I cannot sign up for Premium one on one support as was promised with my purchase of Gold Cart. I have no idea what my FTP is. How do I post Premium support questions to the Getshopped.org site at http://getshopped.org/wp-admin/ ?

    What I expected: I expected to have increased functionality on my WordPress blog with the Gold Cart plugin through the WP E-commerce plugin. Right now I cannot figure out whether or not Gold Cart is adding any functions to my blog.

    I would like to be able to change the image of each product individually, but there's no product image tab where I can upload images. The Product Download tab under my Products button does not display the images that I'm downloading to show what each product looks like individually.

  8. Nonfascist
    Member
    Posted 3 months ago #

    The URL where I'm having trouble using Gold Cart and WP E-commerce with is http://www.horsegulchblog.com.

  9. matthewdgeorge
    Member
    Posted 2 months ago #

    WordPress version: 3.9
    Gold Cart version: 2.9.7.7
    WP E-commerce version: 3.8.13.4
    Theme: Woodberry Pre Responsive

    Let me add that I am seeing EXACTLY the same behavior as Nonfascist (although without some of the working drama, and I have all my keys, etc.)

    Specifically, I cannot seem to get ANY images uploaded for ANY products. The 'Add Media' button on my product page apparently does...nothing at all. Store sales through Authorize.net working appear to be working properly.

    My problems: The functions of Gold Cart are not appearing on my WordPress blog after purchasing and installing the plugin.

    What I expected: I expected to have increased functionality on my WordPress blog with the Gold Cart plugin through the WP E-commerce plugin. Right now I cannot figure out whether or not Gold Cart is adding any functions to my blog.

    I would like to be able to change the image of each product individually, but there's no product image tab where I can upload images. The Product Download tab under my Products button does not display the images that I'm downloading to show what each product looks like individually.

    http://www.andersontrojanband.com

  10. Edward
    Member
    Plugin Author

    Posted 2 months ago #

    As previously mentioned your Gold Cart is not activated. You have it installed and enabled but you still need to *ACTIVATE* it

    Go to your DASHBOARD > STORE UPGRADES

    Here you will see a place to enter your API info to ACTIVATE the plugin.

    See Screenshot
    Gold Cart Activation Screenshot

    Documentation here http://docs.getshopped.org/documentation/activating-your-gold-cart/

    If you still have trouble after following these instructions then you may not have Gold Cart Installed or you may have a plugin conflict. Disable all other NON store related plugins and try again.

    If you still have trouble please open a support topic http://getshopped.org/resources/premium-support/

    Regards
    Edward

  11. matthewdgeorge
    Member
    Posted 2 months ago #

    Well,

    The key has been in my DASHBOARD->Store Upgrades for several months, with the message 'Gold Cart is currently registered' (with green check-mark).

    However, when I attempt to hit the 'Submit' button, I do get a message about the API-Key needing to come from a (now defunct) older domain.

    If this is the root-cause of my problem, I will attempt to get it resolved through the premium-support link you suggested.

    Best,
    -Matt

  12. Edward
    Member
    Plugin Author

    Posted 2 months ago #

    Yes this is correct. Normally you would need to deactivate it on the old domain first. Since it's a per domain key. If you no longer are able to do this you will need to contact support since I don't advise you posting any private information on this open topic.

    Regards
    Edward

  13. paulski1106
    Member
    Posted 2 months ago #

    Hi I just updated WP eCommerce to the latest version (3.8.14) last night from the previous version. I am also running Gold Cart and have been trying to update that from 2.9.7.7 to 2.9.7.8.
    I've only just got the site up and running in a folder on my server and am nearly ready to move to root, (this last week or two all the work has been done).
    The previous versions of both WP eCommerce AND Gold Cart were working fine.
    WP eCommerce is working fine as far as I can tell on the update and with the older version of Gold Cart.
    If I update Gold Cart it all goes pear shaped...
    My first thought with Gold Cart is that its an update, maybe a bug in there, just to run the (slightly) newer version of WP eCommerce with the (slightly) older version of Gold Cart, maybe try updating Gold Cart later. Anyone envisage any issues doing that?
    I have updated WP eCommerce via the plugin tab on my backend and tried to manually update Gold Cart via FTP.
    Any thoughts or ideas?
    Cheers

    Paul

  14. matthewdgeorge
    Member
    Posted 2 months ago #

    Gold Cart updates are a bit different... the best way seems to be:
    1. Deactivate Gold Cart plugin
    2. Delete old (outdated) Gold Cart plugin
    3. Download newest Gold Cart plugin from GetShopped.org
    4. Install 'new' Gold Cart plugin via upload (or FTP)
    5. Reactivate Gold Cart.
    6. Go make sure API Key shows Gold Cart is working using
    DASHBOARD->Store Upgrades

    There are web-pages out there that give the same sequence (strangely, not affiliated in any way with GetShopped... but apparently reputable nonetheless).

    As for my problem: my 'domain' issue is fixed, and Gold Cart reports that it is registered correctly. I can setup (and see) 'Grid View' on my Store (so I know Gold Cart is working), but I still cannot 'Add Media' (an image) to any products (using Product->Edit). Products show a 'placeholder' (empty image) in lieu of a real image.

    On Pages, Posts, tables, etc... the 'Add Media' button works just fine, grabbing and inserting images from my Media Gallery. But for some reason, I cannot get the 'Add Media' button to do ANYTHING at all with Products->Edit. Likewise, I cannot 'Manage Images' from the Product-edit page, as this button also does not appear to work. Frustrating....

    Best,
    -Matt

  15. paulski1106
    Member
    Posted 2 months ago #

    Ah thanks for the tip Matt, I thought I'd done that, and about any other permutation I could think of. Gave it a go anyway but still got the same end result.
    The update to WP eCommerce works fine but it screws up little bits of the cart when I do a test purchase with the old Gold Cart plugin, so I update the Gold Cart plugin and it all comes tumbling down.
    For what it is I think I'll leave it for now, maybe have another go in a few weeks, maybe when the next updates come around.
    I just wanted to stay bang up to date all the time and be able to do it all myself, I had a developer do some work for me who disappeared after a while without telling me what custom code he had inserted and where.
    I was left with a site I could not update after around July last year because every time I updated it broke the site, and starting to get worried about security etc...
    I had the same issue as you with my old site that I could not update, with products (not pages or posts) I had to manually insert code to insert images into the body and upload the images via FTP.
    A bit clunky but it got around the issue for a while...
    Fun and games.
    Cheers

    Paul

Reply

You must log in to post.

About this Plugin

About this Topic