WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Going to sitename.com/wp-admin/install.php gives me error (7 posts)

  1. Dan299
    Member
    Posted 8 months ago #

    Hi, I understand that this exact problem is quite unusual since i have looked all over google and not found anything on this problem exactly.
    I have set up my FTP and used Filezilla to upload the files. All of that ran smoothly. However it seems to be the wp-config.php file which is the problem. I have tried re-downloading the whole thing but it still gives me the same error:

    Parse error: syntax error, unexpected '@' in /homepages/38/d500122291/htdocs/wp-config.php on line 25

    Here is the code (I have removed the important information for confidentiality)

    <?php
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'mydbname');
    
    /** MySQL database username */
    define('DB_USER', 'myuser');
    
    /** MySQL database password */
    define('DB_PASSWORD', ’mypass’);
    
    /** MySQL hostname */
    define('DB_HOST', 'myhost’);
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '');
    define('SECURE_AUTH_KEY',  '');
    define('LOGGED_IN_KEY',    '');
    define('NONCE_KEY',        '');
    define('AUTH_SALT',        '');
    define('SECURE_AUTH_SALT', '');
    define('LOGGED_IN_SALT',   '');
    define('NONCE_SALT',       '');
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress. A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
     * language support.
     */
    define('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    I'm sorry to give you the whole chunk of code, but I really have no idea what the problem is.
    Hope you can help

  2. damian.smith
    Member
    Posted 8 months ago #

    Its probably not the issue but the password line has incorrect quote characters in it:

    define('DB_PASSWORD', ’mypass’);

  3. Start from scratch. Rename your existing wp-config.php file to wp-config-SAVE.php and then copy the wp-config-sample.php to wp-config.php.

    Make sure you do not delete the old file.

    Then with that new copy carefully edit it and put in your database specifics into the new file. Use the most plain text editor you have, notepad or notepad++ is good for that.

    Once you've done that see if that error message goes away.

  4. damian.smith
    Member
    Posted 8 months ago #

    also:

    define('DB_HOST', 'myhost’);

  5. Dan299
    Member
    Posted 8 months ago #

    ok, thanks for that help - i think that may be the problem
    ill give it a go now

  6. Dan299
    Member
    Posted 8 months ago #

    great I'm in. that worked @damian.smith

  7. damian.smith
    Member
    Posted 8 months ago #

    No problem! :)

Reply

You must log in to post.

About this Topic