WordPress.org

Ready to get started?Download WordPress

Forums

Going to site kind of weird... (10 posts)

  1. jhermiz
    Member
    Posted 7 years ago #

    Finally got WordPress running on apache / php / mysql...what a pain...and that five minute install guide is pure junk!

    Now I finally got it installed and went through the install wizard where you tell it what you want to call your site.

    After I do this I get the login screen to login...I login successfully, but immediately it takes me to a listing of all the files (.php) in the directory of my blog.

    I have to actually go up to the address bar and add "index.php" to the end of the url to get it to actually go to that site.

    My site is not on the root of my htdocs folder (I did not want it to be). I wanted it in its own folder called "blog" so that i can go to http://www.mywebsite.com/blog.

    Now when I do go to that address as I said it shows a listing of the files. I have to tack on index.php to the end of it to go to the actual site. Then when I click on ANY link on the site the same thing happens so I have to take on "index.php?=page2" to the end of the url if I wanted to go to my say "About" page.

    I dont want to have to do that..can someone point me to some help ?

  2. estjohn
    Member
    Posted 7 years ago #

    are you hosting the site? The IIS or Apache or whatever webserver needs to be set to show no directory listing and also to read .php as default

  3. jhermiz
    Member
    Posted 7 years ago #

    Yes hosting locally how do I do what you said ?

  4. jhermiz
    Member
    Posted 7 years ago #

    Im using apache by the way
    2.2.3 and php 5.1.6 and mysql 5

  5. estjohn
    Member
    Posted 7 years ago #

    this is a quick way to turn off directory listing off using .htaccess

    Update ".htaccess" file to root directory, with the directive "Options All -Indexes" inside the .htaccess file. This will prevent directory listings on all directories and subdirectories.

    You can also change it in your Apache httpd config

    if you want to change it so that .php files are default instead of .html

    change in your httpd config

    DirectoryIndex Directive
    Default: DirectoryIndex index.html

    to
    DirectoryIndex Directive
    Default: DirectoryIndex index.php

    and restart apache

    more info can be found on apache.org

  6. jhermiz
    Member
    Posted 7 years ago #

    Can you provide more info as I am new to this.
    htaccess file ? Located where ?

  7. jhermiz
    Member
    Posted 7 years ago #

    By the way im on a windows machine (xp)

  8. estjohn
    Member
    Posted 7 years ago #

    in your wordpress directory, you should have a file called .htaccess, that is where you want to add the rules to.

    as far as apache on windows.. that will be hard one for me... i have always worked with apache on freebsd or linux. there should be some documentation on the apache.org site or on google.. you are looking to modify an apache config file.. mine is httpd.conf that I edit.

    I also use multiple vhosts so I am not sure where to tell you to edit.

    Someone else might be a better person to explain that to you, i am sorry :(

  9. Samuel B
    moderator
    Posted 7 years ago #

    You might want to check out Xampp:
    http://www.apachefriends.org/en/xampp.html

  10. jhermiz
    Member
    Posted 7 years ago #

    I see the css theme on my pc but anybody else just gets the site with html only - no theme. What's up?

Topic Closed

This topic has been closed to new replies.

About this Topic