WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] GoDaddy WordPress Install w/ Disabled "mail() function" (20 posts)

  1. windowsx.com
    Member
    Posted 5 years ago #

    I am in the process of configuring my StickyChicky.com domain with WordPress but the forgot email function, and the registration email function, do not work. I get the error "The e-mail could not be sent. Possible reason: your host may have disabled the mail() function".

    Here are repro steps:
    1. Go to http://www.stickychicky.com/wp-login.php?action=lostpassword
    2. In the "Username or E-mail" field enter "testuser@stickychicky.com"
    3. Click "Get New Password"
    4. Receive error

    I have also installed the WP-Mail-SMTP plugin by Callum Macdonald, http://www.callum-macdonald.com, gone through the configurations, changed settings back and forth, different combos, etc. to no avail. Any suggestions would be great.

    I also have a message in with GoDaddy so we will see what they say as well.

  2. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    Hi windowsx.com,

    We will take a look and be in touch. Thanks!

    Alicia R.
    Go Daddy Hosting

  3. windowsx.com
    Member
    Posted 5 years ago #

    Figured it out. Guess I was tired when I was using the WP-Mail-SMTP plugin and didnt try all the combinations.

    Here is what you need to do with GoDaddy:
    1. Set up an email address in your Hosting account, I used one of my Free Email with domain credits
    2. Install the WP-Mail-SMTP plug from here or uSearchIt
    2a. Basically you download the file and drop it into your wp-content\plugins\ folder
    3. Activate the plugin within WP by logging in and going to the Plugins to activate it
    4. After activating the plugin go to Settings - Email
    5. Enter the email from step 1 into the "From Email" field
    6. Enter your "From Name"
    7. Select "Send All WordPress Emails via SMTP"
    8. In the "SMTP Host" field enter "relay-hosting.secureserver.net"
    9. For "Authentication" choose "Yes: Use SMTP authentication."
    10. In "Username" enter the email address from step 1 again, same as step 5
    11. In the "Password" field enter the password you use for the email login (SECURITY NOTE: this is saved in clear text in the UI)
    12. Click "Update Options"
    13. Test by entering an email address you can access in the "To" box under the "Send a Test Email" section
    14. Click "Send Test"

    You might received a message that makes it sound like the email failed but when you check you mailbox it should be there. You might also get a message in the mailbox in step 1 that also sounds like the send might have failed, dont worry though if you received it in the other box. Just dont change the settings after it works for retreiving the email.

    Here is what I receive in the WP UI when the test message is sent:
    --------------------------------------------------------------
    Test Message Sent

    The result was:

    bool(true)
    The SMTP debugging output is shown below:

    SMTP -> FROM SERVER:
    220 p3smtphosting04-02.prod.phx3.secureserver.net ESMTP
    SMTP -> FROM SERVER:
    250-p3smtphosting04-02.prod.phx3.secureserver.net
    250-PIPELINING
    250-SIZE 30457280
    250 8BITMIME
    SMTP -> ERROR: AUTH not accepted from server: 502 unimplemented (#5.5.1)

    SMTP -> FROM SERVER:
    250 flushed
    SMTP -> FROM SERVER:
    250 ok
    SMTP -> FROM SERVER:
    250 ok
    SMTP -> FROM SERVER:
    354 go ahead punk, make my day
    SMTP -> FROM SERVER:
    250 ok 1220684469 qp 31722 by p3smtphosting04-02.prod.phx3.secureserver.net
    SMTP -> FROM SERVER:
    221 p3smtphosting04-02.prod.phx3.secureserver.net Goodbye.
    --------------------------------------------------------------

    Here is what is received by the email address in the To box for the test email:
    --------------------------------------------------------------
    Subject: WP Mail SMTP: Test mail to xxxxxxxxx@hotmail.com
    Body: This is a test email generated by the WP Mail SMTP WordPress plugin.
    --------------------------------------------------------------

  4. benny148148
    Member
    Posted 5 years ago #

    This was a huge help for me!! THANK YOU!!!

  5. Vivid
    Member
    Posted 5 years ago #

    I've got all of this set up and it still seems to be failing with this UI output...

    Test Message Sent

    The result was:

    bool(false)

    The full debugging output is shown below:

    object(PHPMailer)#109 (44) {
    ["Priority"]=>
    int(3)
    ["CharSet"]=>
    string(5) "UTF-8"
    ["ContentType"]=>
    string(10) "text/plain"
    ["Encoding"]=>
    string(4) "8bit"
    ["ErrorInfo"]=>
    string(44) "Language string failed to load: connect_host"
    ["From"]=>
    string(29) "administrator@vastreality.com"
    ["FromName"]=>
    string(12) "Vast Reality"
    ["Sender"]=>
    string(0) ""
    ["Subject"]=>
    string(56) "WP Mail SMTP: Test mail to administrator@vastreality.com"
    ["Body"]=>
    string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
    ["AltBody"]=>
    string(0) ""
    ["WordWrap"]=>
    int(0)
    ["Mailer"]=>
    string(4) "smtp"
    ["Sendmail"]=>
    string(18) "/usr/sbin/sendmail"
    ["PluginDir"]=>
    string(0) ""
    ["Version"]=>
    string(5) "2.0.2"
    ["ConfirmReadingTo"]=>
    string(0) ""
    ["Hostname"]=>
    string(0) ""
    ["MessageID"]=>
    string(0) ""
    ["Host"]=>
    string(30) "relay-hosting.secureserver.net"
    ["Port"]=>
    string(0) ""
    ["Helo"]=>
    string(0) ""
    ["SMTPSecure"]=>
    string(0) ""
    ["SMTPAuth"]=>
    bool(true)
    ["Username"]=>
    string(29) "xxxxxxxxxx" (Email here)
    ["Password"]=>
    string(9) "xxxxxxxxxx" (Password Here)
    ["Timeout"]=>
    int(10)
    ["SMTPDebug"]=>
    int(2)
    ["SMTPKeepAlive"]=>
    bool(false)
    ["SingleTo"]=>
    bool(false)
    ["smtp"]=>
    object(SMTP)#110 (7) {
    ["SMTP_PORT"]=>
    int(25)
    ["CRLF"]=>
    string(2) "
    "
    ["do_debug"]=>
    int(2)
    ["do_verp"]=>
    bool(false)
    ["smtp_conn"]=>
    resource(105) of type (stream)
    ["error"]=>
    NULL
    ["helo_rply"]=>
    string(77) "250-smtpout17-02.prod.mesa1.secureserver.net
    250-PIPELINING
    250 8BITMIME
    "
    }
    ["to"]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(29) "administrator@vastreality.com"
    [1]=>
    string(0) ""
    }
    }
    ["cc"]=>
    array(0) {
    }
    ["bcc"]=>
    array(0) {
    }
    ["ReplyTo"]=>
    array(0) {
    }
    ["attachment"]=>
    array(0) {
    }
    ["CustomHeader"]=>
    array(0) {
    }
    ["message_type"]=>
    string(5) "plain"
    ["boundary"]=>
    array(2) {
    [1]=>
    string(35) "b1_433cb721bd7852a9dde7c664a7287a87"
    [2]=>
    string(35) "b2_433cb721bd7852a9dde7c664a7287a87"
    }
    ["language"]=>
    array(0) {
    }
    ["error_count"]=>
    int(4)
    ["LE"]=>
    string(1) "
    "
    ["sign_key_file"]=>
    string(0) ""
    ["sign_key_pass"]=>
    string(0) ""
    }

    The SMTP debugging output is shown below:

    SMTP -> FROM SERVER:
    220 smtpout17-02.prod.mesa1.secureserver.net ESMTP
    SMTP -> FROM SERVER:
    250-smtpout17-02.prod.mesa1.secureserver.net
    250-PIPELINING
    250 8BITMIME
    SMTP -> ERROR: AUTH not accepted from server: 502 unimplemented (#5.5.1)

    SMTP -> FROM SERVER:
    250 flushed

    Any Ideas? I'm running the newest version of the email plug in and also am running WP 2.7.

  6. Vivid
    Member
    Posted 5 years ago #

    GoDaddy was able to figure out my issue. Since i'm hosting my own web server, I needed to use the host smtpout.secureserver.net on port 80 and turn authentication on.

    Thanks :)

  7. tryforce09
    Member
    Posted 5 years ago #

    are you on linux or windows with godaddy?

    I am on windows and having email issues.

  8. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    tryforce09,

    What type of email issues are you having?

  9. sailpilot
    Member
    Posted 5 years ago #

    I have similar problems. On Godaddy with a shared linux account and the email function seems to be intermittent.

    Sometimes on user registrations both the user and I (admin) receive an email, sometimes the user doesn't but I do. Sometimes neither recieves an email.

    Is there a setup in the Godaddy configuration that needs to be tweaked?

    this has been going on since I installed months ago.

    I called Godaddy and they claim its not their issue, but I believe it is.

    Now on version 2.7 but the problems are still there.

  10. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    I'd like to get you in touch with someone who can look in to this further. Please provide the domain name and we will be in contact with you.

  11. sailpilot
    Member
    Posted 5 years ago #

    I opened a ticket with you today. You can check that out ID: 5662047

  12. pshero
    Member
    Posted 5 years ago #

    @Vivid,
    Thanks so much for posting your solution. It solved my problem as well!

  13. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    I opened a ticket with you today. You can check that out ID: 5662047

    I wanted to follow up with the information our team gave you last week when we contacted you. This should help out other users as they stumble upon this thread.
    http://help.godaddy.com/article/951

  14. chalin09
    Member
    Posted 5 years ago #

    My email is still not working, even after trying windowsx.com's instructions. Below is the test result. Has anyone found another resolution for this issue?

    Test Message Sent

    The result was:

    bool(false)
    The full debugging output is shown below:

    object(PHPMailer)#81 (44) {
    ["Priority"]=>
    int(3)
    ["CharSet"]=>
    string(5) "UTF-8"
    ["ContentType"]=>
    string(10) "text/plain"
    ["Encoding"]=>
    string(4) "8bit"
    ["ErrorInfo"]=>
    string(44) "Language string failed to load: connect_host"
    ["From"]=>
    string(24) "chalin@fooditinerary.com"
    ["FromName"]=>
    string(14) "Food Itinerary"
    ["Sender"]=>
    string(0) ""
    ["Subject"]=>
    string(45) "WP Mail SMTP: Test mail to chalin09@gmail.com"
    ["Body"]=>
    string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
    ["AltBody"]=>
    string(0) ""
    ["WordWrap"]=>
    int(0)
    ["Mailer"]=>
    string(4) "smtp"
    ["Sendmail"]=>
    string(18) "/usr/sbin/sendmail"
    ["PluginDir"]=>
    string(0) ""
    ["Version"]=>
    string(5) "2.0.2"
    ["ConfirmReadingTo"]=>
    string(0) ""
    ["Hostname"]=>
    string(0) ""
    ["MessageID"]=>
    string(0) ""
    ["Host"]=>
    string(30) "relay-hosting.secureserver.net"
    ["Port"]=>
    int(25)
    ["Helo"]=>
    string(0) ""
    ["SMTPSecure"]=>
    string(0) ""
    ["SMTPAuth"]=>
    bool(true)
    ["Username"]=>
    string(24) "chalin@fooditinerary.com"
    ["Password"]=>
    string(6) "mickey"
    ["Timeout"]=>
    int(10)
    ["SMTPDebug"]=>
    int(2)
    ["SMTPKeepAlive"]=>
    bool(false)
    ["SingleTo"]=>
    bool(false)
    ["smtp"]=>
    object(SMTP)#82 (7) {
    ["SMTP_PORT"]=>
    int(25)
    ["CRLF"]=>
    string(2) "
    "
    ["do_debug"]=>
    int(2)
    ["do_verp"]=>
    bool(false)
    ["smtp_conn"]=>
    resource(89) of type (stream)
    ["error"]=>
    NULL
    ["helo_rply"]=>
    string(97) "250-p3nlsmtp03.shr.prod.phx3.secureserver.net
    250-PIPELINING
    250-SIZE 31457280
    250 8BITMIME
    "
    }
    ["to"]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(18) "chalin09@gmail.com"
    [1]=>
    string(0) ""
    }
    }
    ["cc"]=>
    array(0) {
    }
    ["bcc"]=>
    array(0) {
    }
    ["ReplyTo"]=>
    array(0) {
    }
    ["attachment"]=>
    array(0) {
    }
    ["CustomHeader"]=>
    array(0) {
    }
    ["message_type"]=>
    string(5) "plain"
    ["boundary"]=>
    array(2) {
    [1]=>
    string(35) "b1_2fe142b0d269a6d2af44e01e4f04c517"
    [2]=>
    string(35) "b2_2fe142b0d269a6d2af44e01e4f04c517"
    }
    ["language"]=>
    array(0) {
    }
    ["error_count"]=>
    int(4)
    ["LE"]=>
    string(1) "
    "
    ["sign_key_file"]=>
    string(0) ""
    ["sign_key_pass"]=>
    string(0) ""
    }
    The SMTP debugging output is shown below:

    SMTP -> FROM SERVER:
    220 p3nlsmtp03.shr.prod.phx3.secureserver.net ESMTP
    SMTP -> FROM SERVER:
    250-p3nlsmtp03.shr.prod.phx3.secureserver.net
    250-PIPELINING
    250-SIZE 31457280
    250 8BITMIME
    SMTP -> ERROR: AUTH not accepted from server: 502 unimplemented (#5.5.1)

    SMTP -> FROM SERVER:
    250 flushed

  15. jamiesdesigns
    Member
    Posted 5 years ago #

    Thank you! I got my blog to email using this plugin, but I used the following settings on my godaddy shared windows server:

    Step 1-8: just as windowsx.com posted
    Step 9: select "no encryption"
    Step 10: select No: Do not use SMTP authentication

    Do not enter a username or password.

    I guess this is a little less secure, but it worked for me. Thanks!

  16. LiaGr
    Member
    Posted 5 years ago #

    I'm facing the same problem. I've tried all the possible ways that are given in this forum but none of them worked for me. I also tried "relay-hosting.secureserver.net" with No SSL and No Encryption, This worked for "testing e-mail" and for "recovering your password link e-mail" , but there it stops. My new members cannot receive an e-mail of registering and i cannot retrieve my own password ( i had to change it from phpMyAdmin to access my blog).
    GoDaddy sent me an e-mail about the correct ports an servers but they don't work. Any help would be very usefull, since this is a priority topic for blog owners.

    Thank you in advance,
    Lia, Athens-Greece

  17. dragonelle
    Member
    Posted 5 years ago #

    Hi,

    I did what was mentioned above, and it hasn't worked. It's ended up with. Talked with GoDaddy staff several times tonight, and it still doesn't seem to work. Can anyone help?

    The result was:

    bool(false)

    The full debugging output is shown below:

    object(PHPMailer)#77 (45) {
    ["Priority"]=>
    int(3)
    ["CharSet"]=>
    string(5) "UTF-8"
    ["ContentType"]=>
    string(10) "text/plain"
    ["Encoding"]=>
    string(4) "8bit"
    ["ErrorInfo"]=>
    string(43) "SMTP Error: Could not connect to SMTP host."
    ["From"]=>
    string(29) "crystal@becomingcalgarian.com"
    ["FromName"]=>
    string(16) "Crystal Stephens"
    ["Sender"]=>
    string(0) ""
    ["Subject"]=>
    string(48) "WP Mail SMTP: Test mail to bridgitkong@gmail.com"
    ["Body"]=>
    string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
    ["AltBody"]=>
    string(0) ""
    ["WordWrap"]=>
    int(0)
    ["Mailer"]=>
    string(4) "smtp"
    ["Sendmail"]=>
    string(18) "/usr/sbin/sendmail"
    ["PluginDir"]=>
    string(0) ""
    ["Version"]=>
    string(5) "2.0.4"
    ["ConfirmReadingTo"]=>
    string(0) ""
    ["Hostname"]=>
    string(0) ""
    ["MessageID"]=>
    string(0) ""
    ["Host"]=>
    string(30) "relay-hosting.secureserver.net"
    ["Port"]=>
    string(3) "110"
    ["Helo"]=>
    string(0) ""
    ["SMTPSecure"]=>
    string(0) ""
    ["SMTPAuth"]=>
    bool(false)
    ["Username"]=>
    string(0) ""
    ["Password"]=>
    string(0) ""
    ["Timeout"]=>
    int(10)
    ["SMTPDebug"]=>
    int(2)
    ["SMTPKeepAlive"]=>
    bool(false)
    ["SingleTo"]=>
    bool(false)
    ["smtp"]=>
    object(SMTP)#76 (7) {
    ["SMTP_PORT"]=>
    int(25)
    ["CRLF"]=>
    string(2) "
    "
    ["do_debug"]=>
    int(2)
    ["do_verp"]=>
    bool(false)
    ["smtp_conn"]=>
    bool(false)
    ["error"]=>
    array(3) {
    ["error"]=>
    string(27) "Failed to connect to server"
    ["errno"]=>
    int(10060)
    ["errstr"]=>
    string(185) "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    "
    }
    ["helo_rply"]=>
    NULL
    }
    ["to"]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(21) "bridgitkong@gmail.com"
    [1]=>
    string(0) ""
    }
    }
    ["cc"]=>
    array(0) {
    }
    ["bcc"]=>
    array(0) {
    }
    ["ReplyTo"]=>
    array(0) {
    }
    ["attachment"]=>
    array(0) {
    }
    ["CustomHeader"]=>
    array(0) {
    }
    ["message_type"]=>
    string(5) "plain"
    ["boundary"]=>
    array(2) {
    [1]=>
    string(35) "b1_9d050a9c0ea1c699c9ce67cc73e4488a"
    [2]=>
    string(35) "b2_9d050a9c0ea1c699c9ce67cc73e4488a"
    }
    ["language"]=>
    array(13) {
    ["mailer_not_supported"]=>
    string(25) " mailer is not supported."
    ["provide_address"]=>
    string(55) "You must provide at least one mailer is not supported."
    ["execute"]=>
    string(19) "Could not execute: "
    ["instantiate"]=>
    string(36) "Could not instantiate mail function."
    ["authenticate"]=>
    string(35) "SMTP Error: Could not authenticate."
    ["from_failed"]=>
    string(35) "The following From address failed: "
    ["data_not_accepted"]=>
    string(30) "SMTP Error: Data not accepted."
    ["recipients_failed"]=>
    string(56) "SMTP Error: The following SMTP Error: Data not accepted."
    ["connect_host"]=>
    string(43) "SMTP Error: Could not connect to SMTP host."
    ["file_access"]=>
    string(23) "Could not access file: "
    ["file_open"]=>
    string(33) "File Error: Could not open file: "
    ["encoding"]=>
    string(18) "Unknown encoding: "
    ["signing"]=>
    string(15) "Signing Error: "
    }
    ["error_count"]=>
    int(1)
    ["LE"]=>
    string(1) "
    "
    ["sign_cert_file"]=>
    string(0) ""
    ["sign_key_file"]=>
    string(0) ""
    ["sign_key_pass"]=>
    string(0) ""
    }

    The SMTP debugging output is shown below:

    SMTP -> ERROR: Failed to connect to server: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    (10060)

  18. Mariam Talakhadze
    Member
    Posted 5 years ago #

    It doesn't work for me.

    But thing is that I have my email redirected to gmail hosts :(

    Is this the problem? :(

  19. kreigar
    Member
    Posted 5 years ago #

    I tried all the suggestions in this thread and got further than I did before, but now I get a blank screen when I either request a forgotten password or send the test message from the plug-in settings page.

    It takes a long time, then I just get a blank screen. It looks like something is timing out, but I get no errors at all - just nothing. I see the admin "skin" with the menu down the left, but the entire content area is blank. The url at this point is - http://mydomain.com/blog/wp-admin/options-general.php?page=wp-mail-smtp/wp_mail_smtp.php

    I can't even get to the "The result was:" screen. Do you guys have any suggestions on how to debug further?

  20. gedeo
    Member
    Posted 5 years ago #

    same here. what jamiesdesigns said worked for me.

Topic Closed

This topic has been closed to new replies.

About this Topic