WordPress.org

Ready to get started?Download WordPress

Forums

GoDaddy + Permalinks + Internal Server Error 500 (10 posts)

  1. bjtylerx
    Member
    Posted 6 years ago #

    WordPress 2.3.1
    Godaddy hosting
    using permalinks
    php5

    Initially I got an Internal Server Error 500 about 50% of the time when wp-cache was enabled. I disabled it it seemed to work for a couple days.

    Today the site now gets the Internal Server Error 500 100% of the time unless I turn mod_rewrite off...but then of course permalinks no longer work.

    The error log shows the following error:

    Tue Nov 6 13:04:18 2007] [error] [client xxx.xxx.xxx.xxx] Request exceeded the limit of 20 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

    The htaccess contents are as followed:

    # Force PHP5 to run as default (instad of PHP 4.3.11)
    AddHandler x-httpd-php5 .php
    AddHandler x-httpd-php .php4

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    #RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Any ideas, suggestions, or help would be greatly appreciated!

  2. bjtylerx
    Member
    Posted 6 years ago #

    This seems like a workaround but I modified the rewrite rule from this:
    RewriteRule . /index.php [L]

    To this:
    RewriteRule .*/$ /index.php [L]

    That seems to fix the problem.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    GoDaddy has specific problems with WP-Cache. There's fixes out there for this though, just have to edit WP-Cache a little bit. Google for it, you'll find it.

  4. bjtylerx
    Member
    Posted 6 years ago #

    Otto42 - thanks for the reply. The wp-cache issue is actually a secondary. I'm getting the above error with wp-cache disabled.

  5. lachh1
    Member
    Posted 6 years ago #

    I get a similar problem. Can anyone help? It seems whenever I go to the post index (creating a page for all posts, etc) get this error up top of the page:

    [WordPress database error: [Table 'ybc40.wp_post2cat' doesn't exist]
    SELECT p2c.category_id AS cat_id, COUNT(p2c.rel_id) AS numposts, UNIX_TIMESTAMP(max(p.post_date_gmt)) + '-8' AS last_post_date, UNIX_TIMESTAMP(max(p.post_date_gmt)) AS last_post_date_gmt FROM wp_post2cat p2c INNER JOIN wp_posts p ON p2c.post_id=p.id WHERE (p.post_status='publish' OR p.post_status='static') AND p.post_date_gmt<='2007-11-07 01:02:26' GROUP BY p2c.category_id ORDER BY numposts DESC}}}WordPress database error: [Table 'ybc40.wp_post2cat' doesn't exist]
    SELECT p2c.category_id AS cat_id, COUNT(p2c.rel_id) AS numposts, UNIX_TIMESTAMP(max(p.post_date_gmt)) + '-8' AS last_post_date, UNIX_TIMESTAMP(max(p.post_date_gmt)) AS last_post_date_gmt FROM wp_post2cat p2c INNER JOIN wp_posts p ON p2c.post_id=p.id WHERE (p.post_status='publish' OR p.post_status='static') AND p.post_date_gmt<='2007-11-07 01:02:26' GROUP BY p2c.category_id ORDER BY numposts DESCWordPress database error: [Table 'ybc40.wp_post2cat' doesn't exist]
    SELECT p2c.category_id AS cat_id, COUNT(p2c.rel_id) AS numposts, UNIX_TIMESTAMP(max(p.post_date_gmt)) + '-8' AS last_post_date, UNIX_TIMESTAMP(max(p.post_date_gmt)) AS last_post_date_gmt FROM wp_post2cat p2c INNER JOIN wp_posts p ON p2c.post_id=p.id WHERE (p.post_status='publish' OR p.post_status='static') AND p.post_date_gmt<='2007-11-07 01:02:26' GROUP BY p2c.category_id ORDER BY numposts DESCWordPress database error: [Table 'ybc40.wp_post2cat' doesn't exist]
    SELECT p2c.category_id AS cat_id, COUNT(p2c.rel_id) AS numposts, UNIX_TIMESTAMP(max(p.post_date_gmt)) + '-8' AS last_post_date, UNIX_TIMESTAMP(max(p.post_date_gmt)) AS last_post_date_gmt FROM wp_post2cat p2c INNER JOIN wp_posts p ON p2c.post_id=p.id WHERE (p.post_status='publish' OR p.post_status='static') AND p.post_date_gmt<='2007-11-07 01:02:26' GROUP BY p2c.category_id ORDER BY numposts DESC]

    I get the feeling it's something simple but I don't know where to start. Any help is greatly appreciated.

  6. Ejournal
    Member
    Posted 6 years ago #

    I got the server error 500 on go daddy immediately when click on any of the home page links. I deleted disabled the plug in and deleted the cache and deleted the plug in folder right away. I also did not see an increase in speed.

  7. woopop
    Member
    Posted 6 years ago #

    Could it be that GoDaddy's PHP5 is currently busted? I too experienced the 500 Internal Server Error when I went to my homepage, and I found that commenting out the two AddHandler lines in my .htaccess makes wordpress work. My Mediawiki installation, on the other hand, which requires PHP5, doesn't work either way.

  8. woopop
    Member
    Posted 6 years ago #

    Not sure if this helps anyone else, but I found this forum: http://www.webmasterworld.com/apache/3280354.htm which said this:

    The following two lines are an incorrect mixture of AddHandler and AddType syntax.

    AddHandler x-httpd-php5 .php
    AddHandler x-httpd-php .php4

    The php team produced a "hack" when first installing php on Apache, and we've lived with it ever since in the sense of "bad code" posted all over the Web. The correct notation (although it may not work either) is:

    AddType application/x-httpd-php5 .php
    AddType application/x-httpd-php .php4

    #
    AddHandler server-parsed .php
    AddHandler server-parsed .php4

    You may need only one of the two 'sets' above, and I'm not sure which. The "AddHandler" set is the technically-correct way to do it, but as I said, the php team used a "hack" and you may need to use the "AddType" set instead -or in addition to- the AddHandler set.

    The bolded set worked for me...

  9. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    PHP5 works perfectly well for me on GoDaddy hosting, without any issues. And I'm using these:

    AddHandler x-httpd-php5 .php
    AddHandler x-httpd-php .php4

    Whether it is correct or not is irrelevant, it's what GoDaddy's FAQs pages tell me to use, I use it, and it works. QED.

  10. givver
    Member
    Posted 6 years ago #

    I to had this problem. I am using GoDaddy as my host and I finally tracked down to the problem to WP-Cache. I have the problem fixed now and WordPress is working happily with WP-Cache and I even have it working with GZIP. If you would like to see how I fixed it then check out my blog. I also have a download link to to a modified WP-Cache that works with GoDaddy.
    http://www.givveronline.com/wordpress/godaddy-internal-server-error/

Topic Closed

This topic has been closed to new replies.

About this Topic