WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[resolved] GoDaddy Email Hosting - Emails Not Sending (7 posts)

  1. nick@in2itivesearch.com
    Member
    Posted 10 months ago #

    http://www.fastsecurecontactform.com/godaddy-email

    I've tried methods one and two with no success. The error that I get when trying to send a test is this:

    Website is In2itive Search.

    The result was:

    bool(false)
    The full debugging output is shown below:
    
    object(PHPMailer)#58 (65) {
      ["Priority"]=>
      int(3)
      ["CharSet"]=>
      string(5) "UTF-8"
      ["ContentType"]=>
      string(10) "text/plain"
      ["Encoding"]=>
      string(4) "8bit"
      ["ErrorInfo"]=>
      string(98) "The following From address failed: nick@in2itivesearch.com : Called Mail() without being connected"
      ["From"]=>
      string(23) "nick@in2itivesearch.com"
      ["FromName"]=>
      string(15) "In2itive Search"
      ["Sender"]=>
      string(23) "nick@in2itivesearch.com"
      ["ReturnPath"]=>
      string(0) ""
      ["Subject"]=>
      string(50) "WP Mail SMTP: Test mail to nick@in2itivesearch.com"
      ["Body"]=>
      string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
      ["AltBody"]=>
      string(0) ""
      ["MIMEBody":protected]=>
      string(69) "This is a test email generated by the WP Mail SMTP WordPress plugin.
    "
      ["MIMEHeader":protected]=>
      string(470) "Date: Wed, 30 Oct 2013 23:43:13 +0000
    Return-Path: nick@in2itivesearch.com
    To: nick@in2itivesearch.com
    From: In2itive Search
    Subject: WP Mail SMTP: Test mail to nick@in2itivesearch.com
    Message-ID: <39dcd6b899d6d5dd990353b72cf740fb@www.in2itivesearch.com>
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.4 (http://code.google.com/a/apache-extras.org/p/phpmailer/)
    MIME-Version: 1.0
    Content-Transfer-Encoding: 8bit
    Content-Type: text/plain; charset=UTF-8
    
    "
      ["mailHeader":protected]=>
      string(0) ""
      ["WordWrap"]=>
      int(0)
      ["Mailer"]=>
      string(4) "smtp"
      ["Sendmail"]=>
      string(18) "/usr/sbin/sendmail"
      ["UseSendmailOptions"]=>
      bool(true)
      ["PluginDir"]=>
      string(0) ""
      ["ConfirmReadingTo"]=>
      string(0) ""
      ["Hostname"]=>
      string(0) ""
      ["MessageID"]=>
      string(0) ""
      ["MessageDate"]=>
      string(0) ""
      ["Host"]=>
      string(30) "relay-hosting.secureserver.net"
      ["Port"]=>
      string(2) "25"
      ["Helo"]=>
      string(0) ""
      ["SMTPSecure"]=>
      string(0) ""
      ["SMTPAuth"]=>
      bool(false)
      ["Username"]=>
      string(0) ""
      ["Password"]=>
      string(0) ""
      ["AuthType"]=>
      string(0) ""
      ["Realm"]=>
      string(0) ""
      ["Workstation"]=>
      string(0) ""
      ["Timeout"]=>
      int(10)
      ["SMTPDebug"]=>
      int(2)
      ["Debugoutput"]=>
      string(4) "echo"
      ["SMTPKeepAlive"]=>
      bool(false)
      ["SingleTo"]=>
      bool(false)
      ["SingleToArray"]=>
      array(0) {
      }
      ["LE"]=>
      string(1) "
    "
      ["DKIM_selector"]=>
      string(0) ""
      ["DKIM_identity"]=>
      string(0) ""
      ["DKIM_passphrase"]=>
      string(0) ""
      ["DKIM_domain"]=>
      string(0) ""
      ["DKIM_private"]=>
      string(0) ""
      ["action_function"]=>
      string(0) ""
      ["Version"]=>
      string(5) "5.2.4"
      ["XMailer"]=>
      string(0) ""
      ["smtp":protected]=>
      object(SMTP)#59 (11) {
        ["SMTP_PORT"]=>
        int(25)
        ["CRLF"]=>
        string(2) "
    "
        ["do_debug"]=>
        int(2)
        ["Debugoutput"]=>
        string(4) "echo"
        ["do_verp"]=>
        bool(false)
        ["Timeout"]=>
        int(10)
        ["Timelimit"]=>
        int(30)
        ["Version"]=>
        string(5) "5.2.4"
        ["smtp_conn":"SMTP":private]=>
        bool(false)
        ["error":"SMTP":private]=>
        array(1) {
          ["error"]=>
          string(37) "Called Mail() without being connected"
        }
        ["helo_rply":"SMTP":private]=>
        NULL
      }
      ["to":protected]=>
      array(1) {
        [0]=>
        array(2) {
          [0]=>
          string(23) "nick@in2itivesearch.com"
          [1]=>
          string(0) ""
        }
      }
      ["cc":protected]=>
      array(0) {
      }
      ["bcc":protected]=>
      array(0) {
      }
      ["ReplyTo":protected]=>
      array(0) {
      }
      ["all_recipients":protected]=>
      array(1) {
        ["nick@in2itivesearch.com"]=>
        bool(true)
      }
      ["attachment":protected]=>
      array(0) {
      }
      ["CustomHeader":protected]=>
      array(0) {
      }
      ["message_type":protected]=>
      string(5) "plain"
      ["boundary":protected]=>
      array(3) {
        [1]=>
        string(35) "b1_39dcd6b899d6d5dd990353b72cf740fb"
        [2]=>
        string(35) "b2_39dcd6b899d6d5dd990353b72cf740fb"
        [3]=>
        string(35) "b3_39dcd6b899d6d5dd990353b72cf740fb"
      }
      ["language":protected]=>
      array(18) {
        ["authenticate"]=>
        string(35) "SMTP Error: Could not authenticate."
        ["connect_host"]=>
        string(43) "SMTP Error: Could not connect to SMTP host."
        ["data_not_accepted"]=>
        string(30) "SMTP Error: Data not accepted."
        ["empty_message"]=>
        string(18) "Message body empty"
        ["encoding"]=>
        string(18) "Unknown encoding: "
        ["execute"]=>
        string(19) "Could not execute: "
        ["file_access"]=>
        string(23) "Could not access file: "
        ["file_open"]=>
        string(33) "File Error: Could not open file: "
        ["from_failed"]=>
        string(35) "The following From address failed: "
        ["instantiate"]=>
        string(36) "Could not instantiate mail function."
        ["invalid_address"]=>
        string(15) "Invalid address"
        ["mailer_not_supported"]=>
        string(25) " mailer is not supported."
        ["provide_address"]=>
        string(54) "You must provide at least one recipient email address."
        ["recipients_failed"]=>
        string(45) "SMTP Error: The following recipients failed: "
        ["signing"]=>
        string(15) "Signing Error: "
        ["smtp_connect_failed"]=>
        string(22) "SMTP Connect() failed."
        ["smtp_error"]=>
        string(19) "SMTP server error: "
        ["variable_set"]=>
        string(30) "Cannot set or reset variable: "
      }
      ["error_count":protected]=>
      int(2)
      ["sign_cert_file":protected]=>
      string(0) ""
      ["sign_key_file":protected]=>
      string(0) ""
      ["sign_key_pass":protected]=>
      string(0) ""
      ["exceptions":protected]=>
      bool(false)
    }
    The SMTP debugging output is shown below:
    
    SMTP -> ERROR: Failed to connect to server: Connection refused (111)
    
    The following From address failed: nick@in2itivesearch.com : Called Mail() without being connected

    http://wordpress.org/plugins/si-contact-form/

  2. Mike Challis
    Member
    Plugin Author

    Posted 10 months ago #

    Is that email setup in the godaddy control panel? That is a requirement.

    Looks like you set up the SMTP as recommended but the smtp log says connection refused. You would have to contact godaddy support about that issue.

    It does not appear you are following this instruction:
    For best results the “Email To” and the “Return-path address” should be separate GoDaddy email addresses on the SAME DOMAIN as your web site. These settings are on the Basic settings tab of the form edit page.

    Why were you trying Method 2, did you already try Method 1?

  3. nick@in2itivesearch.com
    Member
    Posted 10 months ago #

    We are getting in contact with GoDaddy, but yes we had tried step one already.

  4. Mike Challis
    Member
    Plugin Author

    Posted 10 months ago #

    OK let me know how they resolve it

  5. Mike Challis
    Member
    Plugin Author

    Posted 9 months ago #

    What happened? Did you resolve this? How?

  6. nick@in2itivesearch.com
    Member
    Posted 9 months ago #

    There was a setting on HostGator, the email was setup to work locally with hostgator instead of remotely with another hosting company. Since we were using GoDaddy instead of HostGator for email.

  7. dadvan
    Member
    Posted 2 months ago #

    Log into your cPanel and hit MX Entry > Email Routing > Remote Mail Exchanger (instead of Local Mail Exchanger). If you do not have access to this setting you can call Godaddy and ask them to do it.

Reply

You must log in to post.

About this Plugin

About this Topic