WordPress.org

Ready to get started?Download WordPress

Forums

GoDaddy email (4 posts)

  1. mbcoop
    Member
    Posted 4 years ago #

    I have been trying for months now to get my GoDaddy hosted WordPress site (Windows hosting) to sent our emails. I have my mail hosted by gmail.

    I recently tried Cimy Swift SMTP. I used all their default settings for gmail an get the following error stack:

    Fatal error: Uncaught exception 'Swift_ConnectionException' with message 'The SMTP connection failed to start [smtp.gmail.com:587]: fsockopen returned Error Number 10060 and Error String 'A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. '' in D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\Swift\php5\lib\Swift\Connection\SMTP.php:309 Stack trace: #0 D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\Swift\php5\lib\Swift.php(216): Swift_Connection_SMTP->start() #1 D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\Swift\php5\lib\Swift.php(101): Swift->connect() #2 D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\swift_engine.php(69): Swift->__construct(Object(Swift_Connection_SMTP)) #3 D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\cimy_swift_smtp.php(203): wp_mail('mike@cooperusa....', 'Cimy Swift SMT in D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\Swift\php5\lib\Swift\Connection\SMTP.php on line 309

    I switched it to port 465 (as Cimy suggests) ... and

    Fatal error: Uncaught exception 'Swift_ConnectionException' with message 'The SMTP connection failed to start [tls://smtp.gmail.com:465]: fsockopen returned Error Number 10060 and Error String 'A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. '' in D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\Swift\php5\lib\Swift\Connection\SMTP.php:309 Stack trace: #0 D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\Swift\php5\lib\Swift.php(216): Swift_Connection_SMTP->start() #1 D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\Swift\php5\lib\Swift.php(101): Swift->connect() #2 D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\swift_engine.php(69): Swift->__construct(Object(Swift_Connection_SMTP)) #3 D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\cimy_swift_smtp.php(203): wp_mail('mike@cooperusa....', 'Cimy Swi in D:\Hosting\4088399\html\liberty\wp-content\plugins\Cimy_Swift_SMTP\Swift\php5\lib\Swift\Connection\SMTP.php on line 309

    Has anyone got Godaddy WordPress hosting to send emails via TLS or SSL google mail?

    --mike

  2. scottbothel
    Member
    Posted 4 years ago #

    Stuck on this too... saw some reference to php.ini settings and I would appreciate any help.. did you get it figured out?

  3. scottbothel
    Member
    Posted 4 years ago #

    In conversation with Godaddy, the word is that on a shared server they will not allow mail to be sent via any other method than the standard unencrypted, non-smtp authenticated means via smtp-out.secureserver.net. The way around it is to purchase a vps package at $24/mo with a dedicated IP and SSL cert.

  4. eurekabirds
    Member
    Posted 4 years ago #

    So nobody with GoDaddy and WordPress has figured out an alternate solution?

Topic Closed

This topic has been closed to new replies.

About this Topic