WordPress.org

Ready to get started?Download WordPress

Forums

GoDaddy and mod_rewrite (24 posts)

  1. injinuity
    Member
    Posted 9 years ago #

    Host: Godaddy.com

    I seem to be having problem with wordpress as is suggested by godaddy technical staff...

    My server is displaying the following problem.

    <i>
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/1.3.31 Server at http://www.arrogantly.com Port 80</i>

    This is the godaddy.com technical staff response.

    <i>
    This email is in regards to the issue that you had escalated on 22 March 2005. The problem is the .htaccess file is trying to parse the php urls. We do have a fix that should be released globally soon. Right now, if you remove the .htaccess file, it will allow the welcome.html file to resolve, though you may want to see if WordPress has something you can do now to fix the issue. If you have any other questions or concerns please feel free to contact our customer support team.

    Sincerely,
    Josh A
    Advanced Technical Support
    </i>

  2. injinuity
    Member
    Posted 9 years ago #

    what do you guys think is the real problem.. is it at godaddy's end or at W.P's end.. if its at W.P's end. is there a patch for the same.?

  3. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Was it ever working ?

  4. Jinsan
    Member
    Posted 9 years ago #

    As Podz asks was it ever working? THe htaccess file isn't there by default, so I would ask was it working without htaccess, if so and GoDaddy do state that it doesn't quite work well with them then you'll have to wait for their fix. For my host the htaccess has never been an issue and has never caused any problems.

    The problem is the .htaccess file is trying to parse the php urls.

    I thought that's what it was supposed to do in the case of WP so it's not a design fault.

  5. injinuity
    Member
    Posted 9 years ago #

    actually I didnt enable it initially and it was working perfectly... then I installed... a few plugins... the comment spell checker, spam karma and the no follow plugin and then somehow the .htaccess file was created.
    As they stated once I deleted it, its back working now.. guess I shall wait longer to completely import from blogger.

  6. Jinsan
    Member
    Posted 9 years ago #

    ok try this:

    disable all your plugins

    add the htaccess files again, ensuring it is writeable by WP without you have to copy and paste anything into it. So it should be completely blank. Update your permalinks and then try to view the site.

    You say the htaccess file was somehow created, in which case I would delete it and create a blank notepad page upload that rename it to .htaccess and then do the permalink jig.
    If it works, then it could be a plugin issue, if it doesn't work then I guess it's a GoDaddy issue though I know several sites that use GoDaddy and permalinks.

  7. injinuity
    Member
    Posted 9 years ago #

    hm...thanks a lot... shall try it my friend.

  8. Daynah
    Member
    Posted 9 years ago #

    Yea, your .htaccess is messing up the links.

    Because if you go straight to the post: http://www.arrogantly.com/?p=1 it works perfectly fine.

    I think something is wrong with your permalinks

    Go to

    http://www.arrogantly.com/wp-admin/options-permalink.php

    Are the "Structure" and "Category Base" textfields blank? If not, try clearing them and see if it works... Hope that helps!

    Your layout is very nice btw. :)

  9. Cypher
    Member
    Posted 9 years ago #

    Go to the Permalinks options page as the above post describes and ensure that you just enter "/%year%/%monthnum%/%day%/%postname%/" without the quotes. Do not enter the word Structure:, which you have looking at the links on your website below:

    www.arrogantly.com/Structure:%20/2005/03/20/hello-world/

    Regards

  10. Daynah
    Member
    Posted 9 years ago #

    Cypher, I'm just curious, even if he changes that, wouldn't the first link be: http://www.arrogantly.com/2005/03/20/hello-world/ ?

    And he still gets that error. I think the host doesn't allow mod_rewrite. But I'm not sure.

  11. Root
    Member
    Posted 9 years ago #

    This would be a windows server ?

  12. injinuity
    Member
    Posted 9 years ago #

    absolutely right cypher.... absolutely right... my mistake I guess..

    and no root.. its a linux server.

  13. injinuity
    Member
    Posted 9 years ago #

    as phpprincess say, even with the updated permalinks structure I still cannot acces the first post i.e http://www.arrogantly.com/2005/03/20/hello-world/ but then again now I have deleted the .htaccess file ... is it mandatory?

  14. Jinsan
    Member
    Posted 9 years ago #

    you could simply go with the non-hteaccess method of permalinks which would place the index.php followed by category/postname instead until the fix arrives from GoDaddy. It's an odd problem, but I think there is a simple solution as it really should work under "typical" conditions.

    So delete your htaccess file and use the index.php prefix instead.

  15. injinuity
    Member
    Posted 9 years ago #

    thanks jinsan... I think I will wait a little more longer to see what godaddy can come up with..

  16. Cypher
    Member
    Posted 9 years ago #

    A few things before we all confuse each other. :)

    @phpprincess; Yes, the host has have mod_rewrite capabilities turned on for permalinks to work in the "nice" way.

    @injinuity; Without the .htaccess file, the web server is not going to be able to translate the permalinks to it's respective real links, so you really do need the file.

    So for starters, confirm with your host that mod_rewrite is enabled/available. Then you can have WP setup the .htaccess file, or create it yourself and see if things work.

    If all else fails, you can definitely use Jinsan's suggestion and just prefix the permalink structure with index.php.

    Regards

  17. injinuity
    Member
    Posted 9 years ago #

    godaddy tech support has just informed me that mod_rewrite is currently unavailable... in which case I have one question whether this is essentialfor the smooth running of WP...

  18. injinuity
    Member
    Posted 9 years ago #

    for those who might still be wondering about godaddy and mod rewrite.

    They now fully support mod rewrite.

    Its a good hosting serivce, value for money, the only drawback is their support which though it gets the work done, is always late with a solution.

  19. btkhoo
    Member
    Posted 9 years ago #

    I am using godaddy and I just tried mod_rewrite, it works

  20. sugarfish
    Member
    Posted 8 years ago #

    Well, let me add to the discussion!

    I have an existing GoDaddy domain which I've had for about 6 months. I installed WordPress and had no issues with permalinks. I was ecstatic with the service.

    I recently created a second domains, also hosted with GoDaddy. I installed WordPress there also, but permalinks are no go. In addition I also tried to prevent access to a directory using .htaccess. This also doesn't work (at all), but when I try it on my other GoDaddy domain it works superfine.

    So, now I'm in the middle of a p***ing match with GoDaddy's support who want to charge me money to troubleshoot WordPress ("third party code").

    I believe that this second domain (which is apparently on a different box than my first domain) is not recognizing the .htaccess files. This sounds logical right?

    I'll keep you posted...

  21. injinuity
    Member
    Posted 8 years ago #

    I am the authority on this issue, trust me .. I have spend many hours on this issue...

    you will have to tell support that if your hosting is on a server that does not have mod_rewrite enabled then to move it to one that has mod_rewrite enabled.

    They recently had a problem with the parsing of urls from the .htaccess file.. so check whether the patch to solve the error was run on the server hosting your domain.

  22. ianozsvald
    Member
    Posted 8 years ago #

    I too lost mod_rewrite with GoDaddy, the reason for me was upgrading from the Basic service to the Deluxe CGI/PHP option. During the update there is a 72 hr period during which some things (including mod_rewrite) are disabled. I had a customer service rep confirm this for me.

    After 72 hrs mod_rewrite became available again, and all my WordPress features worked again (previously I'd lost permalinks, trackbacks, categories, comments etc). Everything is fine now (ianozsvald.com)

  23. tcort
    Member
    Posted 8 years ago #

    If you are still having problems with permalinks, then check out my brief tutorial on getting Search Engine Friendly URLs on GoDaddy.

  24. Dan Masters
    Member
    Posted 8 years ago #

    Unfortunately the above link is dead.

    After talking to Godaddy's tech support we came up with the solution.

    You can see it in my post here

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.