WordPress.org

Ready to get started?Download WordPress

Forums

GoDaddy and Error establishing a database connection (8 posts)

  1. Lifespring
    Member
    Posted 8 years ago #

    I've read through the previous posts on this subject and haven't been able to get WP past this error screen. I've contacted GoDaddy to confirm that my DB name, User name, Password and host name are all correct. Still no luck. Can anybody help me?

  2. brucegottlieb
    Member
    Posted 8 years ago #

    This is how I got it to work at GoDaddy,

    Inside your wp-config.php file, the DB_NAME and DB_USER are the same (name of your database). The DB_HOST didn't work with the default 'localhost' value for me, so I went into the Hosting Manager (at GoDaddy) and found out the actual MySQL Host Name to get it to work. Mine was mysql75.secureserver.net, but yours may be different.

  3. Lifespring
    Member
    Posted 8 years ago #

    I've done all that. I confirmed with GoDaddy's techs that I have entered the host name correctly, and all other fields. Still I get the error.

    Now what???

  4. Are you editing the correct field value in wp-config.php? It would be the value on the right. The value on the left identifies the field. More info:

    http://codex.wordpress.org/Editing_wp-config.php

  5. Lifespring
    Member
    Posted 8 years ago #

    I believe I am. Here's the entry:
    (I have replaced my real data with "xxxx" and "yyyy")

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'xxxx'); // The name of the database
    define('DB_USER', 'xxxx'); // Your MySQL username
    define('DB_PASSWORD', 'yyyy'); // ...and password
    define('DB_HOST', 'mysq167.secureserver.net'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'shownotes'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

  6. belverbears
    Member
    Posted 8 years ago #

    I just had the same problem. I went to the WordPress installation page and it said to change the words on the left (between the quote marks). I did that and I was able to get the database connection to work. Changing the words on the right (after the slashes) didn't work for me.

    Belver

  7. wblr
    Member
    Posted 8 years ago #

    Hi, i'm having the same problem.

Topic Closed

This topic has been closed to new replies.

About this Topic