WordPress.org

Ready to get started?Download WordPress

Forums

Go Daddy database connection issues on new install (23 posts)

  1. nomis78
    Member
    Posted 5 years ago #

    Help Trying to install wordpress for the first time and keep coming up with this error, ive check all the information several times and its all correct. ive deleated and recreated the config file, ive done everything i can think of but nothings working.

    Im using go daddys free hosting that came with my domain name purchase (since they wont let me use the automated service for some reason unbeknown to either me or there support staff)

    --

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at (server location). This could mean your host's database server is down.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?

    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

  2. MichaelH
    Member
    Posted 5 years ago #

    Best bet is to get a Linux hosting account that is not free (you will have some issues with WordPress on those Free with Domain type accounts).

    With that said, please review Step 2 in Installing_WordPress. At Godaddy you create the database and the database name and database user are the same and you provide the password. Once the database is create you will be able to see the database server/host and that is your DB_HOST value.

  3. thisisedie
    Member
    Posted 5 years ago #

    Please note that with Godaddy the host name is NOT localhost. Look at the database details to get the host addy.

  4. nomis78
    Member
    Posted 5 years ago #

    the hosting is on linux servers and is using php 5.x

    i have inputted to database name and the database host values i have also inputted the correct password and have changed local host to the required host name.

    i get through step 1 where i input all theses details into the pages provided, the page tells me that details are correct and i can no commence installation

    i click install and then get directed to the page showing the error notice i put into the first post.

    i have contacted go daddy and they have informed that there is nothing at fault with the database servers nor the host and that the issue is that of a scripting error and have effectively washed there hands on the matter.

  5. D4W50N
    Member
    Posted 5 years ago #

    dreamhost has one click installation - unlike hostmonster, they upgraded wordpress the time when wordpress release new version. I recommend dreamhost especially for wordpress users and users who are not very familiar with database like me.

  6. nomis78
    Member
    Posted 5 years ago #

    Dawson im not looking for a new host, i have one, what i am looking for is a resolution to the problem i have

  7. MichaelH
    Member
    Posted 5 years ago #

    nomis78 - if you have confirmed that the information in wp-config.php is correct and matches the database that you setup, AND you have contacted Godaddy support and they say it is a scripting error, then why not start over from Step 1 of Installing WordPress?

    This topic is tagged so maybe someone from godaddy will come along and offer some other solution.

    Oh, you might also rename wp-config.php to wp-config-hold.php, then visit yourdomain.com/install.php and let the install routine ask you for the database info and it will create a wp-config.php file for you.

    I do have to reiterate that WordPress may not work too well with a free hosting plan.

    Also Godaddy offers a WordPress install via the Hosting Connection so see if you can install that way.

  8. nomis78
    Member
    Posted 5 years ago #

    thanks MichaelH

    the install through hosting connection is not open to me thanks to go daddys policies, the account i hold is the same as there low level hosting accounts except with some things through hosting connection disabled.

    i shall try it again from step one however i would be gratefull if anyone else has any more input

  9. xlent1
    Member
    Posted 5 years ago #

    actually, I got same "script error" story from GoDaddy the other day also. My little site london2nice.com stopped working altogether on 27 Jan. I was away and noticed it and called them. Strange thing is that all the pieces are the same and you can find files...only the php is not running at all.

    I am running mysql 4.1.

    No real idea on why it just died, but maybe something related to php and database connection?

  10. Elpie
    Member
    Posted 5 years ago #

    To get the host name to use in wp_config for databases hosted with GoDaddy, just read this GoDaddy FAQ: http://help.godaddy.com/topic/67/article/39

    Once you set up your database, make a note of the host name, database user name, database name and password. Use these to complete the WordPress configuration.

  11. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    actually, I got same "script error" story from GoDaddy the other day also. My little site london2nice.com stopped working altogether on 27 Jan.

    xlent1,

    Did you get this issue resolved? Let me know how I can help.

  12. zombiebaby
    Member
    Posted 4 years ago #

    For those still needing help with this I struggled for two days looking for a solution to the very issue described in this first post. It turned out I had to log into the Hosting Control Center. On the Home tab is the Account Summary and if you click on "View" next to "Primary Domain DNS" the field will expand and tell you that your site is available for preview. You have to make the site live. It takes about an hour for the site to go live. After it was live I opened an ftp connection using FileZilla and deleted the wp-config.php file leaving only the wp-config-sample.php file.
    Next I went to my domain (www.your domain.com) and it prompted me to create the wp-config.php file again. (I had done this before but it hadn't worked)
    I input the database name, username, password, and host name I had been trying previously. (These are found through this path -- Hosting Control Center/Databases/MySQL/Edit (the pencil graphic))
    I received an error message after clicking install, however when I went to log into my domain (www.yourdomain.com/wp-admin) I was prompted for my username and password by WordPress and I was able to log into my site and begin working on it.
    I hope this helps!!

  13. d3madmin
    Member
    Posted 4 years ago #

    My site has been hosted at godaddy.com and was just fine for a monrh until yesterday something went wrong. I could no longer access my site thru wp-login.php and when I tried to view it all I can see is a blank window. Is this a wordpress problem? I've already sent an e-mail with godady support but got no reply as of this time. Any idea please?

    My url is http://onlyinthephilippines-atibapa.com

  14. Go Daddy
    Go Daddy Support
    Posted 4 years ago #

    @d3madmin

    This could happen if you upgrade in Hosting Connection and you upgrade manually through WordPress as well. Our support can confirm this and provide you with a resolution. Support information can be found here: http://www.godaddy.com/community/community.aspx

  15. d3madmin
    Member
    Posted 4 years ago #

    That's the recommendation of the GD support staff and have done it already but my site sill could not be viewed. Besides, I have manually upgraded after this problem happened and not before, upgrading manually could not have been the cause of the problem

  16. heath bern
    Member
    Posted 4 years ago #

    zombiebaby, thank you! I have been searching for days on end to a solution to my problem. I truly appreciate your post.

  17. Alexander Stanuga
    Member
    Posted 4 years ago #

    Ah I see others have had some similar issues with Godaddy & WordPress. I have recently uploaded my wordpress site and everything was running well, until about two days ago, I now get the dreaded error establishing a database connection.

    I have tried everything in this post, checked, re-checked my wp-config.php file, deleted it and gone through the steps described by zombiebaby but still no luck. The only thing I can think of is there might be an issue with WordPress 2.9.1 as the last thing I had recently done on the site was an upgrade.

    If anyone else has had these problems recently, and found a solution, please, I would love to hear from you. my site is below

    http://www.stanuga.net

  18. cyephotography
    Member
    Posted 4 years ago #

    I'm having the same issue since upgrading to WP 2.9.1.

    I upgraded to 2.9.1 last night and my site was OK this morning. I uploaded some new pics for the WP NextGEN gallery plug-in and then everything went down.

    Prior to installing WP 2.9.1, my site has been live and running without issue for almost a year.

    I have checked the wp-config.php file. It is correct.

    I'm getting the same error and can't login in at wp-admin. When I try my site I get a 500 Internal Server Error.

    Anyone had any luck getting this fixed?

    http://cyephotography.com

  19. Go Daddy
    Go Daddy Support
    Posted 4 years ago #

    @alex.s and @cyephotography
    Just came across your posts. Looks like things are okay with your sites now. Please let me know if you still need some assistance.

  20. dmtolbert
    Member
    Posted 4 years ago #

    I see that the problems must have been corrected with the previous posts. I have tried everything. Calling GoDaddy, checking my config file over and over. Can someone tell me how they fixed their sites?

  21. Go Daddy
    Go Daddy Support
    Posted 4 years ago #

    @dmtolbert
    If you feel comfortable, please post the domain name.

  22. overhaulmedia
    Member
    Posted 4 years ago #

    My site will not connect, checked the wp_config.php about 100 times.

    http://maximumfighting.com/videoblog

  23. dougolupski
    Member
    Posted 4 years ago #

    FYI for all new installs out there. I followed Zombiebaby's advice after three days of hell and with a few extra steps I am working. Here we go. I ftp'ed the entire wordpress 2.9 into my files under hosting control with out updating wp-config-sample or creating a new wp-config. Basically downloaded it from wprdpress and then re uploaded it. Then followed zombiebaby's info, all of your setting are located in hosting control/databases/my sql then click the pencil icon to see your info. Once that was completed it tried to install but since all of the files were there it couldn't. So I went into hosting control/databases/my sql and clicked the manage button nexted to your host name which will take you to a logn screen. Your name is what your HOST name is not your account name. Then input your password, after that navigate to databases and then your database name. Drop (delete)the 20 some odd files in there and log out. After that type your url plus /wp-admin/install.php . It should take you through the rest of in setup process.

    I hope this helps, this has been a three day ordeal and a lot of angry emails.

Topic Closed

This topic has been closed to new replies.

About this Topic