WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Go Daddy and Automatic Upgrade...Need Advice (3 posts)

  1. marcpflyer
    Member
    Posted 2 years ago #

    Hello-

    I have a Godaddy Linux account, and used their automatic install of WordPress several years ago successfully. Over the years, I have updated WordPress directly through the automatic update feature in the dashboard with no problems until I have tried to go from 3.2.1 to 3.3.1, and I get the following error:

    [Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Apache Server at (mydomain).com Port 80]

    I contacted GoDaddy, and they say I should run a WordPress Patch through their application manager, although I am not sure what this does or if it will roll-back to earlier WordPress version (they implied it will go back to 2.7.1).

    Anyone experience something similar, and have advice on how I should proceed? Do you think this patch solves server-side issues beyond the WordPress upgrade itself?

    Thank you,

    Marc

  2. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Try:
    - switching to the Twenty Eleven theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    - re-running the upgrade via wp-admin/upgrade.php

  3. marcpflyer
    Member
    Posted 2 years ago #

    Esmi-

    Thanks for the advice. Strange...I just logged in again today to my dashboard, tried the automatic install again (it looked like it failed). Now, just logged in again to my dashboard and I am now at 3.3.1. Maybe Go Daddy was having some other types of issues yesterday that prevented it from working?

    I assume I shouldn't follow the Go Daddy patching at this point, since I have been upgrading directly via WordPress. Hopefully this continues working in the future.

    Regards,

    Marc

Topic Closed

This topic has been closed to new replies.

About this Topic