WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form Clean and Simple
[resolved] "Go back and try again. Error: empty answer. []" (8 posts)

  1. Ian
    Member
    Posted 5 months ago #

    Contact form submission results in a page with the message "Go back and try again. Error: empty answer. []". Works fine when logged in but of course that's no use to everyone else! The page is "http://maxandcarolines.com/contact". Any help gratefully received.

    https://wordpress.org/plugins/clean-and-simple-contact-form-by-meg-nicholas/

  2. megnicholas
    Member
    Plugin Author

    Posted 5 months ago #

    That is a very odd error message, that error is not part of the code. I wonder if you have a conflict with another plugin or your theme?

    Can you disable all your plugins and then go back to the default (2013/2014) wordpress theme and then try it again.

    If all is well, add back each component one by one until you get the problem again.

    Let me know how you get on.

    Meg

  3. Ian
    Member
    Posted 5 months ago #

    Hi Meg. Thanks for response. I had suspected that might be the case as I've used the plugin before without problems on another site. All settings are the same... only difference is the Theme.

    If we assume it to be conflict with the Theme ("Thoughts" v2.0 by WPExplorer) is there anything that can be done? Or am I best finding another plugin?

  4. megnicholas
    Member
    Plugin Author

    Posted 5 months ago #

    Is this a premium theme? If you have support it might be worth going to WPExplorer for help. It doesn't seem to be on the wordpress.org theme list so I can't download it.

  5. megnicholas
    Member
    Plugin Author

    Posted 4 months ago #

    Hi there. As I haven't heard back from you I am marking this support thread as 'resolved'.

  6. Ian
    Member
    Posted 4 months ago #

    Hi Meg. Sorry, I thought I'd concluded this myself. I discovered that "Use client side validation (AJAX)" – the very last setting was not checked and that checking it solved the problem. I'm not sure what that does but I've used the contact form on 3 sites now and on two it works checked and the other not checked. If you understand that I'd love it if you could explain.

    many thanks
    Ian

  7. megnicholas
    Member
    Plugin Author

    Posted 3 months ago #

    Hi Ian,

    I've made AJAX form validation and submission optional in order to cater for instances where it won't work with the chosen theme. It should work with most themes but there are always exceptions.

    If you come across this problem again with a premium theme it is best if you go to the theme author for help. For free ones I can help you. The problem is that in order to troubleshoot the problem I need to have a copy of the theme code on my computer which I can only do for free themes.

    Thanks, Meg

  8. Ian
    Member
    Posted 3 months ago #

    Thanks Meg!... Resolved, understood and very much appreciated!

Reply

You must log in to post.

About this Plugin

About this Topic