WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
Gmail contacts never arrive (11 posts)

  1. biodrama
    Member
    Posted 5 months ago #

    When the sender is a Gmail address, the contact email never arrives. All other email addresses arrive just fine.

    http://wordpress.org/plugins/si-contact-form/

  2. Mike Challis
    Member
    Plugin Author

    Posted 5 months ago #

    Here is the help page;
    http://www.fastsecurecontactform.com/email-does-not-send

    For best results the “Email To” and the “Return-path address” should be separate email addresses on the SAME DOMAIN as your web site.

  3. biodrama
    Member
    Posted 5 months ago #

    Thanks Mike,

    I have done as you suggest, and will test the form again soon, and report back with results. Testing the form involves getting its owner on the phone, because the contact emails go to them, not me. But could lack of a Return-path address cause a Gmail-specific failure?

  4. Mike Challis
    Member
    Plugin Author

    Posted 5 months ago #

    Yes because without a Return-path address on the same domain, your message could be flagged as spam and go to a black hole.

  5. biodrama
    Member
    Posted 5 months ago #

    OK. Thanks for filling me in about this!

  6. biodrama
    Member
    Posted 5 months ago #

    To save time, I tried the same fix on a blog that I own. After inputting a separate Return-path address on the same domain, Fast Secure Contact Form is still failing to work when the sender uses a Gmail address. Other addresses come right through.

  7. Mike Challis
    Member
    Plugin Author

    Posted 5 months ago #

    Perhaps you should contact your web host about mail delivery problem. The form is set correctly

  8. biodrama
    Member
    Posted 5 months ago #

    OK, I will do that, and relay whatever I learn from Dreamhost.

  9. biodrama
    Member
    Posted 5 months ago #

    I have had a dialog with a Dreamhost support person. I am not convinced he understood the issue. I am at a total loss to understand how what he said applies to the issue in question. Here is the exchange:

    Me:
    Subject: Contact Form will not send Gmail contacts
    I already contacted the developer of Fast Secure Contact Form, a WordPress plugin I use on a couple of sites hosted by you. That dialog is here: http://wordpress.org/support/topic/gmail-contacts-never-arrive

    The developer suggested I ask you about this. He says his contact form is not the problem, and it might be a mail delivery problem . Thanks for your time!

    Dreamhost Support:
    I believe the issue you are experiencing is due to our policy regarding
    outgoing mail requiring authentication:

    http://dhurl.org/20b

    The contact form you are using is attempting to send mail as an address
    not hosted here with DreamHost:

    From: A Person <some_name@gmail.com>

    This policy will block e-mail if the FROM address is not using an e-mail
    address hosted here at DreamHost.

    You will need to modify your form to send using a FROM address that
    belongs to one of your DreamHost domains. You can set the REPLY-TO field
    to any other e-mail address and the mail should send without issue.

    I hope this clears things up for you, if you have any other questions
    please feel free to contact technical support again.

    Me:
    Thanks for your suggestion, but I think something else is happening: If the "From" email address was the problem, the form would block all attempts, but in fact, the form fails Only when the sender (the person filling in the form) is using a Gmail address! All other email addresses work fine. I hope this helps...

    Dreamhost Support:
    The error is indeed the FROM address. The sender domain policy attempts
    to ensure that all mail originating from the server is from a DreamHost
    hosted e-mail address. The FROM address cannot be the person filling out
    the form, nor can it be any e-mail address that is not hosted here at
    DreamHost. You can view the bounced e-mails as well as the reasons why
    they were bounced by connecting as the domain user and navigating to the
    following folder:

    /home/my_stuff/Maildir/new

    I would recommend changing the FROM address in your contact form to
    something like postmaster@my_site.com . You can set the REPLY-TO
    address as the person filling out the form and the mail should send
    without issue.

    Me:
    I am sorry, but I am unable to understand what you are saying. Emails sent via the form have a "From" address of the sender who input their contact details. I don't see how I am responsible for this. A Contact Form must accept whatever email address the person types into it. In this case, the form is refusing to send Gmail addresses. All others are fine. What am I not seeing here? So far as I can see, I only set the "To" address, not the "From" address.

    Dreamhost Support:
    The FROM address cannot be a user inputted field at DreamHost. Even
    though your site visitor is filling out the form the e-mail is actually
    being generated from your website and this is why the e-mail address must
    have FROM address belonging to a DreamHost e-mail address.

    Allowing the form to be sent by any inputted e-mail address is commonly
    referred to as spoofing:

    http://wiki.dreamhost.com/Sender_Domain_Policy_and_Spoofing#What_is_email_spoofi ng.3F

    ---------
    What is email spoofing?

    When emails are sent, the program or script can say the sender is "from"
    any address they want. For example, you can send emails from your website
    example.com that are "from" King_of_Mars@SolarSystem.Milky.Way.
    ---------

    The FROM field in your contact forms must be an e-mail address here at
    DreamHost, as I have stated before you can set the REPLY-TO field as the
    user inputted e-mail address so that you can keep track of the user
    inputted e-mail address.

  10. Mike Challis
    Member
    Plugin Author

    Posted 4 months ago #

    To comply with what he wants, you go to the form edit page - Basic settings tab, then check this setting:
    "Enable ONLY when web host requires "Mail From" strictly tied to site"

    Most web hosts will be satisfied the mail comes from your site with this other setting: "Return-path address", you set to an email address on the same web domain as your web site. My web host (Hostgator), that is all I need.

    They are making you prove the mail comes from your site by going one step further with the requirement of the from address.

    Let me know if it works.

  11. biodrama
    Member
    Posted 3 months ago #

    Sorry for the delayed response. It did indeed work. Thank you!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags