WordPress.org

Ready to get started?Download WordPress

Forums

CM Tooltip Glossary
[resolved] Glossary Terms NOT working on posts (23 posts)

  1. asolis11
    Member
    Posted 1 year ago #

    Hello guys,
    thanks for this great plugin. I have a small problem and maybe is something wrong Im doing, I added few terms for the glossary and that looks great but when i go to the post I dont see any links there for the terms. I dont need the tooltip and I have turned that option off. Everything seen to work beautiful exception for the links.

    What can it be?

    thanks and I cant wait for the new update

    http://wordpress.org/extend/plugins/enhanced-tooltipglossary/

  2. CM Plugins
    Member
    Plugin Author

    Posted 1 year ago #

    Do you see the glossary page ? can you send a link to it ?
    and an example for a page which include a term in the glossary that does not show up

  3. asolis11
    Member
    Posted 1 year ago #

    Thanks for the prompt reply CM.
    http://www.ushealthy.com/glossary-terms/

    and here is a post sample that contain both of the terms
    http://www.ushealthy.com/home-remedies/home-remedy-for-acne.html

    please check on remedy #2 and Remedy #3

    thanks

  4. RyanLorem
    Member
    Posted 1 year ago #

    I am having a similar issue which happened both before and after updating to version 2.0.2.

    I have found the cause of one bug which is when there is a space character following the title of a glossary item. This can be solved going to the edit page for that item and removing any unwanted space following the title.

    The function trim() could be added to the plugin in the next update to force it to remove unwanted spaces before or after a glossary term. This is probably used on the glossary index, but not currently used to check the glossary title against posts/pages containing the term. Should be an easy fix. :)

    This solved most of the problems for me, but there are some glossary terms containing special characters such as $, & and ', which do not get linked to on a page, but do get linked to on the glossary index.

    I've noticed my theme converts this ' into the forward tick apostrophe.

    Please see these terms for example: "$100 DOWN PAYMENT PURCHASE", "MECHANIC’S LIEN", "MERCHANTS & MECHANIC’S LIEN", "METES & BOUNDS"

    Here is the glossary index:
    http://dreamloan.pro/glossary/

    Here is a page containing the same list of glossary terms for testing:
    http://dreamloan.pro/glossary-terms-check-hover-items/

  5. RyanLorem
    Member
    Posted 1 year ago #

    BTW, I'm using WPZoom Prime theme, in case that is the source of the problem. http://www.wpzoom.com/themes/prime/

  6. CM Plugins
    Member
    Plugin Author

    Posted 1 year ago #

    New version will be released today, that will fix your issues (ampersands, apostrophes, dollar sign).
    It was found out that the way characters are being transformed in the template strongly relies on server's configuration (charset mostly). In new version, UTF8 will be forced, so it should be OK in all environments.
    Please let us know if that will help after the new version is installed.

  7. RyanLorem
    Member
    Posted 1 year ago #

    Awesome! Thanks for all the great work.

  8. CM Plugins
    Member
    Plugin Author

    Posted 1 year ago #

    New Version in Up please update us if this solve the issues

  9. RyanLorem
    Member
    Posted 1 year ago #

    OK, testing 2.0.3 on this page:
    http://dreamloan.pro/glossary-terms-check-hover-items/

    It has repaired terms with $, but others, such as "BUYER’S AGREEMENT", "RATE/TERM OR RATE & TERM REFINANCE", "REALTOR®" and "CC&RS" are still not recognized. Unfortunately, we must include that reserved mark. :/

    If you think this may be caused by a theme issue, any tips on where to repair it?

  10. asolis11
    Member
    Posted 1 year ago #

    For me I still have the same problem as before, I havent notice any changes detecting the terms on the posts thanks

  11. CM Plugins
    Member
    Plugin Author

    Posted 1 year ago #

    We will work on this Monday, it is related to charset and special symbols, hope to manage fixing this next week

  12. asolis11
    Member
    Posted 1 year ago #

    Thanks CM's you guys have a nice Mod here and thanks for sharing it for FREE. Cant wait to see a clean version of this plugin.

  13. CM Plugins
    Member
    Plugin Author

    Posted 1 year ago #

    We released version 2.0.4, we don't think it solved the issue reported but let us know if u have any change after installation. We will release a new version tomorrow also

  14. RyanLorem
    Member
    Posted 1 year ago #

    No change here, as expected. Will test 2.0.5 tomorrow. Thank you!

  15. asolis11
    Member
    Posted 1 year ago #

    When It comes to adding the links to the terms used on the glossary to the posts still the same. :(
    I download the one tomorrow and see

    thanks guys

  16. asolis11
    Member
    Posted 1 year ago #

    As you can see in this new post is working to perfection. The old posts still the same issue as it didnt fixed them. Should I try deleting the post and reposting it again? or something else i should try?

    thanks Bud

  17. CM Plugins
    Member
    Plugin Author

    Posted 1 year ago #

    First of all, it seems that two things reported here are not related to each other, so let's treat them separately

    @asolis11 - unfortunately we were not able to reproduce your issue. We copied your content to http://dev1.cminds.com/acne/ but, as you can see, all terms are highlighted correctly. They don't contain any special characters, so the issue is really mysterious. Which editor do you use to insert your content? Is it default tinyMce or ckEditor or pure HTML editor? Do you type text in this editor or you copy/paste from somewhere?

    @RyanLorem - Same question to you - which editor do you use in WordPress? We found that tinymce and ckeditor handle special characters differently and the source is different.
    On your page, text: “BUYER’S AGREEMENT" and "CC&RS” is encoded as (spaces added because forum is stripping entities):
    BUYER’S AGREEMENT, CC& #038;RS
    On cminds.com, the same text is encoded as:
    BUYER& #8217;S AGREEMENT, CC& amp;RS
    And on my local machine it looks like this:
    BUYER& #39;S AGREEMENT, CC& amp;RS
    We need to find the common denominator

  18. asolis11
    Member
    Posted 1 year ago #

    Oh boy, that sucks for me. I make my own content no C/P and yes I have installed tinyMce and when I C/P anything from the web I do it using the Text tab instead of the Visual as that brings up unwanted characters or calls like <div> <tables> etc....
    What will be your suggestion for me to try if you have any CM?

    thanks once again for spending your time with us.

  19. RyanLorem
    Member
    Posted 1 year ago #

    I'm using the default text editor (html editor). I have just tested in a sandbox area using the Twenty Twelve theme in WordPress 3.5.1 with all other plugins deactivated. The link does not work yet.

    The DOM source show it as: BUYER’S AGREEMENT

    Is it possible that this is a server side issue?

    Here are some specs. Let me know if there is a setting to look for in phpinfo().

    x86_64 x86_64 x86_64 GNU/Linux
    CloudLinux Server release 5.9 (Sergey Oleynikov)
    PHP Version 5.3.19
    default_charset: no value
    CharConv: No
    mbstring.substitute_character: No value
    session.hash_bits_per_character: 4
    HTTP_ACCEPT_CHARSET: ISO-8859-1,utf-8;q=0.7,*;q=0.3
    _SERVER["HTTP_ACCEPT_CHARSET"]: ISO-8859-1,utf-8;q=0.7,*;q=0.3
    _ENV["HTTP_ACCEPT_CHARSET"]: ISO-8859-1,utf-8;q=0.7,*;q=0.3
  20. CM Plugins
    Member
    Plugin Author

    Posted 1 year ago #

    We released 2.0.5, please let us know if this made the desired change.

  21. asolis11
    Member
    Posted 1 year ago #

    well at least for my case on the old posts like the one I put here for sample still NOT working correctly but for every new posts I make it seen to be working perfectly which is good for me. I will try to delete the old posts and re-post back again and see if that helps.

  22. RyanLorem
    Member
    Posted 1 year ago #

    It is now working for me.

    I did have to go through and make sure any terms which include apostrophe are using a vertical typewriter apostrophe (') in both the title of the glossary item and the pages which include the term. The closing single quote (’) was still breaking it.

    You can see everything working on this test page:
    http://dreamloan.pro/glossary-terms-check-hover-items/

    Thanks a lot CM. Let me know if you need anything else tested.

  23. CM Plugins
    Member
    Plugin Author

    Posted 1 year ago #

    Good to hear, we will add the The closing single quote (’) to the next release but seems that most of the big issues are behind us :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.