WordPress.org

Ready to get started?Download WordPress

Forums

Global Post Password
[resolved] Global Post Password no longer working? (14 posts)

  1. Josh
    Member
    Posted 1 year ago #

    It looks as though this plugin no longer works with WordPress 3.4. This is a real pain for me, as I maintain a blog/newsletter for a corporate client that uses the plugin. Anyone know of another easy way to keep a bunch of old posts password-protected but relatively easily accessible?

    http://wordpress.org/extend/plugins/global-post-password/

  2. djrpowell
    Member
    Posted 1 year ago #

    Yes I contacted John as well. It seems that the first password still works but all the others do not. I have emailed the issue to John and he was going to see if he can fix it quickly.

    Not heard anything back yet.

  3. djrpowell
    Member
    Posted 1 year ago #

    Hi,

    for samantha0401 I have not heard back yet!

  4. John Blackbourn
    Member
    Plugin Author

    Posted 1 year ago #

    Hi folks,

    Apologies for only now seeing this post (something went wrong with the feed I'd been using for my plugins).

    I'll find some time next week to look into fixing this for 3.4, but it is likely this will be the last update to the plugin unless someone wants to take it over from me.

    John

  5. samantha0401
    Member
    Posted 1 year ago #

    John (and djrpowell) - Thank you! I LOVE this plug-in and if I had any knowledge of what it took to maintain it, I'd help :-) I use the plug-in to password-protect the posts on my family blog that have pictures of my kids - and I loved being able to give the grandparents their own password to make it easier for them to remember!

  6. djrpowell
    Member
    Posted 1 year ago #

    Hi Sam,

    not sure I can help really, it is a great plugin and there is nothing like it. I just hope John can fix it for us.

    Thanks

    Daniel

  7. tlairson
    Member
    Posted 1 year ago #

    Any update on this? I'd love to have the additional passwords working.

  8. John Blackbourn
    Member
    Plugin Author

    Posted 1 year ago #

    Hi all,

    I've just updated the Global Post Password plugin to add support for WordPress 3.4 and the upcoming 3.5.

    The underlying architecture of post passwords changed in WordPress 3.4. This is what caused the plugin to stop working. Although the plugin looks and works the same as it did previously, there are significant changes below the surface. Please let me know how you get on.

    John

  9. djrpowell
    Member
    Posted 1 year ago #

    Hi John,

    That is fantastic, you are a total star, as this is the plugin that everyone needs to make the site a VLE for children in schools.

    I think in fact you could even charge for it!

    Thanks

    Daniel

  10. Josh
    Member
    Posted 1 year ago #

    Not sure what the issue is, but the plugin still doesn't work for me, with either WP 3.4 or 3.5.

    Is it working for anyone else?

  11. Josh
    Member
    Posted 1 year ago #

    Never mind - my site is having password-related problems even without the plugin. My apologies. Thanks, John.

  12. snowkitten
    Member
    Posted 1 year ago #

    I having similar issues with my site Josh. Password just stopped working. You enter the correct password but the pages/posts don't unlock. Have you found a fix for your issue?!

  13. Josh
    Member
    Posted 1 year ago #

    snowkitten, I discovered that when I switched themes (I was using a child theme of Twenty Eleven, then moved to something else entirely), the problem went away. So I assume it's either a conflict within Twenty Eleven or within the child theme I put together myself. But I don't know any more than that. Sorry. :-(

  14. snowkitten
    Member
    Posted 1 year ago #

    Bummer! I definitely have not been using the Twenty Eleven theme, nor have I changed my theme (although I was considering doing so). Perhaps I will try a theme change and see if it begins to work again, or I guess I'll have to go through and deactive my plugins and see if one of their updaets caused the issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic