WordPress.org

Ready to get started?Download WordPress

Forums

Gleam menu not working (4 posts)

  1. hedkandiman
    Member
    Posted 1 year ago #

    Hi,

    I'm having problems getting the menu working on the gleam theme.

    I have added the code to register the nav (below) in both the function.php and header.php files plus Ive set the menu name as 'Primary Menu', but the menu just says 'undefined'.

    function register_main_menus() {
    register_nav_menus(
    array(
    'primary-menu' => __( 'Primary Menu', 'Gleam' )

    Any ideas why it isn't working?

    S

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Are you trying to add or change the menu? I'd guess that the theme already has the menu set up? Maybe this is all you need to do?

    http://codex.wordpress.org/Appearance_Menus_Screen

    Beyond that you'll really need to ask the theme developers - http://www.elegantthemes.com/gallery/gleam/

    We don't have access to commercial themes - so can't really answer any theme specific questions.

  3. hedkandiman
    Member
    Posted 1 year ago #

    I'm trying to add a menu - you're correct, you set up the menu in the appearance menu screen ensuring the menu name is reflected in the code that goes in the two php files.

    Sounds like I'll need to reach out to the theme developers.

    Thanks anyway

    S

  4. Mayur Somani
    Member
    Posted 9 months ago #

    The best option is to post on ET forum. It will be resolved instantly there.

    Update: Here's a solution: Fix Undefined Menu Issue in Gleam WordPress Theme

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.