WordPress.org

Ready to get started?Download WordPress

Forums

Giving WordPress Own Directory StyleSheet issue (8 posts)

  1. jetlej
    Member
    Posted 4 years ago #

    I followed the instructions to give wordpress its own directory perfectly and everything works except for none of the pages are being styled by style.css. Literally everything else works. Any thoughts?

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Site url?

    Did you reference the stylesheet within the theme using something like <link rel="stylesheet" type="text/css" href="<?php bloginfo('stylesheet_url'); ?>" media="screen" />

  3. jetlej
    Member
    Posted 4 years ago #

    pptagents.com

    Yes I did reference the stylesheet using that php function and it worked until I changed the directory

  4. jetlej
    Member
    Posted 4 years ago #

    and the directory I moved wordpress to is 'wpress'

  5. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    The site looks fine to me in FF3.

  6. jetlej
    Member
    Posted 4 years ago #

    In fact, none of my stylesheets are being used and all have correct URL's

  7. jetlej
    Member
    Posted 4 years ago #

    Weird, I just checked it in Safari and it looks good but it has no style in my FF3. Anyways, thanks for your help!

  8. itsfridaymoanin
    Member
    Posted 4 years ago #

    I had the same problem - page would load but no css styles. I found that the <link> tag to reference the stylesheet was referencing "example.com/wp-content/theme..." instead of "example.com/thelocation/wp-content/theme..." Fortunately it's working now, but unfortunately I don't remember exactly what I did to fix it! The last thing I remember doing is changing the preferences back to the way they were originally (just loading the blog at example.com/thelocation with WP Address and WP URL set to example.com/thelocation) and then changing it again to the new way described in the article. I even tried going into the database and editing the wp-options table manually. Sorry, but I guess the best advice I can offer is to just keep fiddling with it....

Topic Closed

This topic has been closed to new replies.

About this Topic