WordPress.org

Ready to get started?Download WordPress

Forums

Gravity Forms Directory
[resolved] GF Directory plugin makes form editing disappear (16 posts)

  1. Bet Hannon
    Member
    Posted 1 year ago #

    When I have the GF Directory plugin acitvated, the form to which it is attached ("Membership in this case) does not appear for editing when I try to go to the form editor. The "standard fields" "advanced fields" etc, all appears in the right column, but nothing the area where I would edit the form.

    When I deactivate the plugin, the form re-appears for editing. Is this supposed to happen? Obviously, there is some sort of conflict....

    What can I do besides deactivating & reactivating the plugin?

    http://wordpress.org/extend/plugins/gravity-forms-addons/

  2. Mike Kohn
    Member
    Posted 1 year ago #

    The same thing is happening to me. When I go to an edit form page (e.g. /wp-admin/admin.php?page=gf_edit_forms&id=1) the page starts loading correctly with all of the form fields appearing in the edit area. Then suddenly right before the page is finished loading, all of the form fields disappear. At the same time, the form name in the switcher dropdown in the top-right corner changes to "Switch Form". I can confirm it's happening in both Firefox & Chrome.

    This must be an error in the javascript since it doesn't happen until late in the loading process. Anybody know of a solution?

    UPDATE: This thread points out where the problem is occurring (it's related to the "Approved" functionality). Waiting for a response/update from the author...

  3. firstep3
    Member
    Posted 1 year ago #

    Actually, this is not just related to the Approved functionality. I have two forms that are NOT using this, and my users cannot go in and edit either form. They are seeing a list of their entries, but when they click the link to go to the Single Entry page, it is completely blank. Again, neither of these forms is using the Approved functionality.

  4. Bet Hannon
    Member
    Posted 1 year ago #

    I hope the plug-in author can get this fixed soon. It is a real pain to have to keep remembering to turn the directory back on every time I do something with the form!

  5. scotthack
    Member
    Posted 1 year ago #

    I was able to view the form again by disabling the plugin. Then going in and deleting the special directory form fields off of the form. Then saving the form. Then reactivating the directory plugin.

  6. Bet Hannon
    Member
    Posted 1 year ago #

    Yes, but having to disable the Directory plugin to view the form means that it's impossible to add Directory fields to my form!

    I'm getting a little frustrated that the developer is not responding here. Does anyone know of any work-arounds?

  7. Bet Hannon
    Member
    Posted 1 year ago #

    Agh! Now, I also have the problem that I need to make a field in the form not display in the directory. I can only see the form field to edit it if Directory is deactivated. But is Directory is deactivated, the option to hide a field in the directory display does not appear!

    Any one know of a work around for this? Can I suppress display of a field through the shortcode?

  8. scotthack
    Member
    Posted 1 year ago #

    Try making a donation to the plugin's author and reaching out to him on his personal site.

  9. Bet Hannon
    Member
    Posted 1 year ago #

    scotthack, I did reach out through his business site support forum and his Twitter account, and offered to make a donation, but since we haven't heard anything from the author in over a month, I'm not willing to donate until I hear he's alive and willing to work on the plugin!

  10. Bet Hannon
    Member
    Posted 1 year ago #

    Ok. I finally resorted to an old-fashioned phone call to Zack. He says he is swamped with other projects, but does intend to eventually get back to updates for the Directory plugin– eventually. It did not sound like this would be happening for a number of months….

    I’m thinking of hiring a coder to work on just my issue– or even just a custom solution for my situation…..

  11. mshetler
    Member
    Posted 1 year ago #

    Strange. I can edit forms I created and populated today. But not the ones I created yesterday.

  12. Bet Hannon
    Member
    Posted 1 year ago #

    @mshetler: The form I'm having issues with is pretty complex, so building it from scratch is not really what I want to do. But I did try exporting & importing the form into a new form on this site, and I still have the problem...

    [I don't know at all if this is related, but since WP3.5, I have a similar issue with Widget Logic Visual -- when activated, it prevents me from opening/editing/creating any widgets, when deactivated, everything is fine. Fortunately, I don't need to set any logic widget right now!]

  13. Bet Hannon
    Member
    Posted 1 year ago #

    Just made a discovery that may help some with this problem!

    I created a new form with the Directory plugin activated WHEN I STARTED the new Gravity Form. It all seems to be working like it should be.

    I'm not able to go back and re-create the large & complicated form for my original client that I started this thread with, but I have with shorter forms.

    Key: if you want to make a directory with this plugin, have it activated when you start the form to gather info!

  14. Cole Geissinger
    Member
    Posted 1 year ago #

    Found where the bug is, but it requires you to update the plugin. The best fix is for the developer to update, but if you can't wait you can run the fix in my comment here http://wordpress.org/support/topic/form-editor-returns-blank-when-adding-approved-option?replies=10#post-3829374

  15. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    This issue should be fixed in 3.4.

  16. ghakaf
    Member
    Posted 1 year ago #

    Although this issue has been fixed when I upgraded to 3.4.1, now I don't see the directory listing on my page any more! The last version that worked was 3.3.1.

    So here is what I'm doing to get around this:
    I edit the form while I'm having the 3.4.1 installed, when I'm finished I revert back to 3.3.1 to be able to show the directory listing on my page.

    I hope this will be fixed soon.

    Thanks for your hard work Zack and everyone involved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.