WordPress.org

Ready to get started?Download WordPress

Forums

Getting started (22 posts)

  1. jabash
    Member
    Posted 6 years ago #

    I set up the options in the options panel, and created a a href link, but nothing displays. Do I need do anything more in the post.

    My website is at http://www.motorcycleramblings.com but the map post is not published.

    http://wordpress.org/extend/plugins/xml-google-maps/

  2. dschuesae
    Member
    Posted 6 years ago #

    The most important thing: the Link in the html-source-code has to be on the same line (from <a>).

    Where exactly ist your Google Maps Post...

  3. jabash
    Member
    Posted 6 years ago #

    I publish it on the post Map Test2 temporarily at http://www.motorcycleramblings.com

    I put some text in the first line just so something show. The next line is

    <a href="http://www.motorcycleramblings.com/gis/Baja 2006 GPS Waypoints.GPX">

    but on one line.

  4. dschuesae
    Member
    Posted 6 years ago #

    OK. Don't use white spaces in filenames. Use only lowercase letters (also for .gpx instead of .GPX). Name your link (between the start an end a-tag), like any other link...

  5. jabash
    Member
    Posted 6 years ago #

    OK, I now get a blank box for the map and a error message telling my the api key is for a different directory. I also get an error message on the post saying javascript must be enabled but I do have it enabled on Firefox.

  6. jabash
    Member
    Posted 6 years ago #

    Another question. Every time I go back to the options panel the api code field state none and the map size field go back to the default values. Yes I am saving the changes.

  7. dschuesae
    Member
    Posted 6 years ago #

    Are you sure, you're using WordPress 2.3.2? Try to reinstall the plugin. There are some really strange behaviours at your page...

  8. jabash
    Member
    Posted 6 years ago #

    OK, I upgraded to 232

    The fields now update when saved, but I still get the api error message on the page.

  9. jabash
    Member
    Posted 6 years ago #

    OK, I got it working, thank you.

  10. jabash
    Member
    Posted 6 years ago #

    Sorry for the many questions but I have been waiting a long time for a plugin like this.

    Some of my file name address run across the line in the WordPress edit box. I cannot shorted the name because of the file directory structure. Does the name have to fit on one line in the edit box or just without a hard line break <br>

  11. dschuesae
    Member
    Posted 6 years ago #

    Without a hard line break and also without a carriage return. But if it breaks because of word wrap, it's ok!

  12. jabash
    Member
    Posted 6 years ago #

    I thought so, but I have one map that is not working. I just get empty space where the map should be and a javascript timeout error.

    It is the first map on this page of my maps
    http://www.motorcycleramblings.com/?page_id=310

  13. balivisual
    Member
    Posted 6 years ago #

    My website is at http://www.balivisual.net, please help me?

  14. dschuesae
    Member
    Posted 6 years ago #

    @jabash:
    Download the latest development version from http://downloads.wordpress.org/plugin/xml-google-maps.zip
    You had an quotation mark in den gpx file (not valid in xml). But I solved it with a small workaround in the plugin!

  15. dschuesae
    Member
    Posted 6 years ago #

    @balivisual:
    I can't help without any idea in what I should help you!!!

  16. m0b1us
    Member
    Posted 6 years ago #

    hello,
    i'm using shared hosting and my domain is http://www.top-review.net.
    here is the schema

    /cashflow24hours.com (root)
    -/top-review.net

    i put the plugin to my wordpress version 2.3.2
    and already register to google api
    my kml path is http://www.top-review.net/maps/kml.kml
    and i activated the plugin and put the link
    <a href="http://www.top-review.net/maps/kml.kml">test</a>
    it got error message

    Warning: fopen(/home/content/c/a/s/cashflow24hour/html/maps/kml.kml): failed to open stream: No such file or directory in /home/content/c/a/s/cashflow24hour/html/top-review.net/wp-content/plugins/xml-google-maps/xmlgooglemaps_kmlParser.php on line 28
    Cannot open XML data file: /home/content/c/a/s/cashflow24hour/html/maps/kml.kml

    the error said cannot open XML data file
    as i seen the error message the correct path should be
    /home/content/c/a/s/cashflow24hour/html/top-review.net/maps/kml.kml
    how to fixed this error?
    thank you very much

  17. dschuesae
    Member
    Posted 6 years ago #

    @m0b1us: I tried to fix this. Download the latest version from http://downloads.wordpress.org/plugin/xml-google-maps.zip

  18. IanM1963
    Member
    Posted 5 years ago #

    Hi,

    I wonder if anyone can help me?

    I have followed the instructions for getting this to work and all that happens is a 404 error. I just don't know what to do. The link to the KML file works but no map shows up?

    Here is the link to the site:

    http://northderbyshirerunningclub.co.uk/blog/?page_id=250

    I have a valid GoogleMaps API key and it works ok.
    I put the link into the page as instructed here.

    Is there anything else I could be doing wrong? I just cannot seem to get it working.

    Help! :-)

  19. IanM1963
    Member
    Posted 5 years ago #

    Aha! I have found out what I was doing wrong. I was manually pasting a link to the URL. It doesn't work unless you use the "Add Media" button in WordPress and add hyperlink there.

    Yes, I'm still getting used to WordPress. Sorry if I caused any confusion!

  20. Technolero
    Member
    Posted 5 years ago #

    I am using wordpress 2.7, have a valid api key, and version 1.10.2 of the plugin. Many people are talking about the options panel, but I am unable to find anything on my dashboard that looks like an options panel for this plugin. It works great, but I have to change the options manually in the code. How do I get the panel? Thanks in advance!

  21. dschuesae
    Member
    Posted 5 years ago #

    Click on Settings and then XML Google Maps...

  22. Technolero
    Member
    Posted 5 years ago #

    Duh. I looked everywhere but there. Thank you very much.

Topic Closed

This topic has been closed to new replies.

About this Topic