WordPress.org

Ready to get started?Download WordPress

Forums

getting rid of "index.php" from url (14 posts)

  1. whealie
    Member
    Posted 5 years ago #

    I have several sites and they just show the domain name as the home page then adds /pagename for the others.

    But one site insists on having/index.php/pagename

    How do I get rid of the /index.php?

  2. Samuel B
    moderator
    Posted 5 years ago #

    is it on a windows or linux server?

  3. whealie
    Member
    Posted 5 years ago #

    linux I think

  4. Samuel B
    moderator
    Posted 5 years ago #

    what is your permalink structure

  5. whealie
    Member
    Posted 5 years ago #

    I cannot edit out the index.php from the permalink - not sure how you edit that.

    That is where the difference bewteen this and my other sites exists.

    in custom, if I delette /index.php part thenthe whole site falls down and I get

    Not Found

    The requested URL /thepub was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Powered By WEBHOSTINGUK Server at thecroftonpub.co.uk Port 80

  6. Samuel B
    moderator
    Posted 5 years ago #

  7. whealie
    Member
    Posted 5 years ago #

    I have been there and tried that.

    Honestly I don't juts post here without first searching the site, so II have seen that page and followed all the instruction to best of my ability but it is not possible to delete the index.php without the whole thing crashing.

  8. adamhouston@gmail.com
    Member
    Posted 5 years ago #

    whealie, I have the same issue and I'm getting frustrated.

    I am trying to set up a new site. I installed 2.7.1 fresh through the host's cpanel. It's on a linux box, not IIS. I have run into the "index.php" permalink issue on IIS servers before, but never on a Linux box. Have not been able to find solution searching google or this site so far.

  9. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    adamhouston@gmail.com What is your URL? What does your htaccess file say?

  10. adamhouston@gmail.com
    Member
    Posted 5 years ago #

    currently the new site's URL: http://www.brickst.com/newsite/
    it will eventually, once finished, be moved to replace the entire site at the root of http://www.brickst.com

    htaccess in root of URL(I guess created by web host?) says:

    # -FrontPage-
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
    
    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName brickst.com
    AuthUserFile /home/brickst/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/brickst/public_html/_vti_pvt/service.grp
    
    RewriteEngine On

    on the .htaccess in /newsite/ directory, I have tried varied code with no positive result. Currently says:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
  11. wigginsdesign
    Member
    Posted 5 years ago #

    I am having this same issue. Did you ever get it solved?

  12. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    What is your URL? Are you on a Windows or Linux server? Are you running your server with WebX like Adam Houston?

    BTW, if you add to an old post it is likely you will receive no answer as it scrolls off the screen and is lost forever in the never heard back group. In the future please open a new post describing your exact problems and details not say I am having the same issue.

  13. wigginsdesign
    Member
    Posted 5 years ago #

    Thanks for the tip. First time to contribute. Here is the URL: http://masterscapes.com/wordpress/index.php/services/propertycare
    Not sure what kind of server it's running on. The client has been hosed with them for a long time (http://www.verio.com/). Any help is appreciated.

  14. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    You are on a Windows server (Microsoft-IIS/6.0) which is most likely the problem.

    Here is some information, http://codex.wordpress.org/Using_Permalinks#Permalinks_without_mod_rewrite

    Can you post your permalink's setting?

    I am not a server guy so hopefully someone will jump in here to assist you.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags