WordPress.org

Ready to get started?Download WordPress

Forums

Single Latest Posts Lite
[resolved] Getting rid of bullet points (14 posts)

  1. MikeGuarino
    Member
    Posted 8 months ago #

    Hello,

    I downloaded the Single Latest Posts Lite plugin this morning and have been tinkering around with it to get it to work correctly on my site. I love it so far, but I was wondering if there is a way to hide the bullet points?

    I am fairly new to editing code and all of that stuff, so I apologize if I don't quite understand what it is that I need to change!

    My URL: http://condemnorcondone.com

    Thanks in advance!

    http://wordpress.org/plugins/single-latest-posts-lite/

  2. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 8 months ago #

    Hi,

    You can tweak plugin's output using CSS. To do so just create a custom CSS style, I've done some quick modifications to the default style to make it look like this: Screenshot. Please download this CSS file: slp-aggregate.css save it to your active WordPress theme folder (/wp-content/themes/Aggregate/) then set Widget Style Settings > Custom CSS Filename: slp-aggregate, that's it.

    I hope this helps,

    Cheers.

  3. MikeGuarino
    Member
    Posted 8 months ago #

    Thanks for the reply, Jose. I downloaded that file, but it saves to my desktop as a .GZ file. Is there something I need to do to this file to save it as a CSS file?

  4. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 8 months ago #

    Hi, Gists files are compressed in .tar.gz check this guide which explains how to unpack those files: How to Open .tar.gz Files. Or you could just copy CSS in raw text then create a new file: slp-aggregate.css raw text

    Let me know if you need more help.

  5. MikeGuarino
    Member
    Posted 8 months ago #

    Excellent! Thanks so much for the help, Jose. Your instructions were helpful and easy to follow, which can be rare when looking for help online. Thanks again!

  6. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 8 months ago #

    I'm glad everything is working now, thank you for your feedback and your kind comments.

    Best regards.

  7. MikeGuarino
    Member
    Posted 8 months ago #

    Hi again,

    I actually just ran into an error. When I try to add more than one of the widgets linked to a separate category, I get a fatal error on my site. If I'm only displaying one everything looks fine, but i'd like to have 3 separate ones because I cover 3 major categories on my site. Any idea why this is happening?

  8. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 8 months ago #

    Hello, could you please tell me or take a screenshot of the fatal error? What does it say? I've tested using 3 widgets as well and it's working as expected. Have you set categories slugs instead of names? (slugs don't contain any spaces and they're lowercase).

  9. MikeGuarino
    Member
    Posted 8 months ago #

    Sure thing, here is what it says at the bottom of the page.

    Fatal error: Cannot redeclare filter_where() (previously declared in /home4/mguarino/public_html/wp-content/plugins/single-latest-posts-lite/single-latest-posts.php:1171) in /home4/mguarino/public_html/wp-content/plugins/single-latest-posts-lite/single-latest-posts.php on line 1171

  10. MikeGuarino
    Member
    Posted 8 months ago #

    Also, to answer your other question, I don't have the slugs as the category names. Each category name is set as the actual name of the category.

  11. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 8 months ago #

    Yay!.. You've discovered a bug, it's my fault as I didn't test using time frames which creates the filter_where() function, it works for the first instance but then as the function already exists it fails when trying to create the same function again. I forgot to check if function existed to avoid duplicating it which caused the fatal error.

    I've uploaded version 1.4.2 which hopefully fixes this issue, please update to the latest version and let me know if it solves the problem.

  12. MikeGuarino
    Member
    Posted 8 months ago #

    Hah! The update has made all of the widgets display normally and my site has gone back to normal! Yay! Great job, Jose!

    There is just one more thing that I was wondering about, and it's the title bar.

    On all of my other widgets, the title of the widget is displayed in a red bar with bold white text, though with this widget it is just displaying regular text with no title bar. Do you have any ideas on why that is?

  13. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 8 months ago #

    That's also a styling issue, I've copied your theme widget titles' CSS rules and added them to the slp-aggregate.css file, just download the latest version and replace the one in your folder. Here you can see them:

    background: rgba(255, 0, 0, 1.80);
      height: 42px;
      line-height: 42px;
      text-transform: uppercase;
      font-weight: bold;
      text-align: center;
      padding-bottom: 0;
      font-family: 'Droid Sans',Arial,Verdana,sans-serif !important;
      text-shadow: none;
      font-size: 16px !important;
      color: #ffffff !important;

    Single Latest Posts Wrapper Titles classes are these:

    .slposts-block-wtitle {} // Blocks
    .slposts-ulist-wtitle {} // Unordered Lists
    .slposts-olist-wtitle {} // Ordered Lists

    Cheers.

  14. MikeGuarino
    Member
    Posted 8 months ago #

    Jose, I cannot thank you enough for all the help you have given me today. Everything looks fantastic, so I can stop bugging you now!

    Thanks again and have a great week!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.