WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] getting php error after updating (13 posts)

  1. WordProSystems
    Member
    Posted 6 months ago #

    hello. this morning i attempted to do the manual update for wordpress. i backed my files up before doing anything but all i got after updating was a blank white screen. i tried putting everything back to how it was but to no avail - still got a blank white screen. i checked the error log files and this was the latest one:

    [Fri Jan 24 10:26:13 2014] [error] [client 149.169.213.0] PHP Warning: require(): SAFE MODE Restriction in effect. The script whose uid is 10015 is not allowed to access /var/www/vhosts/stlouiscityseniors.com/httpdocs/wp-includes/load.php owned by uid 0 in /var/www/vhosts/stlouiscityseniors.com/httpdocs/wp-settings.php on line 21
    [Fri Jan 24 10:26:13 2014] [error] [client 149.169.213.0] PHP Warning: require(/var/www/vhosts/stlouiscityseniors.com/httpdocs/wp-includes/load.php): failed to open stream: Inappropriate ioctl for device in /var/www/vhosts/stlouiscityseniors.com/httpdocs/wp-settings.php on line 21
    [Fri Jan 24 10:26:13 2014] [error] [client 149.169.213.0] PHP Fatal error: require(): Failed opening required '/var/www/vhosts/stlouiscityseniors.com/httpdocs/wp-includes/load.php' (include_path='.:') in /var/www/vhosts/stlouiscityseniors.com/httpdocs/wp-settings.php on line 21

    can anyone please help translate this? i am not a programmer by any means and i would truly appreciate any guidance.

    thank you!!

  2. esmi
    Forum Moderator
    Posted 6 months ago #

    SAFE MODE Restriction in effect.

    Looks like a server issue. Try disabling safe mode on your server.

  3. WordProSystems
    Member
    Posted 6 months ago #

    i'm sorry, but what does that mean?

  4. esmi
    Forum Moderator
    Posted 6 months ago #

    Try asking your hosts about it.

  5. congnghevps
    Member
    Posted 6 months ago #

    Open tickets and request your hosting provider turn off safe mode of php. Safe mode help your site have more security, but now don't need :)

  6. WordProSystems
    Member
    Posted 6 months ago #

    i guess what i don't understand is nothing else changed except i tried to update the version of WordPress. we host the servers here locally in our shop, i just don't understand why this happened. any ideas?

  7. WordProSystems
    Member
    Posted 6 months ago #

    and we did turn off the Safe Mode setting and still nothing. we use Parallels for our hosting platform (is that the correct verbage?) i am completely out of ideas, i have spent days researching and it's even more frustrating because it seems like the people that have found solutions to similar problems are well-versed in programming language. i simply am not. i am truly grateful for all the help you all give, but maybe if someone can contact me directly to lend a hand i don't know what else to do. this seemed like such a simple process!

    this morning i re-downloaded the latest version of WordPress and tried re-intalling it manually but nothing changed--i keep getting the same error messages in the log files.

  8. gameutopia
    Member
    Posted 6 months ago #

    Find your php directory, and open your php.ini file.

    Look for:
    safe_mode = On

    Change it to:
    safe_mode = Off

    Save the changes.

    Restart your server Apache or what have you for the changes to take effect.

    Make sure you edit/change the right php.ini file. Some setups have more than one location.

  9. WordProSystems
    Member
    Posted 6 months ago #

    dang. i thought we were on to something, but i'm still getting the exact same errors.

    i am fairly for certain i am in the correct php.ini file, because i went to (my domain).com/wp-admin/info.php and it said where the php.ini file was located, and sure enough, the safe mode was set to on, so i did what you suggested. i'm still getting the safe mode restriction error as well as the other two that i originally posted. :(

  10. gameutopia
    Member
    Posted 6 months ago #

    It appears that your wp-includes/load.php and/or wp-settings.php may have a file ownership/permission problem.

    I am not sure what kind of setup you have but if you can re-upload the above mentioned to files as the actual user of that account that might solve your problem.

    Either change/set those files to match the account name/holder, or rename them like wp-includes/load-backup.php and wp-settings-backup.php.

    Then, login as the actual account holder and re-upload them so they will be owned by that account.

    You might also double check other files and folders to make sure they are owned by that actual account/user.

  11. WordProSystems
    Member
    Posted 5 months ago #

    ok, i will try that this morning. do you know how typically the permissions should be setup? i think those files are setup at 0775, is that ok do you think?

  12. esmi
    Forum Moderator
    Posted 5 months ago #

    Files should usually be 644 and folders 755

  13. WordProSystems
    Member
    Posted 5 months ago #

    gameutopia - i could kiss you!!!

    i finally got my site back up! i looked at one of our other sites we're hosting, looked at how the owner is set up, same with permissions, i made all the changes necessary to get the owners to match, and when i went to test the site i got a "error establishing database connection" and it told me to check he wp-config file. sure enough the credentials were for another site we're hosting. i'm not sure why it pulled those credentials but i checked that wp-config file against the wp-config file in the backup i made (whew, thank god i did that!) and i made them match.

    long story short, my site is up! to everyone that contributed and helped me get through this mess, i thank you from the bottom of my heart!!!

    you guys are the best!!!

Reply

You must log in to post.

About this Topic